Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Starcraft doesn't work...


12 Jan 2009   #11

Windows 7
 
 

Yea this problem is just weird.... I tried googling around, but there are no results about "font.grid" and Starcraft...


My System SpecsSystem Spec
.

13 Jan 2009   #12

 

And yet another user has reported that Starcraft works....
My System SpecsSystem Spec
13 Jan 2009   #13

WIndows 7/Vista/Ubuntu/Fedora
 
 

I wonder if the file trying to be found is part of the windows directory. I'm off to search around for it there. You might try asking on a couple of the Blizzard forums and Starcraft fansites too.

Dunno.
My System SpecsSystem Spec
.


13 Jan 2009   #14

Windows 7 Ult x64(x2), HomePrem x32(x4), Server 08 (+VM), 08 R2 (VM) , SuSe 11.2 (VM), XP 32 (VM)
 
 

nope your disc might just be scratched it tried to install, finished and now has a corrupted file....

you are not going to find that file anywhere since its in one file "think of it as one big zip file"

i had the same problem once and it was fixed by downloading it installing using the the lastest patch which will let you have the setup.exe in the startcraft directory without the cd and play it....
My System SpecsSystem Spec
13 Jan 2009   #15

Windows 7
 
 

The thing is, these discs install perfectly and the game runs perfectly on two other computers, and when I tried to install the game from the installer I downloaded from the blizzard store, it still gives me the same error. I am using the updated version of SC as well.
My System SpecsSystem Spec
13 Jan 2009   #16

Windows 7 Beta 1 b7000
 
 

Ok, I gather you've successfully installed it, but you can't get it to run. Is that right?

If so, have you tried running the game in compatibility mode as well, not just at the install? You'd follow the same instructions provided above for the install. Right-click the game's shortcut, properties, compatibility tab.
My System SpecsSystem Spec
13 Jan 2009   #17

Windows 7
 
 

Yea, I had it running in compatibility mode.
My System SpecsSystem Spec
13 Jan 2009   #18

Windows 7 Beta 1 b7000
 
 

Try following these instructions:
Quote:
Windows Users:
- Make sure you have "Hide extensions for known types" unchecked. To do this please use the following steps:
- Click Start -> Programs -> Accessories -> Windows Explorer
- Click on Tools -> Folder options (Windows Vista users may have to press the Alt key to see the tools option at the top of the window)
- Click on the View Tab In the list, look for the "Hide extensions for known file types" option, and make sure that it is unchecked.
- Click OK to save the changes.
- Now you will need to copy some files from the Game CDs

- If you own only StarCraft, copy "INSTALL.EXE" from the StarCraft CD to your StarCraft folder and rename it to "StarCraft.mpq".

- If you own StarCraft: Brood War, copy "INSTALL.EXE" from the StarCraft: Brood War CD to your StarCraft folder and rename it to "BroodWar.mpq".
**If you wish to play the StarCraft original missions then please copy and rename the install file from the original StarCraft CD as well, as listed directly above.

Mac users:
- If you own only StarCraft, copy "StarCraft Archive" from the StarCraft CD to your StarCraft/StarCraft Files/ folder.
- If you own StarCraft: Brood War, copy "Brood War Archive" from the StarCraft: Brood War CD to your StarCraft/StarCraft Files/ folder. If you wish to play the StarCraft original missions then please copy the Starcraft Archive file from the original StarCraft CD as well, as listed directly above.
I'm thinking the file it's looking for is in the exe/mpq file and following the above might fix it?
My System SpecsSystem Spec
13 Jan 2009   #19

Windows 7
 
 

OK, I had some of my friends come over and to help deal with the problem... and they managed to fix it... by disabling Compatibility Mode... it screws up the color but it at least works. I had to INSTALL in compatibility mode in order for the game to be able to be updated, but not run the game in compatibility mode. It's weird, but thanks for the help.
My System SpecsSystem Spec
13 Jan 2009   #20

WIndows 7/Vista/Ubuntu/Fedora
 
 

Schweet!
My System SpecsSystem Spec
Reply

 Starcraft doesn't work...




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 11:11 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33