Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Starcraft doesn't work...

12 Jan 2009   #11
Am3692

Windows 7
 
 

Yea this problem is just weird.... I tried googling around, but there are no results about "font.grid" and Starcraft...


My System SpecsSystem Spec
.
13 Jan 2009   #12
johngalt

 

And yet another user has reported that Starcraft works....
My System SpecsSystem Spec
13 Jan 2009   #13
STormdce

WIndows 7/Vista/Ubuntu/Fedora
 
 

I wonder if the file trying to be found is part of the windows directory. I'm off to search around for it there. You might try asking on a couple of the Blizzard forums and Starcraft fansites too.

Dunno.
My System SpecsSystem Spec
.

13 Jan 2009   #14
darkassain

Windows 7 Ult x64(x2), HomePrem x32(x4), Server 08 (+VM), 08 R2 (VM) , SuSe 11.2 (VM), XP 32 (VM)
 
 

nope your disc might just be scratched it tried to install, finished and now has a corrupted file....

you are not going to find that file anywhere since its in one file "think of it as one big zip file"

i had the same problem once and it was fixed by downloading it installing using the the lastest patch which will let you have the setup.exe in the startcraft directory without the cd and play it....
My System SpecsSystem Spec
13 Jan 2009   #15
Am3692

Windows 7
 
 

The thing is, these discs install perfectly and the game runs perfectly on two other computers, and when I tried to install the game from the installer I downloaded from the blizzard store, it still gives me the same error. I am using the updated version of SC as well.
My System SpecsSystem Spec
13 Jan 2009   #16
renthor

Windows 7 Beta 1 b7000
 
 

Ok, I gather you've successfully installed it, but you can't get it to run. Is that right?

If so, have you tried running the game in compatibility mode as well, not just at the install? You'd follow the same instructions provided above for the install. Right-click the game's shortcut, properties, compatibility tab.
My System SpecsSystem Spec
13 Jan 2009   #17
Am3692

Windows 7
 
 

Yea, I had it running in compatibility mode.
My System SpecsSystem Spec
13 Jan 2009   #18
renthor

Windows 7 Beta 1 b7000
 
 

Try following these instructions:
Quote:
Windows Users:
- Make sure you have "Hide extensions for known types" unchecked. To do this please use the following steps:
- Click Start -> Programs -> Accessories -> Windows Explorer
- Click on Tools -> Folder options (Windows Vista users may have to press the Alt key to see the tools option at the top of the window)
- Click on the View Tab In the list, look for the "Hide extensions for known file types" option, and make sure that it is unchecked.
- Click OK to save the changes.
- Now you will need to copy some files from the Game CDs

- If you own only StarCraft, copy "INSTALL.EXE" from the StarCraft CD to your StarCraft folder and rename it to "StarCraft.mpq".

- If you own StarCraft: Brood War, copy "INSTALL.EXE" from the StarCraft: Brood War CD to your StarCraft folder and rename it to "BroodWar.mpq".
**If you wish to play the StarCraft original missions then please copy and rename the install file from the original StarCraft CD as well, as listed directly above.

Mac users:
- If you own only StarCraft, copy "StarCraft Archive" from the StarCraft CD to your StarCraft/StarCraft Files/ folder.
- If you own StarCraft: Brood War, copy "Brood War Archive" from the StarCraft: Brood War CD to your StarCraft/StarCraft Files/ folder. If you wish to play the StarCraft original missions then please copy the Starcraft Archive file from the original StarCraft CD as well, as listed directly above.
I'm thinking the file it's looking for is in the exe/mpq file and following the above might fix it?
My System SpecsSystem Spec
13 Jan 2009   #19
Am3692

Windows 7
 
 

OK, I had some of my friends come over and to help deal with the problem... and they managed to fix it... by disabling Compatibility Mode... it screws up the color but it at least works. I had to INSTALL in compatibility mode in order for the game to be able to be updated, but not run the game in compatibility mode. It's weird, but thanks for the help.
My System SpecsSystem Spec
13 Jan 2009   #20
STormdce

WIndows 7/Vista/Ubuntu/Fedora
 
 

Schweet!
My System SpecsSystem Spec
Reply

 Starcraft doesn't work...




Thread Tools




Similar help and support threads
Thread Forum
My bluetooth doesn't work. bttray doesn't open.
Hello. I am quite new here, but I've been wanting to get this problem solved for a long time, and I haven't seemed to get any answer. So here's my problem: I bought my Asus N53SV for around a year ago, and it worked great. But for some reason something changed. When I try to open bluetooth,...
Software
Starcraft (original) doesn't re-size.
Ok so I just installed a new EVGA 750i motherboard with a new EVGA Superclocked 8800 GT, I have a 19" monitor with a native resolution of 1440x900 (16:9 aspect ratio) on my computer and when I try to play starcraft it re-sizes itself so that I have 2 big black lines on the side of my screen...
Gaming
HELP: power option doesn't work - screen saver doesn't start!
I have an ASUS notebook running windows 7 64-bit. I am using the QuietOffice power profile, however the screensaver won't kick in no matter what I do, and the display does not turn off even though I set it to be after 5-minutes of inactivity. I don't know if there is something running in the...
General Discussion
Doesn't Seem to work
i have looked over the forums and followed every direction to a tee.... but for some reason the themes i download and stuff don't work. my windows look either goes to classic or the text is a different color.. you probably get this alot and what not from noobs but a nice direction towards some...
Customization
LIBusb, USB ports doesn't work. Safe mode also no work
After I install LIBusb I could work futher. But after I put him off en reboot an hour later my wired mouse en keyboard didn't work anymore. When I restart in safe mode both still doesnt work. OS: W7 Home Premium 64b Computer: HP Pavilion p6250 Please Help!!
Drivers
Win 7 doesn't... work??
Hi, first, sorry if my english is bad, i'm french. I have installed Win 7 since a few time and .. it doesn't work at all. First, I haven't got transparency, "aero" seems not to be launched. Moreover, Windows Update doesn't work, I've an error message (not the MSI problem, an error which...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:36.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App