Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Starcraft doesn't work...

11 Jan 2009   #1
Am3692

Windows 7
 
 
Starcraft doesn't work...

Problem fixed: Install game in Compatibility mode, but run the game normally (no compatibility mode). Thanks for the help STormdce and renthor

I got this error message, did a reinstall, but it did no good...

Quote:
Starcraft was unable to open a required file. If this problem persists, try uninstalling and reinstalling Starcraft using the program SETUP.EXE on the Starcraft CD-ROM.

The problemoccured while tring to load a file
font\font.grid
The system cannot find the file specified.
And when I try repatching it, it says
Quote:
The patch could not be applied because it does not match the file checksum.This problem can usually be corrected by uninstalling and reinstalling the game and then patching again.

File name: ------\Starcraft\StarEdit.exe
Any ideas?

Thanks
Am3692


My System SpecsSystem Spec
.
12 Jan 2009   #2
STormdce

WIndows 7/Vista/Ubuntu/Fedora
 
 

Well, you should be able to run it normally. I have it on two comps running win7. This sounds like a pretty common error tho. When is the error happening? Oddly enough I can't find that.grid file in my directory at all...

Do you have BroodWar?

You also might want to try installing with the Compatibility Mode
My System SpecsSystem Spec
12 Jan 2009   #3
Am3692

Windows 7
 
 

I am using Brood War, and the first error comes up when I try and run the game. I will try reinstalling a bit later, but how do you install with the Compatibility Mode?
My System SpecsSystem Spec
.

12 Jan 2009   #4
STormdce

WIndows 7/Vista/Ubuntu/Fedora
 
 

"To install using Compatibility Mode, right click on the Setup Application Stub (usually titled Setup.exe or whatever program you are opening to install the driver) and click on Properties, and then click on the Compatibility tab, enable Compatibility Mode and select the version of windows you originally installed the program on from the drop down list, then click on OK and try again."

SC came out in 98, so this may be a good chance to see how far back the mode works...

Also, try using the INSTALL.EXE on the SC disk instead of the SETUP.EXE dunno why it would be any different, but worth a shot.
My System SpecsSystem Spec
12 Jan 2009   #5
Am3692

Windows 7
 
 

OK tried reinstalling using compatibility, I still get the same error. Does SC work for you?
My System SpecsSystem Spec
12 Jan 2009   #6
renthor

Windows 7 Beta 1 b7000
 
 

StarCraft works fine here. I tried using one of the 3rd party launchers to get to launch in windowed mode (as I use a widescreen monitor, and StarCraft is NOT widescreen friendly) and I got that error. But when I launch it without the 3rd party launcher (i.e. a vanilla install) it works fine. Are you using the latest version of StarCraft?
My System SpecsSystem Spec
12 Jan 2009   #7
Am3692

Windows 7
 
 

Yea, patched it, but it still doesn't work. It's an improvement now that I can patch the game, but still getting that weird error. Does using 64bit cause any issues? I used Windows Vista Ultimate 64bit before and it worked fine. Also, I am using the Battle Chest, if that matters.
My System SpecsSystem Spec
12 Jan 2009   #8
STormdce

WIndows 7/Vista/Ubuntu/Fedora
 
 

Its working fine on mine too... I'm using the 64 bit version. I'm using downloaded copies of both games tho. Installed with a cd emulator. Can you try the install outside of win 7 to make sure its not your copy?
My System SpecsSystem Spec
12 Jan 2009   #9
Am3692

Windows 7
 
 

I installed it before on a Vista before upgrading, and also worked on installing on a virtual machine (emulating XP) and an XP laptop, both works fine.
My System SpecsSystem Spec
12 Jan 2009   #10
STormdce

WIndows 7/Vista/Ubuntu/Fedora
 
 

Well, then im fresh out of ideas on this one... Ill keep thinking though.
My System SpecsSystem Spec
Reply

 Starcraft doesn't work...




Thread Tools




Similar help and support threads
Thread Forum
My bluetooth doesn't work. bttray doesn't open.
Hello. I am quite new here, but I've been wanting to get this problem solved for a long time, and I haven't seemed to get any answer. So here's my problem: I bought my Asus N53SV for around a year ago, and it worked great. But for some reason something changed. When I try to open bluetooth,...
Software
Starcraft (original) doesn't re-size.
Ok so I just installed a new EVGA 750i motherboard with a new EVGA Superclocked 8800 GT, I have a 19" monitor with a native resolution of 1440x900 (16:9 aspect ratio) on my computer and when I try to play starcraft it re-sizes itself so that I have 2 big black lines on the side of my screen...
Gaming
HELP: power option doesn't work - screen saver doesn't start!
I have an ASUS notebook running windows 7 64-bit. I am using the QuietOffice power profile, however the screensaver won't kick in no matter what I do, and the display does not turn off even though I set it to be after 5-minutes of inactivity. I don't know if there is something running in the...
General Discussion
Doesn't Seem to work
i have looked over the forums and followed every direction to a tee.... but for some reason the themes i download and stuff don't work. my windows look either goes to classic or the text is a different color.. you probably get this alot and what not from noobs but a nice direction towards some...
Customization
LIBusb, USB ports doesn't work. Safe mode also no work
After I install LIBusb I could work futher. But after I put him off en reboot an hour later my wired mouse en keyboard didn't work anymore. When I restart in safe mode both still doesnt work. OS: W7 Home Premium 64b Computer: HP Pavilion p6250 Please Help!!
Drivers
Win 7 doesn't... work??
Hi, first, sorry if my english is bad, i'm french. I have installed Win 7 since a few time and .. it doesn't work at all. First, I haven't got transparency, "aero" seems not to be launched. Moreover, Windows Update doesn't work, I've an error message (not the MSI problem, an error which...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:00.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App