Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Games Stopped Working at Splash Screen

04 Sep 2011   #11
seth500

Windows 7 Ultimate x64
 
 

OK Dean sounds good..


My System SpecsSystem Spec
.
04 Sep 2011   #12
Deanos63

Windows 7 64bit
 
 

I just brought the CPU back down to 3.1GHz and I still am getting the same issues.

I also agree the problem seems to be with the ATi driver but I have done a complete reinstall of the drivers etc. so I can't see why that would be a problem? But everything seems to be pointing towards that?

My head is hurting, I'm going to bed for now will resume this tomorrow afternoon.

One more thing, I did a SFC Scan and found errors it couldn't fix, I have attached the log, maybe that may help shed some light. My analysis of it, after searching for "cannot repair" 4 came up all with the UIautomationcore.dll file. Now this may be normal, it may not, once again my technical knowledge stops there. Maybe you may have some thoughts on this?

Regards
My System SpecsSystem Spec
05 Sep 2011   #13
Deanos63

Windows 7 64bit
 
 

Ok, So I went for the display driver approach. I completely removed all my current display drivers and software, restarted in safe mode ran driver sweeper and removed all the remaining files.

I downloaded ATi 11.2, which is the driver package used back at the beginning of the year, because this is when I knew my games worked perfectly, so my theory was if they ran with these drivers then they should run now with those drivers.

This has failed, I have the same problem even with well out dated drivers that I knew worked before.

So I don't think it is the display drivers specifically.

When in the menu to select safe mode, I noticed I had a windows memory diagnostic tool, so I have also given that a run and it passed all tests. (not really sure what it was testing).

I have also uninstalled drivers for my gamepad as that has been installed recently, so has my mouse but have decided to leave that alone as I need it at the moment.

In all of my minidumps I have :- ERROR: Symbol file could not be found. Defaulted to export symbols for ntdll.dll, not sure if this is significant?

going to and cry now
My System SpecsSystem Spec
.

05 Sep 2011   #14
seth500

Windows 7 Ultimate x64
 
 

Hey Dean how many times did you run the sfc /scannow? Sometimes it takes a few times to fix bad errors. When you run a search for the UIAutomationCore.dll does it show up?
My System SpecsSystem Spec
05 Sep 2011   #15
Deanos63

Windows 7 64bit
 
 

Hi Seth,

Ran it only a couple of times, will give it more.

That file shows up in the log I attatched in the above post. I can find it on my pc, I think I deleted it and it came back after a reboot with a padlock next to it. I can't check for sure at the moment as I am running memtest86+ at the moment to eliminate bad memory sticks.

When that is done I shall give sfc /scan a few more tries.

Thanks Seth, your being a great help.
My System SpecsSystem Spec
05 Sep 2011   #16
Deanos63

Windows 7 64bit
 
 

UIAutomationCore.dll is in system32 and FSX folder.

I ran Memtest86 and it passed with no errors found.

Is chkdsk different to sfc /scannow? and if it is would it be worth running that? and how?

also if I enter the screen where I can select safemode on boot up, I have options to run windows repair etc? If i run a repair will I lose any data?
My System SpecsSystem Spec
05 Sep 2011   #17
seth500

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by Deanos63 View Post
UIAutomationCore.dll is in system32 and FSX folder.

I ran Memtest86 and it passed with no errors found.

Is chkdsk different to sfc /scannow? and if it is would it be worth running that? and how?

also if I enter the screen where I can select safemode on boot up, I have options to run windows repair etc? If i run a repair will I lose any data?
>You run chkdsk by opening a command prompt and typing either chkdsk /f which is the quick repair most people use or chkdsk /r which is the long repair which checks for bad sectors as well on the disk. It can take a while depending on the size of the disk.

>Running a windows repair from that mode is safe and you will not lose any data. You can do those it most definitely wouldn't hurt.

What I would like to do is replace that UIAutomationCore.dll with the version of windows that you have is it professional, ultimate, ect?
My System SpecsSystem Spec
05 Sep 2011   #18
Wishmaster

Windows 7 Home Premium 64bit
 
 

Have you tried updating your DirectX as well?


The dll seems to be corrupt and can not be repaired.
If Im not mistaken, this will close a game if it thinks theres a problem, such as memory errors etc.
So if its corrupt, it will likely always cause a issue.

Assuming the CPU/RAM/GPU etc has all tested good, it would be pretty safe to say its not a hardware issue.


You may try booting into safemode and attempt the repairs again.
A repair install wouldn't hurt either.


If the file can not be repaired, it will need to be replaced. Which will require some extra effort. Because they can not be deleted by default.



--Do you happen to have a system image somewhere? Or possibly a system restore point?
A image prior to the problem would be ideal.
My System SpecsSystem Spec
05 Sep 2011   #19
Deanos63

Windows 7 64bit
 
 

I have Windows 7 Home Premium 64bit.

Just to let you know there is a small padlock next to the UIAutomationCore.dll in system32, not sure if that makes a difference.

@Wishmaster So far all the burn in tests and the memtests have not produced any errors, plus I'm not getting any crashes any other times, so hopefully it isn't a hardware fault.

I have tried to re-install direct x 11, however the installer from the microsoft site will not overwrite the one on my system as it is the most up to date.

I will continue with a chkdsk and and possible try it in safemode, along with another go at sfc /scannow in sfaemode.

I have 3 HDD, the windows operating system is on a 60GB SSD, I'm assuming I just check that disk, see as that has the system files on it?

Cheers for your help
My System SpecsSystem Spec
05 Sep 2011   #20
seth500

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by Wishmaster View Post
Have you tried updating your DirectX as well?


The dll seems to be corrupt and can not be repaired.
If Im not mistaken, this will close a game if it thinks theres a problem, such as memory errors etc.
So if its corrupt, it will likely always cause a issue.

Assuming the CPU/RAM/GPU etc has all tested good, it would be pretty safe to say its not a hardware issue.


You may try booting into safemode and attempt the repairs again.

If it can not be repaired, it will need to be replaced.
Which may possibly mean a repair/re-install.
Wishmaster it could not be replaced then if you took ownership of it renamed it then replaced it with the original from the dvd disk of windows?
My System SpecsSystem Spec
Reply

 Games Stopped Working at Splash Screen




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Windows installer has stopped working or setup.exe has stopped working
HI, I'VE INSTTALED WINDOWS 7 PROF.ON MY PC. I M TRYING TO INSTALL WINDOWS7ULTIMATE BY CLICKING ON SETUP.EXE AN ERROR MASSAGE APPEARED SAYING: THEN I TRIED TO INSTALL WINDOWS 8 ON MY PC.. BUT THE ERROR MASSAGE APPEARED SAYING SAME THING AND ALL OTHER SETUP IN THAT DRIVE ARE SAYING SAME...
General Discussion
my screen saver stopped working
Normally set to photos and the other day it wasn't working but still set a usual. I mean I haven't changed it in months. I've checked and it's still set, I've shut down, run virus scan, disc cleanup, What's up? anyone have an idea or can help me?
Performance & Maintenance
Multiple games stopped working on start up (BEX error)
Hi! I keep getting the BEX error with multiple games. It's really weird how they occur. Sometimes they do and sometimes they don't. The first time I got that error was when I installed the game called "Omerta - City of Gangsters". Now I get this error on games like "Smite", "Fifa 13", "Age of...
Gaming
Freezes after several minutes in 3D games [*.exe stopped working]
Hello, everyone. I have got a small problem. I checked various forums and other sources of information, and though I found many description of similar problems, they all are a bit different from my case and no solution provided there worked for me. ...
Gaming
Windows boot splash screen not working in W7 Pro
Hi all I had to do a "Windows repair" boot on a W7 X-86 W7 Pro machine. Now when I boot it up I get the boring "Vista" like blank screen with the Microsoft Bar instead of the nice "W7 Windows starting " with the spinning W7 cube. It's not a major issue but is this "fixable" easily. ...
Installation & Setup
Program stopped working message in games
Hi, Since I installed win 7 ultimate x86 I started having troubles with my games. All games that I've been playing have tendency to crash. There is no set time, sometimes it's 3 hours, sometims one and sometimes there's a crash after 5 minutes. The game just shut itself down and message "program...
Gaming


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:42.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App