Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: DOOM3 - Windows 7

04 Apr 2009   #11

windows 7

i have a problem running doom3 in windows 7.. it runs fine except it kinna does the matrix glitch thing. where it jumps and says the same thing twice. weird.

my keyboard will become unresponsive after a few minutes of bein in the game. the game runs fine up to this point.
then.... i will be stuck moving foward, backward, or in a strafe, whichever i was doing when it went unresponsive. the only thing the keyboard will do is espape to the menu. i cant reload, jump, crouch or anything.... im on windows 7 7057 32bit. radeon x1650. basic compaq keyboard.

My System SpecsSystem Spec
04 Apr 2009   #12

Windows 7 (7127)

I still lan with d3, works great for me. Could you give me some system specs? Version of d3 are you running? Driver Version?
My System SpecsSystem Spec
01 Jun 2009   #13

7 RC

If you can stand running it in windowed mode modify your doom3 config located in the /base/ directory and switch off the full screen option.

This removed the flicker for me

oh and @previous poster with all the BUY THE GAME nonsense.

I did, and it was this bought version updated one update at a time and it still flickered.
My System SpecsSystem Spec

01 Jun 2009   #14

Windows 7 Professional x64 RTM

I used this solution a week or so ago with Doom 3 and other older OpenGL-based games.
It involves using a RivaTuner tweak.
You can download RivaTuner here.

Windows 7 with opengl (CS 1.6)
This fixed the flickering lines when running OpenGL games fullscreen.
My System SpecsSystem Spec
01 Jun 2009   #15

Windows 7 RC1 (7100) / Windows XP SP3 dual-boot

You might also try the disable desktop composition/compositing/whatever compatibility mode - I heard that Aero can hose OpenGL apps.
My System SpecsSystem Spec
21 Jul 2009   #16

windows 7


I got it to work but its slow when playing the game wat would cause this?

I dont get any lines or anything and seems to run well on the title screen and story but playing the game just a bit slow.

I have at lead 2000gb mem and processor speed is 3000mhz so cant b that.
My System SpecsSystem Spec
21 Jul 2009   #17

Windows 7 Professional 64-bit

You could try checking the nvidia control panel and setting things to performance rather than quality. Read each entries description and everytime it mentions performance, use that setting.
My System SpecsSystem Spec
21 Jul 2009   #18
Orbital Shark


+1 swafega

Welcome to the forums lisa01707,

There is also the in-game 'System' settings that allow you to 'Autodetect' visual capabilities. I've noticed that when the game first runs it doesn't quite detect correctly so can lead to some performance lag.
My System SpecsSystem Spec
21 Jul 2009   #19

windows 7


I will try this, I also notice when I play DVD's there is a performance lag as well so couldn it be more than just the game?
My System SpecsSystem Spec
22 Jul 2009   #20

windows 7

I tried the performance thing and putting gane on low quality and still the lag is there, what shld i do now?
My System SpecsSystem Spec

 DOOM3 - Windows 7

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:03.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App