Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Frequent frame rate dips

10 Nov 2011   #1

Windows 7 Ultimate 32bit
 
 
Frequent frame rate dips

Hi chaps!

I've been having problems with frame rate dips when playing games - I've monitored my FPS on L4D1/2 and Alien Storm and it drops for the usual 60fps to around 20, sometimes down to the low teens. It doesn't seem to be tied into what's going on on screen, although when it dips and then lots of stuff happens on screen, that's when it dips really low.

I haven't noticed any changes when using Windows 7 at other times, and when I check task manager/resource monitor, I'm not seeing any spikes in CPU or RAM usage, when I've got say chrome, outlook and steam running. The biggest Windows resource running is an svchost that is about 60-70MB, and it looks like superfetch is the main user of RAM here. CPU use is pretty much normal.

I used Real Temp to check the heat when playing L4d2, and it said the max temp was around 75 (I think), so don't think it can be a temp problem. My PC is pretty near a radiator, but the air coming out of the fan is cool and the case itself is cool and the area/air around it isn't hot at all. I have a 350w PSU, and I think the 5670 recommends a 400w supply, but have been told that shouldn't be an issue.

I've uninstalled (through device manager, not removed it etc) my HD5670 and reinstalled it, uninstalled the Catalyst Control Centre and it makes no difference. The only things I can think have happened to the PC since I last played it a week ago (and it was working fine then) has been some installation of some windows updates on 9/11/11 and I played Alien Breed 2 for the first time and I think that may have done something to the Direct X, as some games do when they first boot. I uninstalled the updates from 9/11/11 and that made no difference either!

If anybody can can suggest any possible solutions, I'll be very grateful!

Thanks in advance!

My System SpecsSystem Spec
.

11 Nov 2011   #2

Windows 7 Ultimate 32bit
 
 

Just to add, this morning I tried a system restore going back to before Alien Breed 2 installed some DX and Unreal Engine 3 stuff when I booted it up for the first time, the issue is still there.

I just ran L4D1 in a window with task manager and real temp running, and there were no spikes in activity when things slowed down. L4D1 was running at about 30-35% of my CPU and about 700MB. The max temp in my cores were approx 77-70-65-65.

Between restoring and retrying L4D1 Windows did automatically update, yet the installation of Norton Internet Security 2012 seems to now be screwed up, only one task is running, there's nothing in the system tray and when I try to uninstall NIS nothing happens! But that's a seperate issue and one I'm sure I can get around. When I can uninstall it, I'll try L4D then and see if NIS was somehow causing a problem!
My System SpecsSystem Spec
12 Nov 2011   #3

Windows 7 Ultimate 32bit
 
 

Well I have sorted this problem, for anybody that may find their way here, I did three things and either one of them may have fixed it!

1. I physically removed my graphics card and cleaned it, although it wasn't very dusty at all.
2. I uninstalled Steam. Although by mistake I reinstalled it over the old folder and lost ALL of my steamapps folder, which is even more of a pain as my internet is playing up and currently only downloading at about 3Mb/s!
3. When I opened up my PC, I checked the heat sink. Now I'm not sure if it was already loose on one corner or if I dislodged it somehow when checking it, but anyway, I reapplied the paste and fixed it back on (I think one of the clips is a bit dodgy so I'm going to replace this stock cooler asap with something better).

So one of the above made the difference, not 100% sure which. Had I more time and patience I would have done them all individually to isolate it, but at least it's working now. Well I tried Alien Swarm and L4D2 and both were pretty much locked around the 60fps mark!
My System SpecsSystem Spec
.


Reply

 Frequent frame rate dips





Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:10 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33