Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Upgrade to Win7 Pro

30 Nov 2011   #1

XP Home
 
 
Upgrade to Win7 Pro

Hi all, the win 7update to pro version from Home Premium states that you can run many XP office programs it does not mention XP Games like Age of Empires 2. As I would like to be able to play this old game but have not been able to make it work in Windows 7 home despite ALL web posted tries and suggestions. Would the XP part of Windows 7 Pro play the older XP games? Any help would be appreciated. Regards Peter


My System SpecsSystem Spec
.

30 Nov 2011   #2

Windows 8.1 Pro (x64)
 
 

No...I have Age of Empires 2 running flawlessly, you do not need to upgrade to play it.
My System SpecsSystem Spec
30 Nov 2011   #3

XP Home
 
 

Hi logicearth, how did you get it to play? I get windows has encountered a problem etc no matter what I did with all the suggestions from this site and others nothing worked. Regards Peter
My System SpecsSystem Spec
.


30 Nov 2011   #4

Windows 7 Ultimate x64, & Mac OS X 10.9.2
 
 

id suggest fully updating the game, as well as running in compatibility mode. Not found a game that wont work yet.
My System SpecsSystem Spec
30 Nov 2011   #5

Windows 7 Ultimate x64
 
 

XP mode (or any virtulized mode) is not good at all for games. (unless they are mindnumbling simple).
My System SpecsSystem Spec
01 Dec 2011   #6

XP Home
 
 

Hi all, regarding the Age of Empires2 game not working: when I try to start the game the following message appears, age of empires stopped working. The following error code Problem Event Name: APPCRASH
Application Name: EMPIRES2.ICD
Application Version: 0.14.22.712
Application Timestamp: 3981d1df
Fault Module Name: dplayerx.DLL
Fault Module Version: 0.0.0.0
Fault Module Timestamp: 396602f5
Exception Code: c0000005
Exception Offset: 00003a12
OS Version: 6.1.7601.2.1.0.768.3
Locale ID: 1033
Additional Information 1: 989a
Additional Information 2: 989a2eece94c88e43d080999500de321
Additional Information 3: 4e7c
Additional Information 4: 4e7c87bbc1587161b2639bdf69eae17a

Does anyone have any ideas how to make this work? I have, as stated previously, tried many, many web posted fixes none of them with success. Regards Peter
My System SpecsSystem Spec
01 Dec 2011   #7

Windows 7 Ultimate SP1 64-Bit
 
 

Did you have a look at Microsoft's support site for Age of Empires?

Support for PC games common problems
My System SpecsSystem Spec
01 Dec 2011   #8

XP Home
 
 

Hi seavixen32, yes I have but no answers that work. Like many others I have tried most things that have been posted. No go. I believe that there is a answer that will fix this but no one has been able to find it. The game worked 6 month ago then it quit. Maybe after a windows 7 update. Reverting to a 7 months prior state did not fix the issue either. Microsoft would know why it does not work but they are not saying. It is not the color issue. I know how to fix that. It just does not go past the splash screen that is when I get the error;;;; has stopped working;;;. It installs just fine. I have not changed any hardware from when it worked. Disabling Zone Alarm and all other start programs does not help. On and on and on. Regards Peter
My System SpecsSystem Spec
Reply

 Upgrade to Win7 Pro




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:29 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33