Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Problem with GTA IV on Windows 7 64 bit

03 Dec 2011   #11
M1GU31

Windows 10 64bit
 
 

Quote   Quote: Originally Posted by gambino90 View Post

3.0GHz Dual core processor
2GB Video graphics
what card is it you didn't mention mabye thats why it gets 12fps and gta iv prefers quad cores the most since it was a console port that was designed to run on a xbox 360 and ps3 which use a tri core processor so a quad or tri core would work better then a duo core which is the minimum

anyways have you tried installing in a different directory with admin rights


My System SpecsSystem Spec
.
03 Dec 2011   #12
gambino90

Windows 7 Professional x64
 
 

VisionTek 900356 Radeon HS 5450 Video Card
Link right here: VisionTek 900356 Radeon HD 5450 Video Card - 2GB, DDR3, PCI-Express 2.1 (x16), 1x DVI, 1x HDMI, 1x VGA, DirectX 11, Single-Slot, Low Profile at TigerDirect.com

And no, my friend has an Intel Dual core processor with 2.33 GHz processing speed, and he gets 25+ FPS on his game without a graphics card. I've tried everything.
My System SpecsSystem Spec
03 Dec 2011   #13
M1GU31

Windows 10 64bit
 
 

Quote   Quote: Originally Posted by gambino90 View Post
VisionTek 900356 Radeon HS 5450 Video Card
Link right here: VisionTek 900356 Radeon HD 5450 Video Card - 2GB, DDR3, PCI-Express 2.1 (x16), 1x DVI, 1x HDMI, 1x VGA, DirectX 11, Single-Slot, Low Profile at TigerDirect.com

And no, my friend has an Intel Dual core processor with 2.33 GHz processing speed, and he gets 25+ FPS on his game without a graphics card. I've tried everything.
odd i have the same card but with 512mb video memory instead and i get 24-30fps odd trying updating your CCC or uninstall CCC and reinstall it then update it to the latest CCC version make sure your downloading the correct drivers and getting the correct version for your card and os
My System SpecsSystem Spec
.

03 Dec 2011   #14
gambino90

Windows 7 Professional x64
 
 

That's what I did. I did that on my old computer, and I did that on this new computer (That won't even launch the game), and I still don't get more FPS. The highest I got was 15 FPS, but now I don't get much.
My System SpecsSystem Spec
04 Dec 2011   #15
M1GU31

Windows 10 64bit
 
 

Quote   Quote: Originally Posted by gambino90 View Post
That's what I did. I did that on my old computer, and I did that on this new computer (That won't even launch the game), and I still don't get more FPS. The highest I got was 15 FPS, but now I don't get much.
turn shadows off, with shadows at medium or low i get like 17 and put draw distance on lowest that kills the fps like crazy and with the shadows off and draw distance on lowest/off i get around 24-30fps mainly around 26
My System SpecsSystem Spec
04 Dec 2011   #16
gambino90

Windows 7 Professional x64
 
 

Quote   Quote: Originally Posted by M1GU31 View Post
Quote   Quote: Originally Posted by gambino90 View Post
That's what I did. I did that on my old computer, and I did that on this new computer (That won't even launch the game), and I still don't get more FPS. The highest I got was 15 FPS, but now I don't get much.
turn shadows off, with shadows at medium or low i get like 17 and put draw distance on lowest that kills the fps like crazy and with the shadows off and draw distance on lowest/off i get around 24-30fps mainly around 26
well, I'll try that soon. I just solved the problem with getting GTA IV working on windows 7 x64. I'll post a tutorial on how to get it working in case of future problems with other people.
My System SpecsSystem Spec
04 Dec 2011   #17
M1GU31

Windows 10 64bit
 
 

Quote   Quote: Originally Posted by gambino90 View Post
Quote   Quote: Originally Posted by M1GU31 View Post
Quote   Quote: Originally Posted by gambino90 View Post
That's what I did. I did that on my old computer, and I did that on this new computer (That won't even launch the game), and I still don't get more FPS. The highest I got was 15 FPS, but now I don't get much.
turn shadows off, with shadows at medium or low i get like 17 and put draw distance on lowest that kills the fps like crazy and with the shadows off and draw distance on lowest/off i get around 24-30fps mainly around 26
well, I'll try that soon. I just solved the problem with getting GTA IV working on windows 7 x64. I'll post a tutorial on how to get it working in case of future problems with other people.
wonderful glad you let us know look forward to your article on how you solved it
My System SpecsSystem Spec
04 Dec 2011   #18
gambino90

Windows 7 Professional x64
 
 

I posted the article, and I hope it makes a lot of sense. But as for the FPS, I get a max of 14.5 FPS with everything on low, and shadows turned off. Everything is at a minimum and it doesn't seem to work right.
My System SpecsSystem Spec
04 Dec 2011   #19
windrider

Windows 7 Ultimate x64
 
 

Glad you found a way for it too work on your Windows 7 X64.

I have no issues running it on Windows 7 X64 Ultimate, but last year I had to reinstall on my one laptop, and then the game would not launch.

But the problem there was after updating the GTA IV to 1.07, I had to update my GFWL to the latest before it would work.

You should be able to install to Program Files (X86) but if moving the files worked for you then I guess no problem.
My System SpecsSystem Spec
04 Dec 2011   #20
Wishmaster

Windows 7 Home Premium 64bit
 
 

Ive never had issues with mine.
But, what I do when building a new pC is first make sure Windwos is Completely up to date, SP1 and all.
Then update DirectX, and all my Graphics/Audio drivers etc.

All of this before installing any games.

I also have a quite a few GFWL games. I usually DL the lastest GFWL client, and install it prior to any GFWL games as well.
I have found that game setup for my GFWL games is so much smoother this way if the client is already in place and up to date.


Perhaps theres something with the order which helps eliminate issues? Im not sure. But thats how I have always done, and havent had issues with GTA or any other GFWL game.


In regards to installing into the Program Files / Program Files (x86) folders ...

Personally, I always recommend against that. I know many have no problem, but I have in the past with a few Games.

I would just make a folder for you games preferably on a secondary HD, or at least on the main C drive.
C:/Games/ ----

The downside is youll have to install everything manually and choose that directory, but should work out better.
My System SpecsSystem Spec
Reply

 Problem with GTA IV on Windows 7 64 bit




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Printer problem needs guru. Looks like Windows not Brother problem.
Windows 7 Professional Haven't had the need to use my printer in a couple of weeks, so I don't know when the problem started. It is a Brother HL-2270DW that has been problem free. There are tests that can be tried using the printer itself and it says it has a good connection and should be...
General Discussion
UI Problem/ minimized windows Display problem
Hi windows 7 community, I have a problem with windows 7 since the first day i've installed the OS (couple of years), and i haven't been able to solve it yet. The problem is that when i have a main application window, and different documents(windows) open in that main application window, when i...
General Discussion
Laptop Windows 7 Problem/Software/Hardware? Keyboard problem
Okay, right now I'm currently trying to find out whats wrong with a keyboard that is on a laptop, after the computer starts there are some script errors, I don't know exactly what they are but I ran combo fix without safe mode and restarted the scripts went away...and it started working after...
Hardware & Devices
Moving windows/icons down problem!! Move right/left/up - no problem
New system i7 3930K CPU Sabertooth X79 Mortherboard GeForce GTX690 GPU Intel 520 series SSD 32GB RAM Dell U2711 27" Monitor Win 7 Pro
General Discussion
Windows 7 Not genuine Problem. And 404 error (security?) Problem.
Hi, ive had both of these problems for about two weeks and have tried to fix it myself. No luck at all. Dont no of their connected. Help on how to fix it would be greatly appreciated.
BSOD Help and Support
Windows Media Player Problem - Sound/skipping problem.
Oh look, another windows media player problem, lol. Well, it's something really weird, at first i thought it was just my computer being all slow or the file was messed up, No matter what movie or format i play it makes this weird screeching noise. It also lags pretty bad. I tried the scans, i did...
Music, Pictures & Video


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:30.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App