Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: I'm getting fustrated about this

21 Jan 2012   #1

Microsoft Windows 7 Ultimate: x64 (SP1)
 
 
I'm getting fustrated about this

I wrote a thread a long time ago, and I have to bring it up again because I really want to get it fixed.

Steam.

Games like Bastion, Terraria and Alien Zombie Megadeath have drawback lags with a second in between. A constant lag. Not a framedrop, just a constant drawback.

I was super lucky to win a code I could turn in to play Xotic, a Steam game, and that game did not lag, really. No lag. So I don't know what Terrraria and those other games mentioned, has, that Xotic doesn't have.

Also note that I run non-steam games perfect.

My specs are updated to you can check those as well below.

Thanks.
Fred.

My System SpecsSystem Spec
.

21 Jan 2012   #2

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by FredeGail View Post
I wrote a thread a long time ago, and I have to bring it up again because I really want to get it fixed.

Steam.

Games like Bastion, Terraria and Alien Zombie Megadeath have drawback lags with a second in between. A constant lag. Not a framedrop, just a constant drawback.

I was super lucky to win a code I could turn in to play Xotic, a Steam game, and that game did not lag, really. No lag. So I don't know what Terrraria and those other games mentioned, has, that Xotic doesn't have.

Also note that I run non-steam games perfect.

My specs are updated to you can check those as well below.

Thanks.
Fred.
Are you playing online or offline? I know Terraria online has no dedicated servers, so you either have to connect to someone hosting from their PC, or personal server; which could be part of your lag.

By drawback do you mean slingshot? As in, you move a few spaces left, then all of a sudden you're thrown back right to where you were? That is usually a sign of internet lag, not system lag. This is assuming you're talking about online play. If this is happening offline, I'm not sure what could be causing it, because I've never had a problem like that playing any game offline.

You can always try changing your download region to something closer to you. I don't see it helping in any way, but it can't hurt to try. You need to be abit more clear what you mean, though. I'm only helping by assumption.
My System SpecsSystem Spec
21 Jan 2012   #3

Microsoft Windows 7 Ultimate: x64 (SP1)
 
 

Thanks for your comment.

I'm offline.
Let me try to explain the drawback a little.

Imagine a straight line like this, ---------------------, traveling further and further. It stops for 0.25 sec and a second in between. It's basically just a lag with a second space between, but the lag goes a bit backwards. It all happens really fast so It's rather hard to describe.
My System SpecsSystem Spec
.


21 Jan 2012   #4

Windows 7 Home premium 64bit SP1
 
 

trying turning off v-sync
My System SpecsSystem Spec
21 Jan 2012   #5

Microsoft Windows 7 Ultimate: x64 (SP1)
 
 

Quote   Quote: Originally Posted by M1GU31 View Post
trying turning off v-sync
I tried that in Bastion and the drawbacks turned in to be some tilted lines floating across the monitor.
My System SpecsSystem Spec
21 Jan 2012   #6

Windows 7 Home Premium x64 SP1
 
 

Have you tried verifying game cache or defragment those particular Steam games? I doubt it would help but it couldn't hurt to try. Right click on the game in Steam>Properties>Local Files and then verify integrity of game cache or defragment cache files. If one was going to help I would think it would be defragmenting.
My System SpecsSystem Spec
21 Jan 2012   #7

Microsoft Windows 7 Ultimate: x64 (SP1)
 
 

Quote   Quote: Originally Posted by Squid View Post
Have you tried verifying game cache or defragment those particular Steam games? I doubt it would help but it couldn't hurt to try. Right click on the game in Steam>Properties>Local Files and then verify integrity of game cache or defragment cache files. If one was going to help I would think it would be defragmenting.
Yes I tried that eventually with no luck.
Just keep the replies coming.
My System SpecsSystem Spec
21 Jan 2012   #8

Windows 7 Home premium 64bit SP1
 
 

did you have this problem on previous drivers? If you didn't i say you should rollback to older drivers. Might be driver related because i run terria fine on my AMD card
My System SpecsSystem Spec
22 Jan 2012   #9

Microsoft Windows 7 Ultimate: x64 (SP1)
 
 

Quote   Quote: Originally Posted by M1GU31 View Post
did you have this problem on previous drivers? If you didn't i say you should rollback to older drivers. Might be driver related because i run terria fine on my AMD card
I could try that. I'm not at my computer till Monday.
My System SpecsSystem Spec
22 Jan 2012   #10

Microsoft Windows 7 Ultimate: x64 (SP1)
 
 

I shouldn't try with a BETA driver that's for sure. This is the previous WHQL driver. Should I go with it?
My System SpecsSystem Spec
Reply

 I'm getting fustrated about this




Thread Tools



Similar help and support threads for2: I'm getting fustrated about this
Thread Forum
so confused and fustrated - not responding error BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 04:47 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33