Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Weird video lag, The Sims 3


30 Jan 2012   #1
Anesthetic

Windows
 
 
Weird video lag, The Sims 3

Here are my system specs: CPU-Z Validator 3.1

According to those specs, I know it's not the fastest PC in the world, however, the Sim 3 isn't exactly Crysis either.

Here is the link to the video: Deposit Files

I couldn't upload the file here because it's 12MB

And don't mind the horrible visual quality of the video, just pretend the video is clear but notice how jittery things get when I scroll around.

What could it be?

Someone told me that my processor is a dinosaur, but I've seen people with Core 2 Duos run this game....

Additionally, when things do manage to run smoothly, like when creating a Sim, there are like these tiny screen tears when you spin them around.

Lastly, I just played the game DIRT 3 and it plays smooth like butter. No lagging, no jitters, just perfect on 1920 x 1080. Dirt 3s minimum specs are even higher.... I'm beginning to think it's the game..?


My System SpecsSystem Spec
.

31 Jan 2012   #2
vierasniper

Windows 7 Ultimate
 
 

Is it just like a visual lag, or this there a lag during game play?
My System SpecsSystem Spec
31 Jan 2012   #3
papin97

Windows 7 Home Premium 64bit OEM , Ubuntu 11.10 64-bit , Windows XP Pro 64-bit , Windows 8 CP 64 bit
 
 

Maybe ATI Radeon doesn't support The Sims 3. Make sure your graphics driver is updated and change settings on your ATI RADEON driver.
I have same issue, too. My computer has 2 VGAs, and The Sims 3 select Intel Graphics, not nVidia GT540M. So, I change nVidia settings and select The Sims 3 to use nVidia GPU.
My System SpecsSystem Spec
.

31 Jan 2012   #4
Anesthetic

Windows
 
 

Quote   Quote: Originally Posted by vierasniper View Post
Is it just like a visual lag, or this there a lag during game play?
Visual hiccups during game play. Screen tears. It makes me angry! Other games work fine!
My System SpecsSystem Spec
31 Jan 2012   #5
Anesthetic

Windows
 
 

Quote   Quote: Originally Posted by papin97 View Post
Maybe ATI Radeon doesn't support The Sims 3. Make sure your graphics driver is updated and change settings on your ATI RADEON driver.
I have same issue, too. My computer has 2 VGAs, and The Sims 3 select Intel Graphics, not nVidia GT540M. So, I change nVidia settings and select The Sims 3 to use nVidia GPU.
On youtube, someone else posted video of them playing with the same video card as me and their video looks fine :\
My System SpecsSystem Spec
31 Jan 2012   #6
vierasniper

Windows 7 Ultimate
 
 

Quote   Quote: Originally Posted by Anesthetic View Post
Quote   Quote: Originally Posted by vierasniper View Post
Is it just like a visual lag, or this there a lag during game play?
Visual hiccups during game play. Screen tears. It makes me angry! Other games work fine!
Well just make sure the base game and all expansions (if any), are fully updated. Also Your video card Drivers as well. Its not you processor, i used to run the game on a dual core as well. The game ran fine, i used a GTX260. Are you using any mods?
My System SpecsSystem Spec
31 Jan 2012   #7
MrNeeds

Windows 7 Ultimate x64 SP1
 
 

i think what you're experiencing is v-sync issues, the screen tearing is a dead give away, i'm an Nvidia user so i cannot tell you how to enable v-sync on the catalyst control center, anybody help?
My System SpecsSystem Spec
31 Jan 2012   #8
Anesthetic

Windows
 
 

Quote   Quote: Originally Posted by MrNeeds View Post
i think what you're experiencing is v-sync issues, the screen tearing is a dead give away, i'm an Nvidia user so i cannot tell you how to enable v-sync on the catalyst control center, anybody help?
I've been noticing that in many forums as well. What I'm going to do is, I'm going to purchase an NVIDIA GTX 560Ti and try the V-SYNC thing to see if that card will make a difference. I really don't want to do this because I've already returned one AMD card to Amazon already, but if this solution works, I will let you guys know by end of day Thursday or Friday and will consider this matter solved. I'm crossing my fingers!
My System SpecsSystem Spec
31 Jan 2012   #9
M1GU31

Windows 7 Home premium 64bit SP1
 
 

Quote   Quote: Originally Posted by MrNeeds View Post
i think what you're experiencing is v-sync issues, the screen tearing is a dead give away, i'm an Nvidia user so i cannot tell you how to enable v-sync on the catalyst control center, anybody help?
ye you set this setting to force v-sync in CCC


Attached Thumbnails
-ccc.png  
My System SpecsSystem Spec
04 Feb 2012   #10
Anesthetic

Windows
 
 

Ok guys. Now, I'm rolling with an NVIDIA GTX 560 TI (VSYNC on) and The Sims 3 doesn't have screen tears anymore, however, the game still stutters when scrolling. I noticed that when I start on an empty lot, the games stays at a SMOOTH 60FPS (using FRAPS). Now, the minute I add a house and the Sims begin to live there, my FPS jumps all over the place, but never goes over 60. Even when my FPS goes to 59, I notice the stuttering. And sometimes it goes...... 60- 60- 59- 59- 58- 56, 57 -30 -30 -20 -30 -44 -50-60-59-59-59-60-60-62. It's really stupid. I mean, the game is playable, but the jittering is really going to make me go crazy. So, don't get me wrong, V-SYNC does its job, but now the game jitters when scrolling. This is only a problem with the Sims. Fear 2 runs great, Dirt 3 runs smooth, even the old game from 2003 - the suffering runs smoothly lol. I tried to set affinity to my cores (limiting it to 3), I tried maxing out my graphics card settings, and even setting them to minimal. I tried, lower resolutions, lower in game settings, you name it. I don't know what the deal is. I mean, EA had 3 years to fix this? Message boards are full of these "jittering" claims and EA still hasn't commented on it. Anything else I can try?
My System SpecsSystem Spec
Reply

 Weird video lag, The Sims 3




Thread Tools



Similar help and support threads for2: Weird video lag, The Sims 3
Thread Forum
Crashes during sound/video but very random and weird crash, no BSOD BSOD Help and Support
Weird video playback issue! Music, Pictures & Video
Weird system error after weird BSOD BSOD Help and Support
Weird sound/video issues, possibly virus? System Security
weird video problem on boot-up Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:41 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App