Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Game lag, FPS issues, huge difference transitioning from XP - Windows7

15 Mar 2012   #1
hambuggah

Windows 7 x64
 
 
Game lag, FPS issues, huge difference transitioning from XP - Windows7

Hi all,

I recently formatted my computer running windows XP & installed Windows 7 - 64 bit. (actually, it's been about a week).

I've noticed that games have been super laggy and the FPS could drop to 1 FPS from time to time. It has made it extremely difficult for me to play Starcraft II and other games.

I have installed all the correct & most recent drivers for my hardware (mobo, graphics card, sound card, etc...). I've done virus scans even though I haven't really downloaded much onto my PC aside from iTunes, Chrome, etc...

I've played around with my nVidia control panel settings, & in game graphic settings (from highest to lowest). It didn't fix the low FPS.

I am running Intel Core2: Quad 2.4GHz
8GB Ram
Gfx Card: PNY GeForce 9500 GT
MSI P6N SLI Mobo


I need some insight on this situation & advice. Thank you in advance!


My System SpecsSystem Spec
.
15 Mar 2012   #2
zigzag3143

Win 8 Release candidate 8400
 
 

Lag (or latency) is often caused by a bad driver. Please download this free utility to check. DPC Latency Checker
My System SpecsSystem Spec
15 Mar 2012   #3
hambuggah

Windows 7 x64
 
 

thanks for the quick response. So if my latency ever jumps into the red zone, it'd mean I should uninstall & reinstall drivers?
My System SpecsSystem Spec
.

15 Mar 2012   #4
zigzag3143

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by hambuggah View Post
thanks for the quick response. So if my latency ever jumps into the red zone, it'd mean I should uninstall & reinstall drivers?
Absolutely. It is a bit of a bear finding the driver that is doing it but at least you are pointed in the right direction if it does.
My System SpecsSystem Spec
16 Mar 2012   #5
hambuggah

Windows 7 x64
 
 

I ran drive sweeper to clean out my drivers & reinstall them. It didn't help the situation. Then I used an application called DriverView and apparently I don't even have that many drivers installed aside from the stock MS ones.

It shows the nVidia display drivers, Physx, RealTek Audio, Kaspersky, etc...

Could the issue lie elsewhere?
My System SpecsSystem Spec
16 Mar 2012   #6
zigzag3143

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by hambuggah View Post
I ran drive sweeper to clean out my drivers & reinstall them. It didn't help the situation. Then I used an application called DriverView and apparently I don't even have that many drivers installed aside from the stock MS ones.

It shows the nVidia display drivers, Physx, RealTek Audio, Kaspersky, etc...

Could the issue lie elsewhere?
Sure, it could be the network, ram, power, heat, etc.

Whats the network setup and what does the ISP claim you are getting?
My System SpecsSystem Spec
16 Mar 2012   #7
hambuggah

Windows 7 x64
 
 

My ram seem to be fine. There is usually something like 5GB of ram idling while SC2 is running (out of 8GB). SC2 would eat up 1.5GB while the OS will take up the other 1.5. My network appears to be fine, I've been downloading at good speeds & my speedtest.net results showed what was expected.

I've checked the component temperatures via 3rd party apps & a few times in Bios and they appeared to be fine as well.

The power supply has never given me any problems before and I've been using this computer for 2 years.
My System SpecsSystem Spec
16 Mar 2012   #8
zigzag3143

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by hambuggah View Post
My ram seem to be fine. There is usually something like 5GB of ram idling while SC2 is running (out of 8GB). SC2 would eat up 1.5GB while the OS will take up the other 1.5. My network appears to be fine, I've been downloading at good speeds & my speedtest.net results showed what was expected.

I've checked the component temperatures via 3rd party apps & a few times in Bios and they appeared to be fine as well.

The power supply has never given me any problems before and I've been using this computer for 2 years.
OK and the network?
My System SpecsSystem Spec
16 Mar 2012   #9
hambuggah

Windows 7 x64
 
 

what would should i look at regarding the network?

[edit]

actually i just checked during a huge lag spike. my CPU usage went up to 94% during the time... but when I opened "Resource Monitor", it appears that there's 5GB of ram available & only 3GB in use by OS & SC2 combined.

The SC2 shouldn't work all 4 cores so hard, would it?
My System SpecsSystem Spec
16 Mar 2012   #10
zigzag3143

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by hambuggah View Post
what would should i look at regarding the network?

[edit]

actually i just checked during a huge lag spike. my CPU usage went up to 94% during the time... but when I opened "Resource Monitor", it appears that there's 5GB of ram available & only 3GB in use by OS & SC2 combined.

The SC2 shouldn't work all 4 cores so hard, would it?
No it shouldnt there probably is something else doing it can you open resource monitor when the computer is lagging and take a snip of the most active cpu, and ram screens
My System SpecsSystem Spec
Reply

 Game lag, FPS issues, huge difference transitioning from XP - Windows7




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Huge issues with Windows Installer, Backup, Firewall and services
Hi, (This is my first post on these forums, tried Tom's Hardware countless times but have got no where) Please be patient as this is a huge post :p Around October last year I built my first PC (I'm 17) and was chuffed to finally fit the final piece of the puzzle, i.e. installing Windows. I...
Performance & Maintenance
Transitioning from HDD to SSD + HDD Advice
Hi I would like some advice on my topic. Currently I have a Western Digital Caviar Black 7200 rpm 500 GB HDD as my only drive, running Windows 7 pretty fine. But now I would like to use an SSD, namely the Samsung 840 Series 120 GB drive as a boot drive with some programs, and keep the HDD as...
Hardware & Devices
found vwxrauhf.exe running - causing huge issues
Hi, I have/had a virus whereby logging in,upon startup i would have an internet page that apparently cannot display the page, it is full screen and i cant load or get rid of it and it even closes down task mgr. i started avast and mwab in safemode and the problem wasnt solved, even got worse,...
System Security
Huge bandwith usage from Windows7 64 bit
Just got a new computer, ZT Systems 3.4 i7-2600, 16 GB RAM, running Windows 7 64 bit. I love the computer, I love working on the OS. I do not love the massive amounts of bandwidth I'm using apparently from doing nothing. In 24 hours, we used 4.5 gigs of Internet bandwidth on this thing. Running...
Performance & Maintenance
Windows7 Game Crashes
Hey, my microphone doesn't work on my headset on my computer it doesn't even find it, so when i update my Sound Drivers the microphone works but then my game "Counter Strike:Source" Crashes when i play. This is my Motherboard MCP6PB M2+ i don't no anything about Motherboards or drivers ect so...
Drivers
windows7 not playing ANY game.....
well i have contacted before this too for my problem with windows7.games are not using full screen and this issue didnt solve,then i thought to install vista on D and 7 on C but just today i got a new problem. before games used to run but in small screen but today,games didnt play even.when i...
Gaming


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:32.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App