Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Problem running ALL games with DirectX 10-11

30 Jun 2012   #11
fnnoname

Windows 7 Home Premium 64bit
 
 

I'm so sorry that I've marked this thread to unsolved because the problem still exists.

Okay here's the story : I thought that the problem solved so I turned off my computer and the next time I turn it on again and playing Max Payne 3 using DX11,it could only get past a cutscene and then it exits itself again while sound still playing
This time I couldn't even get 5 minutes in game.

Tried playing Just Cause 2,I could only play to 15 minutes
And I used Driver Sweeper again,still no luck.

So,any suggestions that this issue could come within the hardware?


My System SpecsSystem Spec
.
30 Jun 2012   #12
solarmystic

Windows 7 x64 Professional SP1
 
 

Oh dear me... it does sound more likely there's some hardware instability on your system...

Time to narrow this down further... do you overclock your CPU and/or your graphics card using software like MSI Afterburner or the like? If so, can you try and revert all your clocks back to default....

Another set of stress tests i'd like you try to rule out hardware instability would be LinX (LinX - A simple Linpack interface) for your CPU and RAM, and also Furmark (FurMark: VGA Stress Test, Graphics Card and GPU Stability Test, Burn-in Test, OpenGL Benchmark and GPU Temperature | oZone3D.Net) for your GPU.

For maximum stress run those two applications seperately first to isolate which component is cause, and then together (for at least an hour or until they complete), side by side while monitoring your temperatures... If your system passes those tests (i.e. doesn't crash or hard lock) then we can safely rule out hardware instability and blame it on the software 100%
My System SpecsSystem Spec
30 Jun 2012   #13
fnnoname

Windows 7 Home Premium 64bit
 
 

Hi solarmystic,sorry to bother you again.

I've reverting back all of my configurations to their stock speed. CPU,RAM,everything except Graphics Card.
I've no idea how to revert it to its stock speed because it's like factory-over clocked or something.
The reason that I bought this graphics card is that it has 3 fans so I thought it would be cooler than reference,I have no idea of this factory-over clocked. Here's the pic :
And no,I don't use MSI Afterburner or something similar. I do overclock via BIOS.
But the thing is: It doesn't make any difference . Stock speed or overclocked,the problem still exists.

Okay I'll try those stress tests and I'll post the results here .
My System SpecsSystem Spec
.

30 Jun 2012   #14
solarmystic

Windows 7 x64 Professional SP1
 
 

I eagerly await your stress test results!
My System SpecsSystem Spec
30 Jun 2012   #15
fnnoname

Windows 7 Home Premium 64bit
 
 

I did a clean reinstallation of Windows however,so I get a fresh OS to play and to make sure that there is no other software that might interfere when I'm playing.

Done installing Windows,I proceed to install essential drivers and 2 games: Just Cause 2 and Max Payne 3.

Even worse,this isn't solve anything. I could only play Just Cause 2 up to 45 minutes and Max Payne 3 (DX11) only 15 minutes. BUT there is a notification pop up message when Max Payne 3 exits itself saying something about "Nvidia driver error has crashed and recovered" (I don't really remember the exact message because it disappears so quickly).

So I used Driver Sweeper again but still no luck.
Next, I run the FurMark software and these are the results:
1920x1080 0xMSAA
FPS: Min 17,Max 29,Avg 22
Temperature: Min 34 degrees,Max 68 degrees (in celsius)
Time: 1 hour 5 minutes.

However I don't know how to use LinX because when I press start,nothing happens..CPU still 0-1% load and there's no increase in RAM use. And once I click start,the stop button does nothing when pressed..strange..
SO I used hyperpi and it runs without problem (I don't know if this equivalent or not).

EDIT : I managed to play around with Unigine Heaven and this happens :
My System SpecsSystem Spec
30 Jun 2012   #16
solarmystic

Windows 7 x64 Professional SP1
 
 

Thanks for all the effort fnnoname!

That's really good work there refreshing your OS to exclude all other software possibilites... hmm if Furmark runs for an hour without any issues, your GPU should theoretically be in the clear... BUT that fatal error for Unigine still makes it suspect...

There're two last things i'd like you to try before i recommend a GPU replacement (I'm sorry =(),

1. Can you take a screenshot of GPUz and your game in windowed mode side by on your desktop with the sensors tab selected (e.g. for Max Payne), like below? (before it crashes of course)

Problem running ALL games with DirectX 10-11-test.jpg


2. Download MSI Afterburner (event.msi.com/vga/afterburner/download.htm) and either reduce the clocks (core, shader and memory frequencies) or increase the voltage of your graphics card slightly?

Your default clocks should be:-

732/1464/950 for core/shaders/memory respectively

(You mentioned your card was factory overclocked, perhaps the supplied voltage is not enough to run DX11 games stable enough)

How to: Once inside the program go to settings then check two boxes saying "unlock voltage control", and "unlock voltage monitoring"

After that just bump up your voltage and hit apply.

Try running the games after a small voltage increase?

Once again, thank you for your patience mate!


My System SpecsSystem Spec
30 Jun 2012   #17
fnnoname

Windows 7 Home Premium 64bit
 
 

No,it should be me for thanking you for your efforts and patience

But I'm using Gigabyte graphics card,is this OK with MSI afterburner?

Okay,I'm going to test it now.
My System SpecsSystem Spec
30 Jun 2012   #18
solarmystic

Windows 7 x64 Professional SP1
 
 

MSI Afterburner works with most dedicated desktop graphics cards from AMD/NVIDIA, so it should be okay...

Don't forget to post screenshots of Max Payne and GPUz, plus the MSI Afterburner windows of your detected clocks and voltages, and the lowered clocks too!
My System SpecsSystem Spec
30 Jun 2012   #19
w1dpc

windows 7 x64 pro sp1
 
 

you dont state what your PSU is

try this site for graphics card power requirements. it has a very good DB

Power-On
My System SpecsSystem Spec
30 Jun 2012   #20
fnnoname

Windows 7 Home Premium 64bit
 
 

@solarmystic

This is the screenshot of MSI Afterburner at default :


So far I've only increased the Core Voltage from 1025 to 1038 and I think games are going well..I played Max Payne 3 for 30 minutes and Just Cause 2 up to 1 hour,but because I have other things to do I stop playing it and now I leave my PC running Heaven DX11 Benchmark.

So far so good though,15 minutes running Heaven without any problems now.

and this is the screenshot of Max Payne 3:


@w1dpc :

Oh yes,I use FSP Aurum Gold 700W. Is it good enough?
My System SpecsSystem Spec
Reply

 Problem running ALL games with DirectX 10-11




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Having DirectX Problem, Specifically DirectX Diagnostic
Hello, I Have a Problem With My Direct X Working For My Lenovo Thinkpad Labtop. Specifically An Error Running Direct X Diagnostic. I Have been told this is major problem and Would Like To know If Someone would be able to assist me with this situation. Attached is my SFC Scan Results from...
Performance & Maintenance
Windows XP Mode problem running older games
Hello, I am running Windows 7 Pro x64 and have been trying to run some old games in XP Mode. I keep getting error messages. "16 bit MS-DOS Subsystem, C:\WINDOWS\system32\cmd.exe, The video device failed to initialize for fullscreen mode." How can I fix or get around this error? Here are just...
Gaming
No VGA Input while running directx 9 games
My GPU temperature is running at 100 degree celsius ! Please help me out !!
Gaming
Problem with running games on Sony HDTV
Hi, I upgraded my Graphics Card to a Radeon HD 4350 as my motherboard onboard graphics card was old and wasn't supported in Windows 7. I have a 50 inch Sony LCD TV. I have extended the display to show on the tv and the monitor. My problem is that whenever I try and play older games on my...
Graphic Cards
problem running games
Hello, I have an asus 1201ha laptop with a GMA 500 and Win 7. When I try playing some old games like heroes 3 the mouse arrow and the game menus strat flashing and don't run smooth. Can anyone help me? Thanks alot
Gaming
Problem with Directx when trying to open games..
When ever I open any game I get a message telling me that d3d9.dll is not designed to run on windows or contains an error.. I have already reinstalled directx, as well as downloaded a d3d9.dll file and tried that one out.. Still get the same error message.. Any help?? I have attached a...
Gaming


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:30.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App