Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: GTA IV Error


11 Jul 2012   #1

Windows 7 Ultimate x64
 
 
GTA IV Error

I keep getting errors on my gta iv! I cant even play it1! I do not know what to do! I will give you my system details and the error! Error> GTAIV has stopped working< I have taken out ELS and it still pops that up and I run it as an admin. Here are my system details!(Below)
Operating System
MS Windows 7 Home Premium 64-bit SP1
CPU
Intel Core i5 2300 @ 2.80GHz 39 C
Sandy Bridge 32nm Technology
RAM
8.00 GB Dual-Channel DDR3 @ 665MHz (9-9-9-24)
Motherboard
Intel Corporation DH61WW (LGA1155 CPU 1) 32 C
Graphics
Acer P221W (1680x1050@60Hz)
1024MB GeForce 210 (ASUStek Computer Inc) 41 C
Hard Drives
596GB Western Digital WDC WD6402AAEX-00Z3A0 ATA Device (SATA) 45 C
Optical Drives
Optiarc DVD RW AD-7261S ATA Device
DTSOFT Virtual CdRom Device
Audio
High Definition Audio Device

I also have re-installed it about 2-3 times witch takes ages and I tried with out mods same thing!
Its a Steam Copy


My System SpecsSystem Spec
.

11 Jul 2012   #2

Windows 7 Home premium 64bit SP1
 
 

What is the exact error that windows reports?Also what video card are you using and what version of drivers? If unsure you can download speccy and see your specs and post what video card you have. link to speccy>>> Download Speccy 1.17.340 - FileHippo.com
Provide as many details as possible on what exactly happens when crashing and what error it displays. Taking screen-shots would help too. If you don't know how to take a screen shot then go to this link Screenshot with Paint and it will show you how and you can upload them here and put them in your post.You click the paper clip to the right hand corner of were you type your post to attach images to your post.
My System SpecsSystem Spec
11 Jul 2012   #3

Windows 7 Home Premium 64bit
 
 

It may be a bad setting from a mod.


I would delete the settings files and force the game to remake them.

Users/ (user name) / AppData / local / Rockstar Games / GTA4 / -> Delete the settings folder here.
It will not hurt to delete the entire GTA4 folder if you have no save you need to keep.


After that, go into Steam and right click GTA4 in your library. Click Properties, then click the Local Files tab in the next window. Choose Verify Integrity of Game Cache.

Once that finishes, I would recommend installing the latest copy of GFWL. Download the Games for Windows Client | PC Games Client - Xbox.com

Then re-install the game.


Without a specific error its just a guess. But I can tell you the game runs just fine on Windows 7 x64 through Steam. So its a matter of pinpointing whats wrong.
My System SpecsSystem Spec
.


11 Jul 2012   #4

Windows 7 Ultimate x64
 
 

Thank you Wishmaster I am trying that now! )))) thank you so much for your help I will tell you if it works or not! I'm doing the files right now! I'm re-installing it right now!
My System SpecsSystem Spec
12 Jul 2012   #5

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by Wishmaster View Post
It may be a bad setting from a mod.


I would delete the settings files and force the game to remake them.

Users/ (user name) / AppData / local / Rockstar Games / GTA4 / -> Delete the settings folder here.
It will not hurt to delete the entire GTA4 folder if you have no save you need to keep.


After that, go into Steam and right click GTA4 in your library. Click Properties, then click the Local Files tab in the next window. Choose Verify Integrity of Game Cache.

Once that finishes, I would recommend installing the latest copy of GFWL. Download the Games for Windows Client | PC Games Client - Xbox.com

Then re-install the game.


Without a specific error its just a guess. But I can tell you the game runs just fine on Windows 7 x64 through Steam. So its a matter of pinpointing whats wrong.
It didnt work! I did what you told me to do
My System SpecsSystem Spec
12 Jul 2012   #6

Windows 7 Home premium 64bit SP1
 
 

Quote   Quote: Originally Posted by Warriormpw View Post
Quote   Quote: Originally Posted by Wishmaster View Post
It may be a bad setting from a mod.


I would delete the settings files and force the game to remake them.

Users/ (user name) / AppData / local / Rockstar Games / GTA4 / -> Delete the settings folder here.
It will not hurt to delete the entire GTA4 folder if you have no save you need to keep.


After that, go into Steam and right click GTA4 in your library. Click Properties, then click the Local Files tab in the next window. Choose Verify Integrity of Game Cache.

Once that finishes, I would recommend installing the latest copy of GFWL. Download the Games for Windows Client | PC Games Client - Xbox.com

Then re-install the game.


Without a specific error its just a guess. But I can tell you the game runs just fine on Windows 7 x64 through Steam. So its a matter of pinpointing whats wrong.
It didnt work! I did what you told me to do
Update or reinstall your nvdia drivers. Also update windows 7 and have you tried re-installing the steam client?
My System SpecsSystem Spec
13 Jul 2012   #7

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by M1GU31 View Post
Quote   Quote: Originally Posted by Warriormpw View Post
Quote   Quote: Originally Posted by Wishmaster View Post
It may be a bad setting from a mod.


I would delete the settings files and force the game to remake them.

Users/ (user name) / AppData / local / Rockstar Games / GTA4 / -> Delete the settings folder here.
It will not hurt to delete the entire GTA4 folder if you have no save you need to keep.


After that, go into Steam and right click GTA4 in your library. Click Properties, then click the Local Files tab in the next window. Choose Verify Integrity of Game Cache.

Once that finishes, I would recommend installing the latest copy of GFWL. Download the Games for Windows Client | PC Games Client - Xbox.com

Then re-install the game.


Without a specific error its just a guess. But I can tell you the game runs just fine on Windows 7 x64 through Steam. So its a matter of pinpointing whats wrong.
It didnt work! I did what you told me to do
Update or reinstall your nvdia drivers. Also update windows 7 and have you tried re-installing the steam client?
Would that delete my game
My System SpecsSystem Spec
18 Jul 2012   #8

Windows 7 Home Premium 64bit
 
 

I have ATI graphics card and I use to play games like this with PowerPlay.
Go to your Nvidia settings and look around, see if you find anything about gaming and PowerPlay and turn it on.
My System SpecsSystem Spec
19 Jul 2012   #9

Windows 7 Ultimate x64
 
 

I have fixed! I uninstalled Internet 9 re-installed the game and it worked! DO NOT INSTALL THE PATCH INSTALL IT MANUALLY
My System SpecsSystem Spec
Reply

 GTA IV Error




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:12 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33