Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Age of Empires 3 - Failed to join multiplayer game

18 Jul 2012   #1
MisterTurtl3

Windows 7 Home Premium x64
 
 
Age of Empires 3 - Failed to join multiplayer game

Hi, I bought the Age of Empires 3 complete collection on steam in the sale and the game runs fine and lets me log into the multiplayer but whenever I try to join a game it come up with an error saying "failed to join game". I have found 2 solutions on other forums, one is to port forward which I have tried and hasn't worked. The other is to buy a new router because the error is caused by running the game on windows 7 using a thomson router (which I have). Any ideas why this would cause an error and any other ideas guys?

Cheers
Joe


My System SpecsSystem Spec
19 Jul 2012   #2
Chalky Emultion

 

hi,

have you got any mod installed on this game? have you patched it to the last version?

Try to turn off firewall and, if you can, set your anti-virus software in game mode (only when you're playing!)
It worked for me: I wasn't able to connect to other players in games like Generals Zero Hour, Unreal Tournament 3, (...) because of the firewall and the anti-virus.
My System SpecsSystem Spec
22 Jul 2012   #3
MisterTurtl3

Windows 7 Home Premium x64
 
 

I tried this and it did not work. Also, I am upgrading my internet on saturday and will be getting a new router, so I'll see if this fixes the problem
My System SpecsSystem Spec
23 Jul 2012   #4
Chalky Emultion

 

Your router could be the problem, why not. Replacing it could solve your problem
My System SpecsSystem Spec
30 Jul 2012   #5
MisterTurtl3

Windows 7 Home Premium x64
 
 

The new router came and now it works well (it is a totally differnet router btw) so it seems like it was the router
My System SpecsSystem Spec
31 Jul 2012   #6
Chalky Emultion

 

good.
have fun
My System SpecsSystem Spec
Reply

 Age of Empires 3 - Failed to join multiplayer game




Thread Tools





Similar help and support threads
Thread Forum
Multiplayer problems with Age of empires II
Hi all We have two computers. One a laptop running windows 7 64 bit home edition and a self build running windows 7 ultimate 32 bit. We are connected by cable to a netgear router and can quite happily "see" each other's computers through a home group. We want to play Age of empires II as a...
Gaming
Server Execution Failed when trying to launch a game
Hello All, I have been through and read the post on people having server execution failed messages, but they all seem to be for Windows Media Player etc. I have yet to find a post for someone having a hard time launching a game. The game is The Sims 3 and I HAVE played it on my laptop before....
BSOD Help and Support
Multiplayer Game recommendation - IGP
Looking for a good multiplayer game that will work with the on-board graphics (HD 3200). I dont want to pay monthly fees, just want to play one other person. Any Ideas? Thanks!
Gaming
Game Cannot Run: Failed to set up Graphic System
My Friend has just Loaded Football Manager 2010 on Windows 7 32-bit and it says Game Cannot Run: Failed to set up Graphic System I looked at whether it was His graphics card but it was up-to-date I am totally bamboozled Help? Thanks
Gaming
Multiplayer Game Lag Spikes?
Computer specs: Windows 7 64 bit. AMD Athlon II X4 620 Processor (4 cpus) 2.6 GHz Graphic card: Nvidia GeForce 9100 Im on a wired connection and have roadrunner. Ok. I no theres 1000 threads on the internet about this but im still having the problem. I bought this computer brand new and...
Gaming
Windows 7 unable to Join 2003 Domain, offline Join erro
Hello to all, I have a Windows 7 Professional Version 6.1.7600 Build 7600 Every time I try to join the 2003 server Domain, I got the error attached in the post. Im not trying to do a offline joint, the W7 can ping the domain IP, and can resolve the domain name. I hope anyone can help me...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:33.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App