Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Several issues (aoe2, ra3, steam)


19 Jan 2009   #1

Windows 7
 
 
Several issues (aoe2, ra3, steam)

Basically I can't get age of empires 2: the conquerer's, red alert 3, or steam to install correctly. im running windows 7 build 7000 x86. oh, and sorry in advance if these have already been answered, i looked as best i could through the forums beforehand.

aoe2 will play, but the colors are all messed up (red grass, purple water, etc.) I had this problem when i was running vista but i simply installed dx9 and it worked, this is not the case now. tried everything i could think of here.

for red alert 3 i boot the installer, enter the product key, then i get the "windows installer has stopped working".

for installing steam i just try to open steaminstaller.msi and i get an error message. ive looked through both the software and gaming forums for this one, saw several solutions (extracting the .msi and running steam.exe, using ccleaner to clear registry errors) and none worked. extracting did something, there were 2 application when i extracted and the second one updated steam or something. this might be helpful in case i did something wrong and was on the right track, i dont know.

oh, and fiddling with the compatibility or running as admin doesn't do anything for any of these, ive already tried that several times lol. oh, and i can paste the technical information that the reliability tool gave me if that helps.

My System SpecsSystem Spec
.

19 Jan 2009   #2

Windows 7
 
 

For AoE2, the color issue might can be fixed by disabling desktop composition, that's how I fixed SC colors back in Vista, but didn't help me much here in Win 7.
My System SpecsSystem Spec
22 Jan 2009   #3

Windows 7
 
 

i solved the steam issue, any more help guys?
My System SpecsSystem Spec
.


21 Apr 2009   #4

Windows 7
 
 
fix

for aoe2... i dont know why it works but it does for me...
If you have 'screen resolution' window open (right click->screen resolution) then run it, it seems to work! Try alt-tabbing back and forth to.
I have no idea why this works.
Also for ra3, try looking around ra forums... they will have answer. I installed ra3 on Windows 7 no problems.
It runs like **** on eee pc tho.
My System SpecsSystem Spec
25 May 2009   #5

Windows 7 RC
 
 

What did you do in order to get Steam running?

EDIT:
I was able to get things working by uninstalling Steam, extracting the .msi installer (use 7zip), copying those files to "C:\Program Files\Steam\", renaming "Steam.exe1" to "Steam.exe" and running.

Steam problems
My System SpecsSystem Spec
Reply

 Several issues (aoe2, ra3, steam)




Thread Tools



Similar help and support threads for2: Several issues (aoe2, ra3, steam)
Thread Forum
Strange issues with Steam? Gaming
Sound Priority Issues (Steam-iTunes) Sound & Audio
AoE2 and AOE2:Conquerors don't launch Gaming
Steam Launching Game Issues Gaming
AOE2 on Windows 7 Gaming
Steam Icon Issues Software
steam menu issues Gaming

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:30 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33