Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Major Problem with Starcraft

15 Sep 2009   #1
Smash

Windows 7 Build 7100 32 Bit
 
 
Major Problem with Starcraft

Running starcraft on a WIndows 7 7100 Build 32 Bit and it runs it with the messed up colors at loading screen when i make a single player game it works just fine, i can face computers, play campaign etc. When i connect to bnet and enter my pw/user name and enter a channel my monitor says "out of range" and about 3 seconds later i get blue screen and computer restarts. When i log back on windows i get this error message:

Problem signature:
Problem Event Name: BlueScreen
OS Version: 6.1.7100.2.0.0.256.1
Locale ID: 1033
Additional information about the problem:
BCCode: 116
BCP1: 8448C510
BCP2: 8C41D56A
BCP3: 00000000
BCP4: 00000002
OS Version: 6_1_7100
Service Pack: 0_0
Product: 256_1
Files that help describe the problem:
C:\Windows\Minidump\091509-17546-01.dmp
C:\Users\Cevin\AppData\Local\Temp\WER-32046-0.sysdata.xml


Also when i log into battle.net the text box where you type chat in has a grey outline on it and if needed i can post a s/s. Any help is greatly appreciated.


My System SpecsSystem Spec
15 Sep 2009   #2
zigzag3143

Win 8 Release candidate 8400
 
 

go into c:\windows\minidump, zip the dump file (*.dmp) and using the attachment icon (shaped like a paperclip) upload it to us so we can debug it.

Kene
My System SpecsSystem Spec
15 Sep 2009   #3
Smash

Windows 7 Build 7100 32 Bit
 
 

Getting this error when trying to zip it:

File not found or no read permission
My System SpecsSystem Spec
15 Sep 2009   #4
Smash

Windows 7 Build 7100 32 Bit
 
 



My System SpecsSystem Spec
16 Sep 2009   #5
Freelancer852

Windows 7 Professional SP1 64-bit
 
 

You can fix your messed up colors by killing explorer.exe while you're playing. And as a bonus you can expand your resolution if you have a monitor that's capable of an image larger than 640x480, check out the Resolution Expander that I've attached!

StarCraft Resolution Expander 5.1.zip

I bundled in a batch file that kills explorer.exe while you play, then lets you restart it after you're done!


My System SpecsSystem Spec
16 Sep 2009   #6
Smash

Windows 7 Build 7100 32 Bit
 
 

Quote   Quote: Originally Posted by Freelancer852 View Post
You can fix your messed up colors by killing explorer.exe while you're playing. And as a bonus you can expand your resolution if you have a monitor that's capable of an image larger than 640x480, check out the Resolution Expander that I've attached!

Attachment 28196

I bundled in a batch file that kills explorer.exe while you play, then lets you restart it after you're done!
Im getting error:

"Unable to inject DLL" when i press any key to continue
My System SpecsSystem Spec
16 Sep 2009   #7
zigzag3143

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by Smash View Post
Smash

the dump you zip'ed was caused by atikndag.sys. this is part of the ati driver. It is probably not current. best bet update the ati driver. Let us know if you need help either updating or if it doesn't fix the problem.

Ken

Microsoft (R) Windows Debugger Version 6.11.0001.404 X86
Copyright (c) Microsoft Corporation. All rights reserved.


Loading Dump File [C:\Users\K\Desktop\090909-24875-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Symbol search path is: SRV*d:\symbols*Symbol information
Executable search path is:
Unable to load image \SystemRoot\system32\ntkrnlpa.exe, Win32 error 0n2
*** WARNING: Unable to verify timestamp for ntkrnlpa.exe
*** ERROR: Module load completed but symbols could not be loaded for ntkrnlpa.exe
Windows 7 Kernel Version 7100 UP Free x86 compatible
Product: WinNt, suite: TerminalServer SingleUserTS
Built by: 7100.0.x86fre.winmain_win7rc.090421-1700
Machine Name:
Kernel base = 0x8280a000 PsLoadedModuleList = 0x82952810
Debug session time: Wed Sep 9 11:39:41.768 2009 (GMT-4)
System Uptime: 0 days 13:45:03.815
Unable to load image \SystemRoot\system32\ntkrnlpa.exe, Win32 error 0n2
*** WARNING: Unable to verify timestamp for ntkrnlpa.exe
*** ERROR: Module load completed but symbols could not be loaded for ntkrnlpa.exe
Loading Kernel Symbols
...............................................................
................................................................
.........
Loading User Symbols
Loading unloaded module list
.....
kd> !analyze -v
*******************************************************************************
* *
* Bugcheck Analysis *
* *
*******************************************************************************

VIDEO_TDR_FAILURE (116)
Attempt to reset the display driver and recover from timeout failed.
Arguments:
Arg1: 81e98510, Optional pointer to internal TDR recovery context (TDR_RECOVERY_CONTEXT).
Arg2: 8c23656a, The pointer into responsible device driver module (e.g. owner tag).
Arg3: 00000000, Optional error code (NTSTATUS) of the last failed operation.
Arg4: 00000002, Optional internal context dependent data.

Debugging Details:
------------------

*** WARNING: Unable to verify timestamp for dxgmms1.sys
*** ERROR: Module load completed but symbols could not be loaded for dxgmms1.sys
***** Kernel symbols are WRONG. Please fix symbols to do analysis.

*************************************************************************
*** ***
*** ***
*** Your debugger is not using the correct symbols ***
*** ***
*** In order for this command to work properly, your symbol path ***
*** must point to .pdb files that have full type information. ***
*** ***
*** Certain .pdb files (such as the public OS symbols) do not ***
*** contain the required information. Contact the group that ***
*** provided you with these symbols if you need this command to ***
*** work. ***
*** ***
*** Type referenced: nt!_KPRCB ***
*** ***
*************************************************************************
*** WARNING: Unable to verify timestamp for atikmdag.sys
*** ERROR: Module load completed but symbols could not be loaded for atikmdag.sys
*************************************************************************
*** ***
*** ***
*** Your debugger is not using the correct symbols ***
*** ***
*** In order for this command to work properly, your symbol path ***
*** must point to .pdb files that have full type information. ***
*** ***
*** Certain .pdb files (such as the public OS symbols) do not ***
*** contain the required information. Contact the group that ***
*** provided you with these symbols if you need this command to ***
*** work. ***
*** ***
*** Type referenced: nt!_KPRCB ***
*** ***
*************************************************************************
*************************************************************************
*** ***
*** ***
*** Your debugger is not using the correct symbols ***
*** ***
*** In order for this command to work properly, your symbol path ***
*** must point to .pdb files that have full type information. ***
*** ***
*** Certain .pdb files (such as the public OS symbols) do not ***
*** contain the required information. Contact the group that ***
*** provided you with these symbols if you need this command to ***
*** work. ***
*** ***
*** Type referenced: nt!_KPRCB ***
*** ***
*************************************************************************

ADDITIONAL_DEBUG_TEXT:
Use '!findthebuild' command to search for the target build information.
If the build information is available, run '!findthebuild -s ; .reload' to set symbol path and load symbols.

FAULTING_MODULE: 8280a000 nt

DEBUG_FLR_IMAGE_TIMESTAMP: 49b5d039

FAULTING_IP:
atikmdag+1056a
8c23656a 8bff mov edi,edi

DEFAULT_BUCKET_ID: GRAPHICS_DRIVER_TDR_FAULT

CUSTOMER_CRASH_COUNT: 1

BUGCHECK_STR: 0x116

CURRENT_IRQL: 0

STACK_TEXT:
WARNING: Stack unwind information not available. Following frames may be wrong.
8a699b74 8c70716c 00000116 81e98510 8c23656a nt+0xdbf28
8a699b98 8c707f8b 8c23656a 00000000 00000002 dxgkrnl+0x8d16c
8a699bbc 8c73792c 00000000 00000102 81fe1008 dxgkrnl+0x8df8b
8a699c34 8c761a32 fffffcfb 003056d6 00000000 dxgmms1+0x692c
8a699c5c 8c762153 00000000 00000000 00000000 dxgmms1+0x30a32
8a699c98 8c73e8f0 8a699c90 8283ba3e 81fe1008 dxgmms1+0x31153
8a699d28 8c7634b7 81fe1008 8283ba3e 81fe1008 dxgmms1+0xd8f0
8a699d3c 8c763573 81fe1008 00000000 81fe6948 dxgmms1+0x324b7
8a699d50 82a04bc3 81fe1008 91aaca09 00000000 dxgmms1+0x32573
8a699d90 828c7e29 8c7634f4 81fe1008 00000000 nt+0x1fabc3
00000000 00000000 00000000 00000000 00000000 nt+0xbde29


STACK_COMMAND: .bugcheck ; kb

FOLLOWUP_IP:
atikmdag+1056a
8c23656a 8bff mov edi,edi

SYMBOL_NAME: atikmdag+1056a

FOLLOWUP_NAME: MachineOwner

MODULE_NAME: atikmdag

IMAGE_NAME: atikmdag.sys

BUCKET_ID: WRONG_SYMBOLS

Followup: MachineOwner
---------
My System SpecsSystem Spec
16 Sep 2009   #8
Freelancer852

Windows 7 Professional SP1 64-bit
 
 

Quote   Quote: Originally Posted by Smash View Post
Quote   Quote: Originally Posted by Freelancer852 View Post
You can fix your messed up colors by killing explorer.exe while you're playing. And as a bonus you can expand your resolution if you have a monitor that's capable of an image larger than 640x480, check out the Resolution Expander that I've attached!

Attachment 28196

I bundled in a batch file that kills explorer.exe while you play, then lets you restart it after you're done!
Im getting error:

"Unable to inject DLL" when i press any key to continue
Do you have UAC enabled? You might need to set InsectLoader.exe to run as Administrator in the Properties > Compatibility Mode tab.

However, as suggested you should first try updating your ATI drivers.
My System SpecsSystem Spec
14 May 2010   #9
Gengaeldelse

Window 7 64 bit
 
 

If i'm necroing a thread, I apologize in advance. I download your version of Resolution Expander and followed your instructions for Windows 7 and I'm getting an error:

The instruction at 0x6b644a14 referenced memory at 0x6b644a14. The memory could not be written.

Know of a resolution for this?

Thanks

Edit: Got it working; however, are they menus and mission briefing still supposed to be 640x480 in the top left corner?
My System SpecsSystem Spec
Reply

 Major Problem with Starcraft




Thread Tools





Similar help and support threads
Thread Forum
problem in game starcraft 1
hi when run this game i have this picture.but when run pes 2012 I have no problem. my laptop is asus u43jc. please help me. http://shareyourimage.com/images/6RmYL.jpg
Gaming
Possible File Association Problem or Open With Problem! MAJOR
Apologies if this is not the appropriate catagory but i had trouble finding a suitable one, here is my problem: I was messing about with a file using winrar, (sorry i cant remember which file it was) i right clicked the file and clicked 'open with' i chose winRAR and it screwed up and decided...
Software
Starcraft and broodwar launch problem (Windows 7)
Hi, I was trying to play starcraft on my toshiba laptop with windows 7 SP1 but the game crashed upon launch and at the part where the blizzard cinematic should appear(instead its just a cloud of pixels on the screen and then the game crashes). The games work fine on my other computers vista and...
Gaming
Major Problem
hi i have a problem with my pc my pc was working ok until 4.3.11 i came from school and turnd on my pc, everything was ok until desktop. Pc logd in and i were on desktop about 10 sec then BSOD came up. Then i restarted and it was ok but every time i shut down my Pc it wont let my do anything...
BSOD Help and Support
Starcraft Sreen Size problem help!
Hello all, I don't know much about specifics of comps and such but i just got a new laptop with windows 7 and when i run starcraft the screen is in the middle of my monitor and only about half the size with black borders surrounding it. I need to make it full screen!! Please help!!
Gaming
Major problem!
As of yesterday my xbox 360 reciever was fine and showed in devices and hardware. today it says it has been disabled beceause it had a problem? ,unfortunately it wont show so i cant use a trouble shooter ,tried reinstalling controller software ,no good, windows update says the driver was installed...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:32.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App