Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Age of Empires 2 corrupt colors

20 Sep 2012   #1

Windows 7 Professional x64 w/SP1
 
 
Age of Empires 2 corrupt colors

EDITED at bottom of post

I have a HP Pavilion dv6t-6100 CTO laptop set up with switchable graphics.
The iGPU is the Intel HD 3000
The dGPU is an AMD Radeon HD 6770m
I've set the switchable graphics mode to "Fixed" in the BIOS.

When I try to play the game with the dGPU, it looks almost like the first couple of pixels on one side were dragged across the screen, so it's entirely unplayable and I can't get past the main menu because of this (however I can click where buttons are supposed to be and the game reacts with the correct sound)

When I try to play with the iGPU, the main menu is fine, but in game the colors are all wrong. For instance, the screenshot was taken while using the iGPU (not sure why it's not showing the colors wrong though) and on the minimap the color that's supposed to be sky-blue shows up as yellow, and the magenta/purple shows as blue. The grass has a bunch of pixels that show up as red, and in the water, you see just past the shore where the water is really light blue? There's a bunch of magenta pixels in there. And the deep parts have a lot of really dark purple pixels.
  • I've already updated my display drivers
  • Direct x and all the other stuff like that are all up to date
  • I've tried the "end explorer.exe" trick
  • I've tried running in compatibility mode for Windows
    • 95, 98/ME (these crash it every time)
    • NT 4.0 Service Pack 5 (this ALWAYS requests that I insert the CD, even when the physical disc is inserted)
    • All other modes render the above results
  • Run in 256 color
  • I've changed my resolution to run 16 bit, which doesn't help, and 8 bit, which returns an "unsupported" error (understandable)
  • Run with visual themes and desktop composition disabled
  • A large assortment of combinations of these
  • This is a legit, store bought copy

Any help would be greatly appreciated, and I've made a disc image so I can insert or remove files if I need to.

this is what my screen looks like http://img4.imageshack.us/img4/6167/140520091107.jpg

EDIT:
As I posted this in the midst of my frustration with the issue, I was still looking around on the web for a solution. However, I found that changing my Windows theme to Classic, as suggested by adamzx, solved the bad colors issue.
My issue with the dGPU (a little better described here) has yet to be resolved



Attached Thumbnails
Age of Empires 2 corrupt colors-empires2-2012-09-20-21-03-50-91.png  
My System SpecsSystem Spec
.

Reply

 Age of Empires 2 corrupt colors




Thread Tools



Similar help and support threads for2: Age of Empires 2 corrupt colors
Thread Forum
Will my computer run Age Of Empires 3?? General Discussion
Age of Empires II: The Conqueror Gaming
Age of Empires II: The Conqueror's will not run Gaming
Age of empires Gaming
Age of Empires - Age of Kings Gaming
Age of Empires II Gaming
Age of Empires III! [ALL] Gaming

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:52 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33