Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Battle for Middle Earth 2 startup problems

03 Oct 2012   #1
Pyroelk

Windows 7 64 bit
 
 
Battle for Middle Earth 2 startup problems

I recently purchased BFME 2 and it will not start up. After I click on the application icon the program begins to boot up and the initial game window (the one seen below) pops up. But then nothing else happens. That screen will stay up for a little while and then crash itself.




Attached Thumbnails
-frdg.png  
My System SpecsSystem Spec
.

03 Oct 2012   #2
DanRex

Windows 8 Pro 64-Bit
 
 

Hello, And welcome to SevenForums! Please post your system specs to your profile please, they will help answering!
Also, do you get any error messages?
What I would suggest is to do a complete reinstall of the game, and check that your drivers are up to date.
My System SpecsSystem Spec
03 Oct 2012   #3
Pyroelk

Windows 7 64 bit
 
 

I just updated a few of my specs.

There are no error messages. This is my third time reinstalling.

Which drivers do you suggest checking?
My System SpecsSystem Spec
.


03 Oct 2012   #4
Richardc269

Windows 7 Ultimate 32-Bit
 
 

Video primarily. Have you tried starting the game with admin rights? Or maybe set it up with other compatibility options?
My System SpecsSystem Spec
03 Oct 2012   #5
DanRex

Windows 8 Pro 64-Bit
 
 

Yes, your Graphics Card. But others might also be good to check as they may too cause the problem.
But try the following things:

-Right-click on the program icon and go to "Properties." In the "Compatibility" tab, check the "Run in compatibility mode for:" box and choose "Windows XP Service Pack 2".

-Right-click on the program icon and go to "Properties." In the "Compatibility" tab, check the "Run this program as an administrator" box.

If they don't work, try this fix: http://www.gamefront.com/windows-7-6...rth-2-fix-mod/
My System SpecsSystem Spec
05 Oct 2012   #6
Pyroelk

Windows 7 64 bit
 
 

I have checked my drivers and they are all up to date. I also tried the admin solutions you presented but neither has shown any change. You also added that link to another solution. I have seen this solution many times and I have a feeling that it would work but when I look for the "My Battle for Middle Earth II Files" folder under C:/Users/[my name]/AppData/Roaming it is not there. I have tried re-installing the program to see if it would then create the file, but it was to no avail. Is there any way I can create/download/link this file to the program?
My System SpecsSystem Spec
05 Oct 2012   #7
DanRex

Windows 8 Pro 64-Bit
 
 

OK! Probably, the folder may be hidden. Try this:

Click Start > Computer > Hold ALT + T to get the tools menu open > Folder Options > View > Enable "Show hidden files, folders and drives" and Untick "Hide protected operating system files".

Now, try finding AppData.
You could also do a reinstall (again), but turn your AntiVirus OFF while the installation is in progress.
My System SpecsSystem Spec
08 Dec 2012   #8
Pyroelk

Windows 7 64 bit
 
 

Fiddle sticks. This is my 6th time reinstalling (and anti-virus was off) the My Battle for Middle Earth II Files folder is still not there and when I try to create it myself it makes no difference
My System SpecsSystem Spec
08 Dec 2012   #9
Pyroelk

Windows 7 64 bit
 
 

Also I don't know if this has anything to do with it, but when I try to download the patches for he first time I get and error saying "file not found"
My System SpecsSystem Spec
08 Dec 2012   #10
AstaLaVista

Windows 7 x64 (Ultimate)
 
 

Perhaps you installed the game on another drive and not the default drive and this is why the patches can't find it?

Also, perhaps this is a steam or origin game and you must install and login first? Just random thoughts here. Also, make sure you have the exe file enable on your firewall, it may be preventing the game to call home.
My System SpecsSystem Spec
Reply

 Battle for Middle Earth 2 startup problems




Thread Tools





Similar help and support threads
Thread Forum
LOTR Battle For Middle Earth 2
Loaded LOTR Battle for Middle Earth 2 and its expansion pack The Rise of the Witch-King. Patched both games before trying to play them. When the game loads i only get to the loading screen before it crashes/fails to load. Have updated all drivers for video card, sound card and so on. Computer...
Gaming
Can Windows 7 RUN Battle for middle earth 2?
Simple question, I want to buy it off amazon but don't want to waste the $50.00 US dollars if it isn't going to work. I ask this because I heard from somewhere since Battle for middle earth 2 is a windows XP game it wont run properly on windows 7 format. A word of caution, i'm not really...
Gaming
Battle for Middle Earth 2 error?
When I want to run the game, I keep getting an error. I created the folder from AppData, even the options.ini file but it keeps crashing!(Note: when I had Windows XP it was working perfectly) On my PC I have: Windows 7 Ultimate 32 bit Intel(R) Celeron(R) CPU 2.66GHz 2.67GHz 1,50 RAM...
Gaming
Lord of The Rings: Battle For Middle-Earth II has problems starting
Hey Windows 7 users and gamers, I was wondering if you could help me out with a problem I'm having with LOTR:BFME2. When I click on the icon in the computer window it starts to launch the game. It gives me the window with all the options for BFME2 (like "PLAY" or "CHECK FOR UPDATE") but when I...
Gaming
The Battle for Middle-earth (tm) II - Elvenstar
have aproblem with install The Battle for Middle-earth (tm) II - Elvenstar on windows seven 86 bit:(:( I had install the game, but the game not start's:( than crashes... wath can i do:( :(:cry: http://b.pix.ge/n/61hz7.png
Gaming
LOTR Battle for Middle Earth
Ive look all over and it seems that only the 32bit Win7 will run this? I dont have the expansion pack (BfME2) installed yet. All i get are the two splash screens and the 2nd core of my CPU goes to 100% and it just hangs until i stop it.
Gaming

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:12.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App