Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Age of Empires 3 Problem

21 Sep 2009   #1
AlexRD

Windows 7 Professional x64
 
 
Age of Empires 3 Problem

Hi

My friend and i wanted to play Age of Empires 3 on the lan, and we were having some problems.
First: We go on LAN, and no one sees each other, even though we tried to connect to each other every possible way.
Wires, wireless...
Second: My friend is using XP and i am using windows 7.

We got another XP machine, and it worked fine on lan, with the same PC my friend used.
The IP on XP machine that worked was 192.168.0.1
And in windows 7 : 192.168.1.1


Please, help me, i really want to play with him on LAN.

Any suggestion, ANY, will do it.


Thanks,
Alex.


My System SpecsSystem Spec
.

21 Sep 2009   #2
DeaconFrost

Windows 7 Ultimate x64 SP1
 
 

First, it seems like there could be a problem with the IP addresses. How are the assigned? They should be on the same subnet, which might account for why they can't see each other. If you are hardcoding the addresses, make sure you have them on the same subnet, such as 192.168.0.2 and 192.168.0.3, if, for example, your router is 192.168.0.1.

You always want to try pinging the other machines by IP before launching the game, just to make sure they will see each other.
My System SpecsSystem Spec
21 Sep 2009   #3
AlexRD

Windows 7 Professional x64
 
 

Quote   Quote: Originally Posted by DeaconFrost View Post
First, it seems like there could be a problem with the IP addresses. How are the assigned? They should be on the same subnet, which might account for why they can't see each other. If you are hardcoding the addresses, make sure you have them on the same subnet, such as 192.168.0.2 and 192.168.0.3, if, for example, your router is 192.168.0.1.

You always want to try pinging the other machines by IP before launching the game, just to make sure they will see each other.

Look, what do i have to change?
Everything is automatic, i trying to change the SUBNET but it wont accept the 192.168.0.2 as SUBNET MASK, only 255.255.255.0
Windows 7 is using Cables and XP Wireless
My System SpecsSystem Spec
.


21 Sep 2009   #4
DeaconFrost

Windows 7 Ultimate x64 SP1
 
 

The third digit dictates what subnet it is on...not directly related to the subnet mask. Look at the third digits of your IP addresses. One is one and the other is zero. That's not going to work. You shouldn't be seeing this on a home network if both computers are getting their address from DHCP running on the router. Either set them both to DHCP, or hardcode both computers to a legit address outside of the DHCP scope. Look at my example above for how they should be addressed, whether it be DHCP or static (hardcoded).
My System SpecsSystem Spec
Reply

 Age of Empires 3 Problem




Thread Tools





Similar help and support threads
Thread Forum
Age of Empires II color problem (not the common one)
hey! I'm having trouble with age of empires II: the conquerors =/ I got laptop (win 7 home premium x64) and all I have to do is kill explorer.exe to run the game without any trouble (the common color bug). but I recently bought a new stationary computer (also win 7 home premium x64). the problem...
Gaming
Trying to play age of empires 3 but encountered msxml 4.0 problem
msxml 4.0 was not installed properly or not compatible or some crap like that. I am very annoyed. I lost my case and disk but have the game file still. So when i click on the app, it says C:\Windows\Syswow64\mssxml4.dll is either not designed to run on windows or it contains an error. Then in says...
Gaming
Age of empires
Can some please tell me if age of empires, will play using windows 7? Thanks, Sarah.
Gaming
Problem installing Age of Empires online
Hey guys, I have a problem when i try download or install age of empires. I start the setup and secs later he show me this error: http://imageshack.us/photo/my-images/88/ageyt.png/ I have already installed the update for windows (Service Pack 1), thinking that was the problem, but still...
Gaming
Problem with Age of empires 3 help please
well i just instaled aoe3 and when i said "launch" it did this thing with compadability. i first said to check for solutions but it couldnt find any, so i said "run any way". when i do this the screen changes and says "adjsting screen colour" or some thing like that. then a error message pops up...
General Discussion
Age of Empires II
Hi, I have a problem with Windows 7. I can play Age of Empires II, because the whole picture is green! The video is up to date,knows someone who is wrong? Thx
Gaming

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 22:51.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App