Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Lag issues


19 Oct 2012   #1

windows 7 home
 
 
Lag issues

Hi there i recently built a pc and when i try play any game i get massive lag on lowest settings even offline my graphics card is poor but it should run games on low settings easily
any help would be greatly appreciated thanks!


My System SpecsSystem Spec
.

20 Oct 2012   #2

windows 7 home
 
 

Anyone?
My System SpecsSystem Spec
20 Oct 2012   #3

 

hi,

your CPU is fine, but your graphics card is really a low-end one.
What games are you trying to run? and at what resolution?
My System SpecsSystem Spec
.


20 Oct 2012   #4

windows 7 home
 
 

Quote   Quote: Originally Posted by Dorado View Post
hi,

your CPU is fine, but your graphics card is really a low-end one.
What games are you trying to run? and at what resolution?
Hi mate thanks for the reply my cousin gave me this card he was playing left for dead and arma 2 with no lag on medium settings but when i try play them on lowest settings its constant lag like choppy 1 fps at most i tried slender too same lag and the graphics in that game are bad anyway
My System SpecsSystem Spec
20 Oct 2012   #5

 

Quote   Quote: Originally Posted by Wulbo View Post
Quote   Quote: Originally Posted by Dorado View Post
hi,

your CPU is fine, but your graphics card is really a low-end one.
What games are you trying to run? and at what resolution?
Hi mate thanks for the reply my cousin gave me this card he was playing left for dead and arma 2 with no lag on medium settings but when i try play them on lowest settings its constant lag like choppy 1 fps at most i tried slender too same lag and the graphics in that game are bad anyway
you're welcome!
don't expect major performance with the Radeon HD 5450, it is really a basic card. However it should be more than enough for these games... What resoultion are you currently using?

Also have you tried to update AMD Catalyst drivers? These are the link to update them:

for Windows 7 32 BIT ONLY: AMD Catalyst
for Windows 7 64 BIT ONLY: AMD Catalyst

download and install "Catalyst Software Suite"
My System SpecsSystem Spec
20 Oct 2012   #6

windows 7 home
 
 

Quote   Quote: Originally Posted by Dorado View Post
Quote   Quote: Originally Posted by Wulbo View Post
Quote   Quote: Originally Posted by Dorado View Post
hi,

your CPU is fine, but your graphics card is really a low-end one.
What games are you trying to run? and at what resolution?
Hi mate thanks for the reply my cousin gave me this card he was playing left for dead and arma 2 with no lag on medium settings but when i try play them on lowest settings its constant lag like choppy 1 fps at most i tried slender too same lag and the graphics in that game are bad anyway
you're welcome!
don't expect major performance with the Radeon HD 5450, it is really a basic card. However it should be more than enough for these games... What resoultion are you currently using?

Also have you tried to update AMD Catalyst drivers? These are the link to update them:

for Windows 7 32 BIT ONLY: AMD Catalyst
for Windows 7 64 BIT ONLY: AMD Catalyst
Yeah mate i've updated my drivers didn't make a difference im running everygame on the lowest possible settings like u said i know its a bad card but should run ths gams on low sttings easily
My System SpecsSystem Spec
20 Oct 2012   #7

 

what resolution are you using?
My System SpecsSystem Spec
20 Oct 2012   #8

windows 7 home
 
 

Quote   Quote: Originally Posted by Dorado View Post
what resolution are you using?
in game resolution is the lowest possible like 800x600 or something i tried every resolution in the games and they all lag
My System SpecsSystem Spec
20 Oct 2012   #9

 

have you tried to disable Aero effects before starting the games? also try to run the games in Windows XP SP3 compatibility mode.
My System SpecsSystem Spec
20 Oct 2012   #10

windows 7 home
 
 

Quote   Quote: Originally Posted by Dorado View Post
have you tried to disable Aero effects before starting the games? also try to run the games in Windows XP SP3 compatibility mode.
Where do i find the settings form aero? i dont know what u mean by windows xp mode.I used old sata cables from my old pc but that shouldn't make a difference should it?
My System SpecsSystem Spec
Reply

 Lag issues




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:31 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33