Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Would Bioshock work on my pc?

30 Sep 2009   #11

Windows 7 Ultimate 32bit

Nope doesnt work. I installed the game and patched the shader file. When i run the game i can see the intro to the game with the nvidia logo and 2k games logos but then it just stucks on a black screen.

My System SpecsSystem Spec

 Would Bioshock work on my pc?

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
BioShock Infinite
Hi does anyone know how can i check my fps on BioShock Infinite i am at ultra high settings and i want to know what fps im getting can anyone tell me please how i can turn on my fps in BioShock Infinite thanks a lot
BioShock 2
can anyone give me there views on this game please? :D
Bioshock and GEF
For some reason, my bioshock icon is blank in the GEF. I checked and it also is in the main directory for some reason. How can I go about changing this. I don't need it to appear in the main directory but really need it to show in GEF. I've tried adding "BoxArt" string to regedit and typing...
BioShock Infinite
So did anybody see this? Irrational Games released a trailer of their current game. It's a new BioShock by the name of Infinite. It's setting... A city called Columbia... in the clouds. Don't know what I think about it at the moment to be honest. The trailer looks cool but not the BioShock I...
For some reason, I cant seem to hear any sound during game play of Bioshock, but the weird thing is, during cut scene movies, there is sound. Anyone experience this problem before?
BioShock issue
I'm running Windows 7 RC Build 7100 64-bit with a Q6600 9800GT and 8GB ram I bought BioShock on Direct2Drive today due to the sale they had on it. It installs runs but it gets stuck on the first loading screen and hangs and I have to kill the process? Any ideas?

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:46.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App