Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Problems with Age of Empires 3


05 Dec 2012   #1

Windows 7 Professional x64 Sp1
 
 
Problems with Age of Empires 3

I recently upgraded from Intel HD graphics to an Nvidia GTX 650ti I have found that i had better performance with the integrated graphics than I have with the card. I was wondering if there was any fix.


My System SpecsSystem Spec
.

Reply

 Problems with Age of Empires 3




Thread Tools



Similar help and support threads for2: Problems with Age of Empires 3
Thread Forum
Multiplayer problems with Age of empires II Gaming
Age of empires Gaming
Age of Empires II Gaming
Age of Empires II Problems Gaming
Age of empires 3 problems Gaming
Age of Empires III! [ALL] Gaming
age of empires II conquerors Gaming

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:20 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33