Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: age of Empire 2 EN LJ 65 laptop runs slowly

06 Jan 2013   #1

windows 7 32 bit
age of Empire 2 EN LJ 65 laptop runs slowly

age of empire 2 runs very slowly on my EN LJ 65 laptop.

It starts in the menu and it takes a long time to switch hotkeys. When im playing it runs rather smoothly in the beginning but when more units is on the map the game responds very slowly.

None of my friends have the same issue so it must be the computer.

This thread seem to have the same issue
Old games have lag spikes

but i want to make sure i dont screw up any settings if its dfifferent on my laptop.

thanks for the help

My System SpecsSystem Spec

06 Jan 2013   #2


Hi there Welcome to Seven Forums,

Can you provide your computer specs? OR the Make and model of your laptop?

It sounds like your laptop or graphics card can not handle the game.

Please provide the specs in order for me to confirm this.
My System SpecsSystem Spec
06 Jan 2013   #3

windows 7 32 bit

the laptop is model EN LJ 65 so it should be able to run the game smoothly. =/

Im not sure how to post the computer specs ^^

My System SpecsSystem Spec


 age of Empire 2 EN LJ 65 laptop runs slowly

Thread Tools

Similar help and support threads
Thread Forum
Laptop running very slowly with 0% cpu usage
My Acer laptop started to run extremely slowly, taking several minutes to do simple things as opening a folder or Google Chrome D: I dont think my CPU or my RAM is a problem, since it is using about 0% cpu usage and 30% of my RAM. I have run several anti-virus scans with both Avast! and...
Hardware & Devices
WIN7 x64 - Uses all available RAM, runs slowly
Hi all, pardon the newbie question. If this has been answered already please point me that way? I did do a search but found nothing to help. My system is a home built, Core I7, 8GB RAM, Radeon 560 TI with 2GB VRAM. Recently upgraded from 4GB RAM. I was having this same issue with 4GB of...
General Discussion
Windows 7 x64 installs and runs slowly
I am trying to upgrade my wife's computer to Windows 7 x64 from Windows Vista x32. It has run great for the past 3 years using Vista 32bit. The system shows it should run x64 bit no problems. I've already run the Windows 7 Upgrade adviser that also says I should have no problems. However...
Installation & Setup
replaced rj45 lan input with a new lan card but runs very slowly
My motherboard is an Asus M3A78-EM and I have been using the system with the built in lan rated at 10/100/1000 mbps. The socket seems to be going bad so I tried replacing it with another internal card. They only had two to choose from at Office Depot were rated at 10/100/ mbps. and the other which...
Network & Sharing
Virus? Computer runs extremely slowly!
Hi, I hope this is the right place to post. If not, I apologise, let me know and I'll move it to where it should be. Thanks! Basically, I'm having major problems with my computer of late, and the troubles all started a few weeks ago when I got a virus. I don't know much about getting rid of...
System Security
Why runs slowly when i have 2GB RAM and P4 2.8 Ghz ?
Hello everybody I have problem with Windows 7 on PC computer. IT runs slowly even i turn on clasic view and turned off all effects... My PC is: Pentium 4 2.8 Ghz RAM 2GB Motheroard - AsRock Video - Nvidia GeForce 7600 - 512Mb WIndows installed on Sata HDD 40GB, in system there is more two HDD...
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:36.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App