Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: age of Empire 2 EN LJ 65 laptop runs slowly


06 Jan 2013   #1

windows 7 32 bit
 
 
age of Empire 2 EN LJ 65 laptop runs slowly

Hi,
age of empire 2 runs very slowly on my EN LJ 65 laptop.

It starts in the menu and it takes a long time to switch hotkeys. When im playing it runs rather smoothly in the beginning but when more units is on the map the game responds very slowly.

None of my friends have the same issue so it must be the computer.

This thread seem to have the same issue
Old games have lag spikes

but i want to make sure i dont screw up any settings if its dfifferent on my laptop.

thanks for the help
/mattias

My System SpecsSystem Spec
.

06 Jan 2013   #2

Windows 7
 
 

Hi there Welcome to Seven Forums,

Can you provide your computer specs? OR the Make and model of your laptop?

It sounds like your laptop or graphics card can not handle the game.

Please provide the specs in order for me to confirm this.
My System SpecsSystem Spec
06 Jan 2013   #3

windows 7 32 bit
 
 

the laptop is model EN LJ 65 so it should be able to run the game smoothly. =/

Im not sure how to post the computer specs ^^

thx
My System SpecsSystem Spec
.


Reply

 age of Empire 2 EN LJ 65 laptop runs slowly




Thread Tools



Similar help and support threads for2: age of Empire 2 EN LJ 65 laptop runs slowly
Thread Forum
Solved Laptop running very slowly with 0% cpu usage Hardware & Devices
WIN7 x64 - Uses all available RAM, runs slowly General Discussion
Solved Windows 7 x64 installs and runs slowly Installation & Setup
replaced rj45 lan input with a new lan card but runs very slowly Network & Sharing
Computer runs very slowly, apparently after new Router was connected. Performance & Maintenance
Virus? Computer runs extremely slowly! System Security
Why runs slowly when i have 2GB RAM and P4 2.8 Ghz ? Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:28 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33