Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Need for Speed: Shift; not working


04 Oct 2009   #1

Windows 7, Build 7100
 
 
Need for Speed: Shift; not working

Well i try to play nfs:s obviously.....the installation ran smoothly without problems but when i click the application for nfs:s it directly becomes (not responding) and i have to either (check for solution online) or (close program)



Attached Images
 
My System SpecsSystem Spec
.

04 Oct 2009   #2

Windows 7 x64 (Ultimate)
 
 

I am assuming your video, audio & monitor drivers are up to date?

Have you checked online for a solution or it doesn't give you any? Typical that it won't

Some games don't like to run with Overclocked machines, more so those that are badly coded or cheap PC ports
My System SpecsSystem Spec
08 Oct 2009   #3

 

I have the exact same problem, the game loads just fine, but when i start a race, and are about to take off it freezes. I searched the net and found a little tweak, that kinda worked, now i can drive for 30 seconds before freezing. I really hope someone has the solution for this problem, cause i really wont to fix this. In the start there wasnt no problems loading tracks, driving etc, i found out it might have something to do with the graphicsconfig.xml, but it wasnt it
My System SpecsSystem Spec
.


08 Oct 2009   #4

 

This is the solution:

Don't know if this will help but don't hurt to try. Edit your graphicsconfig ( goto C:\users\yourname\documents\NFS SHIFT\

I edit mine to this =
<xml version="1.0" ?>
<Reflection>
<class name="BRTTIRefCount" base="root class" />
<class name="BPersistent" base="BRTTIRefCount">
<prop name="Name" type="String" />
</class>
<class name="GraphicConfigData" base="BPersistent">
<prop name="Mode" type="Fct" />
<prop name="Vsync" type="Fct" />
<prop name="Windowed" type="Fct" />
<prop name="TextureFilter" type="Fct" />
<prop name="TextureResolution" type="Fct" />
<prop name="Brightness" type="Fct" />
<prop name="CarDetailLevel" type="Fct" />
<prop name="TrackDetailLevel" type="Fct" />
<prop name="ShadowDetailLevel" type="Fct" />
<prop name="MotionblurLevel" type="Fct" />
<prop name="EffectsDetailLevel" type="Fct" />
</class>
<data class="GraphicConfigData" id="0xBB11E0">
<prop name="Name" data="" />
<prop name="Mode" adapter="0" width="1024" height="768" antialias="8" refresh="75" />
<prop name="Vsync" vsync="0" />
<prop name="Windowed" windowed="0" />
<prop name="TextureFilter" texturefilter="0" />
<prop name="TextureResolution" textureresolution="0" />
<prop name="Brightness" brightness="10" />
<prop name="CarDetailLevel" cardetaillevel="0" />
<prop name="TrackDetailLevel" trackdetaillevel="0" />
<prop name="ShadowDetailLevel" shadowdetaillevel="0" />
<prop name="MotionblurLevel" motionblurLevel="0" />
<prop name="EffectsDetailLevel" effectsdetaillevel="2" />
</data>
</Reflection>

Also in game settings goto custem controler and set your keys up ( I use xbox360 pad ) and did not set the online player name key or gears.

Started the game and its working fine, you can change your settings higher when ever you like ( dont know if it will crash mine ) but the above got the game going for me.

Well hope it works for all or some like it has me, and good luck.

And I am using the onboard geforce 8200 in hybrid with 8400gs using nforce 15.26 drivers.

Source: Got mine working at last - Need for Speed Technical Help - Need for Speed: EA Forums

As you see on the source site it has helped a lot of people, so it is worth a try

Also seems like the eye candy can be turned on again after this:

Quote: I have done this too , afterwards i have changed my ingame settings back to some more eyecandy and my game is still working.
Thanks for this tip , have been searching for awhile and was getting pretty frustrated.


Edit: Sorry about the missing < It is edited now
My System SpecsSystem Spec
09 Oct 2009   #5

Windows 7, Build 7100
 
 

Well i thank you for trying but the thing is i cant even START the game before it crashes. imagine that u click on the application to start game and it crashes 1 second after you click
My System SpecsSystem Spec
09 Oct 2009   #6

 

Quote   Quote: Originally Posted by nikkula View Post
Well i thank you for trying but the thing is i cant even START the game before it crashes. imagine that u click on the application to start game and it crashes 1 second after you click
You could try to make a thread at the EA Technical help forum (See source in previous post), there is probably more people that know about this than us.
My System SpecsSystem Spec
26 Sep 2011   #7

Windows 7
 
 

I have the same problem. The file graphicsconfig.xml is overwritten every time I run the game, no matter how I change the data manually.
My System SpecsSystem Spec
10 Dec 2011   #8

Win 7
 
 

what worked for me was uninstalling Nvidia PhysX and installing the latest one from

PhysX 9.11.1107

have fun
My System SpecsSystem Spec
14 May 2012   #9

windows 7 home basicX64
 
 

thanx bro this thing worked for me I hope it works for others even...
My System SpecsSystem Spec
14 May 2012   #10

Windows 7 Home premium 64bit SP1
 
 

Quote   Quote: Originally Posted by SuperFreak View Post
I have the same problem. The file graphicsconfig.xml is overwritten every time I run the game, no matter how I change the data manually.
Try making the file read only by right clicking the file and then clicking properties then tick the box next to read only. I had to do that to keep black ops from changing my custom settings in the file at start up.

EDIT:LOL i just noticed it was a Necro post anyways will leave it anyways just in case somebody stumbles among this.
My System SpecsSystem Spec
Reply

 Need for Speed: Shift; not working




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:50 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33