Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Mass effect glitch???


24 Mar 2013   #11

 

Oh that's ME1, I never had problems with ME3, I thought you were talking about ME3.

My System SpecsSystem Spec
.

1 Week Ago   #12

Windows 7 Home Premium x64
 
 

Just to say, this is still an ongoing problem with AMD drivers. It isn't the drivers' fault so much as the fault of Mass Effect for not recognising or being thoroughly tested on them!

I am having the identical issue in the identical location. I admit my GPU is on the older side, but it's hefty - 2GB I believe (at least 1GB) with a quad-core 2.5GB processor along with it. To put it into perspective, I run Mass Effect 3 just fine..

Will be trying the fix in this thread myself and I'll post again if it doesn't work out!
My System SpecsSystem Spec
Reply

 Mass effect glitch???




Thread Tools



Similar help and support threads for2: Mass effect glitch???
Thread Forum
Mass Effect Gaming
mass effect 3 Gaming
Mass Effect 2 Help please. Gaming
Mass effect 2 problem Gaming
Mass Effect 1 Gaming
Mass Effect Gaming
Mass Effect on 6801 Gaming

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:11 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33