Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Good ping but extreme lagging in Battlefield 2

12 Oct 2009   #11

Windows 7 x86/x64, Server 2008r2, Web Server 2008

Hope all works out for you. I may not be able to get on tonight im going home to apply for a job down there I should be back within the next 48 hours.

My System SpecsSystem Spec
12 Oct 2009   #12

Windows Seven Pro

@mckillwashere : Thx for your help mate, i hope it will work for you
My System SpecsSystem Spec
12 Oct 2009   #13

Windows 7 x86/x64, Server 2008r2, Web Server 2008

What kind of router are you using? have you manually set the MTU size to 1500?
(I'm racking my mind for every last thing that can cause lag or slowdown for online games lol)
have you tried cunning it in vista or xp compatibility, (not xp mode).
Have you threatened your computer with gasoline and a match? (Jking)
Im assuming you did a fresh install not an upgrade from vista or xp? Upgrades tend to cause issues.
Installed the latest compatibility patch? (MS actually has been releasing them I just forget what they are called)
Enabled wait for vertical sync? (it may help some, If its on turn it off)
My System SpecsSystem Spec

12 Oct 2009   #14

Windows 7 RC 7100 x64

I used to be a very heavy BF2 gamer (just shy of 1000 gameplay hours :P) and recall having a similiar issue back when I was on XP where I would look Right 40 degrees or so and then it would move a further 40 degrees without me moving the mouse (80 in total).
I dont remember a specific fix for this unfortunately. Have you tried to re-install the game? I seem to remember that fixing alot of problems for me.
Other than that it seems like a connection issue.

I am currently on Win7 RC 7100 and have BF2 installed and can run it online and offline without issue.

Also make sure that you update your Motherboard drivers from the stock Windows 7 drivers. Win 7 can make your hardware work but wont nessessarily make it work well.
My System SpecsSystem Spec
13 Oct 2009   #15

Windows Seven Pro

@mckillwashere : I am under the router provided by a Freebox ( famous french connection box ). I haven't modified any parameters and i haven't any reason to do this because it's ok on the same PC under Windows XP or Vista. I have tried the compatibility mode but the game refused to run ... and it's a fresh install of Windows Seven Pro ^^ ( same issue with Windows Seven RC 7100 ). Hummm ... threat my computer may be a solution

@sleek : 1000 gameplay hours ... OMG xD. Well, your problem looks like mine but i have already reinstall the game ( so many times ! lol ). I think you are right, my motherboard seems to be not 100% compatible with Windows Seven ... I have just bought a new network controller, i am waiting to receive it. If it's a motherboard issue then i haven't no more solutions than returning to Vista ...

My motherboard is based on the P35 chipset, it's the Gigabyte P35-DS4, a well known motherboard ( 2/3 years ago ). I have installed chipset and NIC drivers just fine but without improvements.
My System SpecsSystem Spec
13 Oct 2009   #16

Windows 7 Ultimate x64 SP1

Ok I have a few things to try they may sounds nuts but anything is worth a shot here.
Like mckillwashere said it might be your router, since Win 7 is the first OS to always try to use IPv6 before IPv4 if your router doesnt support IPv6 it might cause a lag between the two. If your router has an update to support it do it other wise disable it in Windows.
Second uninstall the game run defrag then reboot and install BF2 run the defrag again and then install the 1.5 patch. I know this sounds odd but it might be looking for a file when you pan to the side making the drive search causing an odd skip. Never know odder things have caused things around here.
Last thing is PB. go to evenbalances website and pull down the update tool run that after all this mess.
Few more questions what anitivirus software are you running and I also see you have a creative blaster X-fi sound card Im going to have to search around I remember during the RC Creative cards where having some issues but that could be gone by now.
My System SpecsSystem Spec
13 Oct 2009   #17

Windows Seven Pro

@DarkXeno : My router support ipv6 but it is not activated . I prefer disabling in Windows than activing on the router ( but why not ). My game is already patched by default ( downloaded via steam ). I have tried to update punkbuster via pbsetup.exe, update was ok, but the game was still lagging. I have disabled antivirus and firewall ( for testing ). Creative has recently made (finals ?) drivers for Seven 64 bits.
I can't test for now ipv6 disabling. It may be THE solution ^^ but i prefer collecting potentials solution until the next week end to test each of them. I have already tried several things to remove lag ( spend 10 hours last week ) but always disapointed :'(
My System SpecsSystem Spec
14 Oct 2009   #18

Windows 7 x86/x64, Server 2008r2, Web Server 2008

Im back in town
I haven't heard anything back from them yet. But I did get some more businesses that need help im getting them to fax me applications XD.

So how has it been any luck?
My System SpecsSystem Spec
16 Oct 2009   #19

Windows Seven Pro

Hello, I am back to home and can test all your good advices.
I have test all possible graphic tunes (vsync on/off, triple buffering, etc) ... No work
I have also tried to disable ipv6 ... No work
I have also changed my network card ... NO WORK !
I have also retried to change TCP propreties in regedit ( tcpnodelay / tcpnoack ) and autotuning=disable ... No work ...

I have also tried with others games ( CSS / Team Fortress 2 / Left 4 dead ) and only Battlefield 2 has the problem.

I have also reinstall BF2 many times and updated PunkBuster too ...

My ping remain good, my fps rate is contant and good too ...
So wtf is the problem ?

I don't know ... maybe a motherboard incompatibility. Well i think i will reinstall this old good Windows XP.

Windows Seven is so disappointing me.
My System SpecsSystem Spec
16 Oct 2009   #20

Windows 7 x86/x64, Server 2008r2, Web Server 2008

Seven is still in working stages as it will be for about 3 months after release, as everyone will be calling the official MS help and they will be creating patches left and right creating compatibility. Same for game manufactures Most places are releasing the patches until it is released and the with BF being a slightly older game they may not even release a patch for it.
My System SpecsSystem Spec

 Good ping but extreme lagging in Battlefield 2

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Is this processor is good for Battlefield 3
I have an intel(r) pentium(r) D core 2.80ghz and i want to know is this processor is better than my pentium (r) Dual-core cpu t4500 2.30ghz and is this processor is good for battlefield 3?
Problem Playing Battlefield 2 or Battlefield 2142
Ok I just got a computer with Windows 7 on it, it's a Dell Gaming laptop and everything works fine on I except one thing, when I play Battlefield 2, or Battlefield 2142 in single player, It will sometimes lag, it's really bad on battlefield 2142 and I have graphics on low settings, I moded them...
BSOD playing battlefield 3/battlefield 4 beta
I've made threads asking for help in the past and went back over them before posting here, but I'm kind of stuck again. I ran furmark without my gpu overheating/crashing, and I ran prime95 again without overheating/crashing. I haven't done any overclocking, and I ran 9 passes of memtest...
BSOD Help and Support
Games lagging on good laptop.
Hello. When I'm playing high or medium end games on my laptop, they often lag even with the quality turned down to the lowest. These are my specs: AMD Quad-Core A10-4600M @ 2.30Ghz x4 8 GB RAM 750 GB HDD AMD Radeon HD7660G + HD 7670M Dual Graphics As you can see I should be able to play...
Can ping but not browse-iPhone browses good
Hello, i am in need of some help. Ive been trying to fix this all day long and im getting frustrated. I recently had a new internet connection setup this morning. It was working fine up until 4-5 hours ago, now i cannot browse websites. I can ping and other domain names and get...
Network & Sharing
Zone Alarm Extreme Security beta good
I've been beta testing version available now and it's the first one that hasn't given me any issues on 7. Previously, I had HDD issues and Winamp would not start properly until a complete uninstall of ZA. Those issues are fixed and system is running smooth with little or no noticable...
System Security

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:30.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App