Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Source Engine Games Have "Stopped Responding"

25 Jan 2009   #1

Windows 7
 
 
Source Engine Games Have "Stopped Responding"

Okay, here's the deal: I just recently installed the Windows 7 32bit beta to find that all games that run on the source engine stop responding as soon as they're launched. This happens with source games only whether they are ran through steam or not. All of the games ran fine on vista.

I have a Dell computer with and xfx 8600gt and 3gigs of RAM

Here's What I've tried:
-Runnig the game in compatability mode and/or as admin
-Rolling back on previous Nvidia driver
-Updating drivers
-Defragging game files

Games that have stopped responding:
-CS:Source
-DOD:Source
-TF2
-Left 4 Dead
-Portal
-Dark Messiah
NOTE: Some of these games were installed after Windows 7 and not all of them are hl2.exe.

Half Life 2 was the only one that would work.

I think the problem might be either coming from my video card or directx. When I run dxdiag the dx version shows up at 11, which is strange. Also, I am using the Windows 7 nvidia drivers 1.1. I was also wondering if it is possible to use vista 32 bit drivers to run my card.

Any suggestions?

My System SpecsSystem Spec
.

25 Jan 2009   #2

Windows 7 beta 64 bit build 7000
 
 

Wow......I'm running 7 64 bit. I loaded HL2, CS:S & HL2: Episode 1. CS:S runs fine, EP 1 runs very well, but HL2 will load, I start to go through the first part of the game where Freeman arrives at the Citadel and has to run across the rooftops to escape from the Combine. Here's where I get a message, "AI cannot initiate". No more game. It doesn't crash, only the AI cues not are being read anymore.

Oh well, it's a beta OS. HL2 did look very good and was rendered quite nicely.

EDIT: I turned off UAC and HL2 starting playing without error. Certain mouse buttons are not recognised, but the game seemed to be running. I don't know for how long it will remian error free. What was interesting is that game updated to 64 bit mode when it detected the 64 bit os.
My System SpecsSystem Spec
Reply

 Source Engine Games Have "Stopped Responding"





Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:46 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33