Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: StarCraft fix holy cow!

22 Nov 2009   #131

Windows 7 Professional (x64)

StarCraft reminds me of a day not so long ago when I was young and happy. That's why I play once in a while, haha!

My System SpecsSystem Spec
23 Nov 2009   #132

Windows 7 Ultimate x64 // Windows 7 Ultimate x64

Quote   Quote: Originally Posted by tiger2wander View Post
Quote   Quote: Originally Posted by johnathanamber View Post
Hey guys... still no go for me. Although StarCraft launches and I can run it... it looks great... but it freezes after a couple minutes of use.

Hi everyone,

I just tried to set all compatibles and write a script to disable explorer while starcraft is running but no luck, I have got freeze and no way to get back using Alt-Tab

So, I tried to to configure in compatible tab like:
Compatible mode: Windows XP (Service Pack 3)
- Disable visual theme
- Disable desktop composition
- Disable display scaling on hight DPI settings
Privilege level:
- Run this program as an administrator

then run the script runonwin7.cmd (placed in same location with starcraft.exe) which content:
@echo off
taskkill /f /im explorer.exe
start explorer.exe
then starcraft (I'm using blood war origin & expansion) play perfectly with right color & not freeze the system again

I'm using HP Compaq CQ45 with ATI Radeon HD3200 integrated video card & windows 7 RTM

PS: I'm tried to play it with few minutes then I have lose the sound but animation still playing, the shortcut key like go to menu (ESC) is not work now but the keyboard still working :P and I can bring back to system to write this post without hard reset my computer

Edited: I have go out then close the minimized windows have name BroodWar (First I have idea to kill it ) then starcraft playing mission bring back immediately after I have closed the minimized windows, LOL => continuos play

Have fun and good luck guys!
This is the only solution that works 100% of the time for me, the script + without any need for compatibility modes.

Thanks very much, cheers for everyone's help on this topic
My System SpecsSystem Spec
24 Nov 2009   #133

Windows 7 Professional (x64)

Quote   Quote: Originally Posted by daviesow (Page 9) View Post
Ok, after reading this and several similar threads I whipped up a TaskKill Explorer... script. Problem was I didn't like to hit a key after a pause and if I didn't pause I couldn't get Explorer to reliably relaunch. Sometimes it launched but left the CMD window opened, other times it only launched an actual file explorer window and not the taskbar. Very frustrating.

However, after a ton of tweaking, I think I've got it all sorted. Attached are the final bat file along with the same bat compiled as an Exe including the StarCraft icon so you can substitute it straight in any games links you may have.
This solution worked for me! I don't even have to change the compatibility mode.

Edit: Actually the explorer doesn't always launch after the game is closed. Anybody have any other suggestions on a better script?

ECHO The Windows Taskbar will be re-loaded after StarCraft is closed...
taskkill /f /IM explorer.exe > NUL
choice /N /T 2 /C Q /D Q > NUL
start /B explorer.exe
My System SpecsSystem Spec

27 Nov 2009   #134

Windows 7 Ultimate 32 bit

guys I havent had a crash in more than a week!
Here's what I did..
1. update to the newest geforce driver
2. update to the newest nforce driver
3. in windows 3D graphic settings, set everything to low or none.

works for me! let me know if anyone else encounters any problems.
My System SpecsSystem Spec
29 Nov 2009   #135

Windows 7 Pro x64 Build 7600

Just installed SC for fun and had the same color issue. Had to edit the path name but works perfectly. Nothing else seem to work. TY.

taskkill /f /IM explorer.exe
start explorer.exe
My System SpecsSystem Spec
29 Nov 2009   #136
squall leonhart

Windows 7

This is a workaround not a fix.
My System SpecsSystem Spec
03 Dec 2009   #137

Windows 7 Home Premium 64 bits

@HughShaw Try this:
under compatibility settings check all boxes without checking the compatibility mode
- Run in 256 colors
- Run in 640x640 screen resolution
- Disable visual themes
- Disable desktop composition
- Disable display scaling on high DPI settings

run the game as administrator from the desktop

hope this works for you
My System SpecsSystem Spec
13 Dec 2009   #138

Win 7 and Xp

taskkill /f /IM explorer.exe
"C:\Program Files (x86)\Starcraft\Starcraft.exe"
on exit
start explorer.exe

this will automatically restart explorer after it is closed in win 7
My System SpecsSystem Spec
18 Dec 2009   #139

Window 7
Additional fix!

Has anyone tried changing their theme to Windows Classic? That worked perfectly for me. I didn't have to do any of the previous work arounds. I tried just turning off areo, but that did nothing for the funky colors.

Also, anyone want to try a good resolution hack try this I found it yesterday and tried it. It works very well.
My System SpecsSystem Spec
09 Jan 2010   #140

win7 build 7100
Help needed

Ok - so there are several methods to avoid the color-issue when playing starcraft.

However, the random crashes still occur when starting SC from Windows 7
The crashes are caused by a known bug that's been reported to Microsoft a while ago.
So please - let them know that there a many people waiting for them to fix this issue
by signing the petition in the MS Questions Forum.

BTW - I just spend a couple of hours installing SC in the virtual XP mode. After quite a bit of tweaking (had to manually change the color depth to 265 colors in regedit + change my win7 resolution to 640x480 for SC to start) I finally got it to start properly -only to find out that it's lagging like hell.
Has anyone had better luck with running SC in the WinXP mode?

Greets Jim


When I use the WinXp mode + Chaos Launcher and activate the "Window mode"-Plugin the game runs fine (but in windowed mode, obviously)!

When I set my Win7 resolution to 640x480, then start the XP mode (which then will have 640x480px as well) and start the game normally, it runs incredibly slow (even in the main menu...)
My System SpecsSystem Spec

 StarCraft fix holy cow!

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Holy Blessing Batman!
Not Windows 7 related, but, you've got to give them top marks for trying "Apple's iTunes has received a unique endorsement in a marketplace populated by sports and entertainment celebrities: The Vatican has blessed an iPhone app. Well, not quite blessed, but acknowledged and praised...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:15.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App