Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: GTA 4 Not using GPU properly

20 Oct 2009   #1
Maniaknl

Windows 7 Professional 64Bit
 
 
GTA 4 Not using GPU properly

Hello i just installed GTA 4 and i found it that it does not use the GPU properly


When i am inside a interior he uses like 30% of my GPU(Video card) and the game runs perfect but when i got outside a interior the game uses 0% of my GPU and 100% of my CPU....


This is causing a mayor lag to my game its olmost like the video card wants the CPU to do his calculations instead of letting his own GPU do the those calculations.

So is there a hotfix for this ??

PS When i play other games the GPU Works at 100% and the other games runs perfect (for example Assassins Creed)

So i don't think my GPU is malfunctioning.

I'm using a Q9400 @ 2,66 GHZ with a ATI HD RADEON 4890 with the newest Catalyst (ATI DRIVERS)

Thank you for your time and efford


My System SpecsSystem Spec
.

21 Oct 2009   #2
AntiStar

Windows 7 64bit
 
 

Its down to how the game was programmed, if I remember correctly GTA4 is a CPU heavy game. I agree with you about your GPU. It's not broken. You could try overclocking your CPU but that's another story for another day.
My System SpecsSystem Spec
21 Oct 2009   #3
Maniaknl

Windows 7 Professional 64Bit
 
 

So basicly GTA IV is a game that comepletely ignores GPU's so the game is only playable with a Core I7 ?
My System SpecsSystem Spec
.


21 Oct 2009   #4
DarkXeno

Windows 7 Ultimate x64 SP1
 
 

Its playable on any system just poorly programed to use high powered GPUs. Manly you would have to cut down the settings instead of everything being on MAX at 1600x1400 run it at MED 1240x1020. The screen size is just an example you might have to play with it abit. I have always felt the PC version of GTA IV was a quick very poor console port, just to keep the PC fans happy. The only thing i can suggest is the cut the setting and make sure you have all the newest drivers loaded along with shutting down any other unneeded background task.
My System SpecsSystem Spec
21 Oct 2009   #5
Maniaknl

Windows 7 Professional 64Bit
 
 

The problem is the FPS gain from Everything high to everything low and 1680x1050 to 800x600 is only like 5 FPS
My System SpecsSystem Spec
21 Oct 2009   #6
AntiStar

Windows 7 64bit
 
 

I only get 25 - 30 fps on my system
My System SpecsSystem Spec
21 Oct 2009   #7
Maniaknl

Windows 7 Professional 64Bit
 
 

Quote   Quote: Originally Posted by AntiStar View Post
I only get 25 - 30 fps on my system
Hmm you overclocked your CPU ?
If you do do you need better cooling since i only got the standard
My System SpecsSystem Spec
21 Oct 2009   #8
Everlong

 

Quote   Quote: Originally Posted by Maniaknl View Post
So basicly GTA IV is a game that comepletely ignores GPU's so the game is only playable with a Core I7 ?
Pretty much. Plays perfectley on my mate's Core i7, max everything and 60fps. I do that on mine and I get about 15-20 fps.
My System SpecsSystem Spec
22 Oct 2009   #9
Maniaknl

Windows 7 Professional 64Bit
 
 

Quote   Quote: Originally Posted by Everlong18 View Post
Quote   Quote: Originally Posted by Maniaknl View Post
So basicly GTA IV is a game that comepletely ignores GPU's so the game is only playable with a Core I7 ?
Pretty much. Plays perfectley on my mate's Core i7, max everything and 60fps. I do that on mine and I get about 15-20 fps.
Still then i should get more than 15-20 since i have a Core 2 Quad and you got a Core 2 Dual
My System SpecsSystem Spec
22 Oct 2009   #10
torrentg

7600.20510 x86
 
 

On just about every new game, my system plays it well enough and smooth. Usually on high or highest settings. GTAIV completely owns my system and runs at less than 10 fps. Poor coding for sure. I've seen places on the net that show you how to tweak rendering and that promise to up framerates while actually making the game look better. I haven't bothered. Google it and you may find what I have. I remember there was even a video about this on Youtube.
My System SpecsSystem Spec
Reply

 GTA 4 Not using GPU properly




Thread Tools





Similar help and support threads
Thread Forum
How do I shut down properly?
Sometimes my laptop doesn't shutdown at all. When it happened for the first time I was frightened and I left it all by itself to shut down. It didn't shutdown even after 19 Hours :shock: I called a local technician and he came all along just to remove my battery and restart it. It doesn't happen...
Hardware & Devices
Will Windows 7 run properly in my PC???
My PC has the following configuration: 1>Motherboard P5VD2-MXSE 2>Processor:Intel Pentium 4 HT 3.20 GhZ 3>Express Card: Radeon HD 5450 1024 MB 4>RAM: DDR2 -2GB 5>Hard Drive:80 GB with 23 GB in C drive. More: My PC's CPU-z Saved Report:See in attached files.
Installation & Setup
Why won't my ram fit properly?
I have an inspiron 570 desktop with 4gb of ram already installed. I went on crucial, and it found compatible RAM, 1gb 240pin ddr3 128mx64. When I opened my computer up, there were 4 slots, 2 blue ones with the default ram, and 2 open black ones. I couldn't get the ram to seat properly, it took a...
Hardware & Devices
not installing properly, one HDD may not be recognized properly
okay so I'm trying to install a new copy of Win7 onto my machine. i usually have my main drive as a RAID 0 setup of two WD 500Gb sata3 HDD's. the problems first started upon first attempt. BIOS recognized my RAID, windows also recognized my RAID with full capacity. install went great until it...
Installation & Setup
Not starting up properly?
Is Windows 7 . . . - x86 (32-bit) or x64 ? 32 bit - the original installed OS on the system? Yes - an OEM or full retail version? OEM - What is the age of system (hardware)? Around 10 months
BSOD Help and Support
Not able to Log On Properly
I installed Windows 7 (xp already installed) and went to documents and settings and took owership and changed the persmissions of the "User Ishq File" Now when i try to log on to XP user it says. WIndows can't log on the user's profile but has logged you on as the default profile for the...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:49.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App