Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: To gamers that play LoL

28 Sep 2013   #1
MPN

Windows 7 Home x64
 
 
To gamers that play LoL

Hello.

I got a question to other LoL players with a AMD graphic card.

I got a 7970ghz card in my PC and i experience alot of fps drop in the game, and white flashes on the screen. Ive been searching the grate interweb for a long time now for a fix on this porblem but all i see is other posts from people having the same problem. and for the most part it seem to be the 7xxx series that are effected by this. I just upgraded my PC with a new mobo and CPU followed by a clean instal of Windows 7 hoping this would be gone, but no luck. I`ve had this problem since around januray. when i instaled the new AMD driver, and downloaded a huge patch to LoL. And over time none of the new patches or driver updates has helped.

Il post a youtube video that showes 1 of the screen problems.
I alos as i said get huge fps drops and white flashes



My System SpecsSystem Spec
.

29 Sep 2013   #2

Windows 7 x64 (Ultimate)
 
 

I have never like ATI/AMD graphic cards, more so because I have always had bad luck with the drivers and/or control panel (or whatever they call it). Granted, I am mostly taking about their onboard chipset cards.

Being said that and having never played that game nor knowing how old or new the game is... have you tried uninstalling the drivers and control panel, restarting in safe mode and using CCleaner to clean your registry and installing the newest driver (if game is recent) or older driver (if game is that old) to see if that solves your problem?

If the problem is just with this particular game than I would suggest uninstalling the game completely (save your saves somewhere else), restart, clean registry with ccleaner, restart and install game again, if you are ask to install DirectX, do so, do not patch the game yet and test it. Download any patches the game has manually and start patching 1 patch at a time and then testing the game... it may very well be the patches.
My System SpecsSystem Spec
29 Sep 2013   #3

Windows 7 Home Premium 64bit sp1
 
 

I have a code to this game but never tried it

Do you happen to play without V-sync that could be why it's tearing when you have V-sync in enabled it will be forced to stay at 60 fps also look into your CCC settings and fix them up


Attached Thumbnails
To gamers that play LoL-x.png  
My System SpecsSystem Spec
.


29 Sep 2013   #4

Windows 7 Home Premium 64bit sp1
 
 

Yeah I just finished installing it and it runs fine to me doesn't flicker unless you mean the pointer ?
My System SpecsSystem Spec
30 Sep 2013   #5
MPN

Windows 7 Home x64
 
 

Quote   Quote: Originally Posted by AstaLaVista View Post
Being said that and having never played that game nor knowing how old or new the game is... have you tried uninstalling the drivers and control panel, restarting in safe mode and using CCleaner to clean your registry and installing the newest driver (if game is recent) or older driver (if game is that old) to see if that solves your problem?

If the problem is just with this particular game than I would suggest uninstalling the game completely (save your saves somewhere else), restart, clean registry with ccleaner, restart and install game again, if you are ask to install DirectX, do so, do not patch the game yet and test it. Download any patches the game has manually and start patching 1 patch at a time and then testing the game... it may very well be the patches.
How i have tried to ersolve this problem: Updating all drivers for my PC.
Uninstaled my GPU driver, and tried to instal older onces
Tried the repair tool for the game in the game client
Reinstaled the game.
And i got some new PC komponents so ended up with a clean instal of Windows 7, still the same problem
new parts i got was: MIS z77 mobo and a i5-3570k cpu

And as for testing the game 1 patch of the time, dosnt work. as this is a online multiplayer game only, and without patching it you cant launch the game.

And yes i have tried with and without V-sync on.
With v-sync on and capped at 60 fps i notice much more to the UI flickering as i linked in the youtube vid.
And i get alot worse fps drop in fights.
With v-sync off i get a bit more white flashes on the screen, but almost no more UI flickering and my FPS is much more stable.
Having v-sync off is at this moment the best thing for me. it still kinda suck. but its not as bad as when its on.
other games i experince screen tearing on is World of Tanks,


Hope you guys are able to read this. and that my bad english dont give you all a headache

My System SpecsSystem Spec
30 Sep 2013   #6

Windows 7 x64 (Ultimate)
 
 

You say you installed a new Mobo, did you also install the newest chipset drivers for your Mobo? Go to MSI check for newer drivers for your Mobo, download them to a temp folder and save there.

Make sure that after you have updated all of them, including Bios if needed, that your mobo does not have an Onboard graphic card and that in the bios your mobo is looking at your AMD/ATI card as primary card.
My System SpecsSystem Spec
30 Sep 2013   #7
MPN

Windows 7 Home x64
 
 

The newest chipset driver is instaled.
And the onboard GPU is disabled.

And just tried BF3 today. maxed all the settings with out any problems with tearing and all that crap. Only problem i had with that game was heat. GPU peaked at 69c after like 15 min of game play.
My System SpecsSystem Spec
30 Sep 2013   #8

Windows 7 Home Premium 64bit sp1
 
 

Quote   Quote: Originally Posted by MPN View Post
The newest chipset driver is instaled.
And the onboard GPU is disabled.

And just tried BF3 today. maxed all the settings with out any problems with tearing and all that crap. Only problem i had with that game was heat. GPU peaked at 69c after like 15 min of game play.
Try turning up AA settings and see if bring it around to 4x or 8x times make a difference

also what are your temps when that happens ????
My System SpecsSystem Spec
30 Sep 2013   #9
MPN

Windows 7 Home x64
 
 

Quote   Quote: Originally Posted by Solarstarshines View Post

Try turning up AA settings and see if bring it around to 4x or 8x times make a difference

also what are your temps when that happens ????
Dont think LoL have AA
When playing LoL my temps are around 40-50c
And world of tanks it peaks around 60c last time i played it
My System SpecsSystem Spec
30 Sep 2013   #10

Windows 7 x64 (Ultimate)
 
 

So, no tearing with other games but LoL, hmmm, is it safe to say that the problem is with the game then? Also, temps may have something to do with it, check in your bios to see if you can maximize your fans or add a couple of fans to the case to help dissipate the heat
My System SpecsSystem Spec
Reply

 To gamers that play LoL





Thread Tools



Similar help and support threads for2: To gamers that play LoL
Thread Forum
A place for real gamers Gaming
The ultimate gamers rig!! Gaming
PS3 Gamers! Chillout Room
Are computer gamers less likely to go to university? Gaming
For the gamers - new Radeon GPU Hardware & Devices
Gamers Wanted Gaming
Is Windows 7 Good For Gamers News

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 01:22 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33