Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Age of Empires 2 Conquerors - Problems with the usual Color Fix

19 Oct 2013   #1
XyRoN

Windows 7 Ultimate x32
 
 
Age of Empires 2 Conquerors - Problems with the usual Color Fix

OK, so I've been at this for 6 hours straight now (so please forgive me for any mistakes here, grammatical or otherwise) and I'm flat out of ideas, so I thought it might be a good idea to post my problem online and at least get some second opinions.

So the story goes like this; I just recently (read: earlier today) re-installed Windows 7 and installed Age of Empires 2, along with the Conquerors expansion immediately after getting the system into shape (configuring settings and installing essentials and drivers). Since I've had a lot of experience trying to get AoE2 to work on Win7/Vista before, I was fully aware of the direct draw color crap that AoE has problems dealing with. The problem this time is that apparently, the bad colors aren't being caused by direct draw, but rather something else.

At first I tried the two regular approaches; adding a "taskkill" .bat file to kill explorer.exe and then jump into AoE2, and running the w7ddpatcher.exe to patch AoE's age2_x1.exe file. After seeing both of these common methods (which have both worked for me perfectly well in the past, mind you) crash and burn miserably at fixing the bad coloration, I started wondering. I also noticed the coloration was way worse than any time before (I'm referring to the time before I fixed AoE2 before re-installing Windows 7), and also that it was present in the main menu and game lobby.

So I started experimenting; so far, I've tried re-installing the game (several times) using compatibility mode and administrator privileges for the setup and patches, I've tried fixing the game before and after applying patches, I've tried using the PalettestealerSuspender program, applying the 1.0e unofficial patch, applying the wide-screen patch, installing an older version of DirectX (5.0, I believe), manually messing with direct draw in the registry (adding a compatibility reg-key for AoE2 manually), changing Windows 7's theme to Classic from Aero, Alt-Tab-ing while AoE2 is running and terminating explorer.exe's process in Task Manager, starting AoE2 with the "Change Resolution" window open in the background (apparently fixes the colors for some people), etc... I've even tried downloading different releases off of torrents but they all run into the exact same problem (meaning that the problem obviously isn't a corrupt file or anything like that).

The result of my exploration of the strange and mystical lands of "Howtogetageofempirestoperformproperlyffs" would be a founded statement that this time around, the problem isn't being caused by direct draw (since no workarounds for direct draw have worked so far), but by something else. I've run completely dry of ideas on how to fix this. Any help would be very much appreciated!

tl;dr - I'm having trouble with Age of Empires 2's colors in Windows 7 Ultimate, which seems to not be caused by direct draw as no direct draw fix worked so far. I also re-installed Win7 very recently (earlier today). Read the Wall-'o'-Text above if you want the dirty little details.


My System SpecsSystem Spec
.

08 Nov 2013   #2
mikoniko

W7 64
 
 

Please tell me that you found a solution for this...im having the SAME problem, Windows 7 64 bits...
My System SpecsSystem Spec
24 Nov 2013   #3
XyRoN

Windows 7 Ultimate x32
 
 

At first I was very optimistic about this getting solved all by itself (a Windows, .NET, C++ Redist or DirectX/OpenGL/Graphics Driver update, or something of the likes), but after such a long time of playing different games in the meanwhile and allowing all updates Age's colors still seem very much off...

To further describe the problem, in the hopes that maybe someone someday might find the cause/a fix for this, I'll post a couple of screenshots from the game (The images provided are photos of the screen taken via my phone and not actual screenshots - this is because screenshots from the game pasted into paint seem to be almost completely black);
My System SpecsSystem Spec
.


24 Nov 2013   #4
mikoniko

W7 64
 
 

Well i have the same exact problem. The only solution was installing Oracle VM VirtualBox, and creating a system whit XP SP3...and not just that. To make fullscreen at 1920x1080 you have to install Oracle VM VirtualBox extension pack. This hole thing is too much for a game like this...but if you're willing to play at any cost, that's your solution.
My System SpecsSystem Spec
24 Nov 2013   #5
Erick Aguilar

Windows 7 professional X64
 
 

Guys..

Age of Empires II HD has been released for months on steam. It has Win 7 support as well as native 1920 x 1080.
My System SpecsSystem Spec
24 Nov 2013   #6
mikoniko

W7 64
 
 

Yes, but for x64 it has less than 20fps...sucks
My System SpecsSystem Spec
25 Nov 2013   #7
Erick Aguilar

Windows 7 professional X64
 
 

Quote   Quote: Originally Posted by mikoniko View Post
Yes, but for x64 it has less than 20fps...sucks
It performs exactly the same if not better.
Not to mention it has more expansions and the ability to be modded.

I don't know where you tried, I am running it and have no issues whatsoever with FPS.
My System SpecsSystem Spec
25 Nov 2013   #9
Erick Aguilar

Windows 7 professional X64
 
 

All 3 threads were created on April 2013. It's november and all performance issues were solved a month after release. Me myself never had issues running AOE on release.
My System SpecsSystem Spec
25 Nov 2013   #10
mikoniko

W7 64
 
 

Quote   Quote: Originally Posted by Erick Aguilar View Post
All 3 threads were created on April 2013. It's november and all performance issues were solved a month after release. Me myself never had issues running AOE on release.
Good to know! i will try it. Thx!
My System SpecsSystem Spec
Reply

 Age of Empires 2 Conquerors - Problems with the usual Color Fix




Thread Tools





Similar help and support threads
Thread Forum
Graphics issue with Age of Empires II: The Conquerors
I have been a long time Age of Empires II player, and have once suffered from the classic red grass and purple water graphics issue that a lot of people suffer from. However, using one of the below solutions, it eventually corrected itself. Recently, I installed Windows 7, build 7100 as my main...
Gaming
Age of Empires II: The Conquerors Expansion graphics and crashing
Hello, I know that there are loads of threads about the graphics problems (the red grass and the purple oceans), and I do have that problem as well. Unfortunately, when I try and play a random map in compatability mode (I have tried multiple OS's) the game crashes when I fix the red grass +...
Gaming
Age of Empires 2: The Conquerors freezing.
Hi, I'm using win 7 x64 ultimate. dx updated. most win updates installed (omitted malicious software tool & etc.) Versions: Age of Kings: 2.0b (failed with 2.0a too), The Conquerors: 1.0e (fails with 1.0c too) AoE: Forgotten Empires installed, runs ok. AoE: Age of Kings runs ok. Tried killing...
Gaming
ago of empires 2 the conquerors expansion.
My windows 7 premium 64 bit comp will install age of empires but refuses to run the game . I've tried adjusting the resolution and coloure bit but still no good.does anyone have any solutions to this problem?
Gaming
Age of Empires II The Conquerors-High Resolution+Music Fix on Win7 64
Hi all I just got a huge itch to play the Age of Empires series again. I played Age of Mythology last week and worked without a hitch on Windows 7. But when trying to install my all time favorite Age of Empires 2 yesterday, ran into a lot of problems - after hours of googling, I have managed to...
Gaming
age of empires II conquerors
salut , am si eu o problema si de fapt nu doar eu cam toata lumea pe care o cunosc si joaca age of empires II conquerors , la win 7 nu merge bine in joc se vede foarte nasol culoarea , am vazut aici la voi ca spuneti ca nu are nici e problema, dar nu e asa , nu e compatibil jocu sau daca voi chiar...
Gaming

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:34.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App