Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Age of Empires III compatibility issue


25 Oct 2009   #1

Windows 7
 
 
Age of Empires III compatibility issue

Hello,


I've upgraded my Windows Vista to Windows Seven (32-bit), but I'm having trouble running Age of Empires III. It used to work fine prior to Seven's installation.


I have reinstalled the game, but when I try to run the game I get the following message (in French):
"Le programme suivant a effectué une action qui impose à Windows de remplacer temporairement le jeu de couleurs par celui de Windows 7 de base.
Programme: Age of Empires III Patch 1.13
Editeur: Microsoft Corporations
PID: 5904"

Which basically means that due to the program's action, the Aero color set is temporarily deactivated and replaced by the basic color set of Windows 7.


I can find "age3.exe" in the process management tool (and kill it, which makes Aero functional again) but the game does not run. I have also tried using the compatibility mode (XP SP 3 and Vista), but with no success.


My specs:
Dell Inspiron 1720 laptop
Intel Core 2 Duo CPU (T8300, 2.40 GHz)
4 Go RAM
Nvidia GeForce 8600m GT video card (I have installed the latest-available driver on Nvidia's website)


Everything else is working fine.

Any suggestions to get the game working? Or must I wait for some compatibility fix?

Thank you.

My System SpecsSystem Spec
.

26 Oct 2009   #2

Windows 7
 
 

Salut!

J'ai eu le même message que toi. Mais le jeu se lançait quand même avec des couleurs plus pâles. J'ai installé le patch 1.13 d'AOE (c'est important de le faire) que tu peux récupérer sur agecommunity.J'ai choisi un thème sans aéro (clique droit sur le bureau, personaliser). Ca me met plus de message d'erreur mais les couleurs restent pâles. Mais je peux toujours jouer.

C'est déjà ça... En attendant qu'il y ait un patch...

Dis moi si ca fonctionne pour toi!

A plus
My System SpecsSystem Spec
26 Oct 2009   #3

Windows 7
 
 

Thank you for answering,

I had already installed the latest patch from agecommunity; I've tried switching to a non-aero theme, but the game still does not run (although I don't get the error message anymore). I have to manually kill the age3.exe process.

++

Nuco
My System SpecsSystem Spec
.


26 Oct 2009   #4

Windows 7 x86
 
 

I installed and is running normally without errors with the latest patch.
My System SpecsSystem Spec
29 Oct 2009   #5

Windows 7
 
 

Could you please tell me which video card you have?
It works for some people, partially or not at all for others, I'm finding this rather strange...
My System SpecsSystem Spec
29 Oct 2009   #6

Windows 7 Professional x64
 
 

Out of interest, have you tried to install the game under the compatibility mode rather then just running it under? *Sometimes* this can help.
My System SpecsSystem Spec
30 Oct 2009   #7

Windows 7
 
 

Yes, I've also tried that, to no avail
My System SpecsSystem Spec
30 Oct 2009   #8

Windows 7 x86
 
 

Strange, my video card is a GeForce 8600 GT too. Is XFX dont know if it has different.
My System SpecsSystem Spec
30 Oct 2009   #9

Windows Seven Ultimate x64
 
 

its probably your pc config, 4GB of RAM sucks for windows seven, u'll need at least 8GB of RAM and the new intel i7-975 Extreme Edition CPU https://www.ecomelectronics.com/prod...19&ref=froogle
My System SpecsSystem Spec
30 Oct 2009   #10

Windows 7
 
 

Ah, I've finally got it working!!

I chose the hard way though, I did a clean install of 7, and while I was at it, I chose the 64 bits version.
Aero is still deactivated, but the game loads, and runs very smoothly.

Thanks to all who answered,

Nuco.

----------------------------------------------------------------------

Quote:
its probably your pc config, 4GB of RAM sucks for windows seven, u'll need at least 8GB of RAM and the new intel i7-975 Extreme Edition CPU https://www.ecomelectronics.com/prod...19&ref=froogle
My System SpecsSystem Spec
Reply

 Age of Empires III compatibility issue




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 09:37 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33