Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Master of Orion II - Anyone got it to work correctly?

05 Feb 2010   #11

windows 7 home premium
 
 

I have gotten MOO2 to run with win 7 64 bit.

First I had it installed on a computer using windows xp and I copied the micropose directory to the program files (x86) directory.

I then copied the dplayx.dll file from the windows\sysWOW64 directory and renamed it dplay.dll and put it back in the sysWOW64 directory (be sure the dplayx.dll file is still there)

I then created a batch file in notepad

TASKKILL /F /IM "explorer.exe"
cd C:\"Program Files (x86)"\Microprose\Orion2
start /w C:\"Program Files (x86)"\Microprose\Orion2\Orion95.exe
start C:\Windows\explorer.exe

I named it MOO2.bat

MOO2 now runs great

I wish I could take credit but Lord_Xorn @ MOO2 DPLAY.dll error - Atari Forums posted this. He also has a bat file for 32 bit versions of win 7 in that thread.

My System SpecsSystem Spec
.

14 Feb 2010   #12

Window 7 Professional 64
 
 

Hi, Still trying to get MOO2 to run on Windows 7 Prof 64. Tried the solution by kiliddar and bat suggested by dumbfire still no joy.

I am not even sure it installed. When I tried to run it the screen flashes and then goes blank. I have to use Task Manager to kill the process to regain control.

Any other suggestions welcome....
My System SpecsSystem Spec
15 Feb 2010   #13

windows 7 home premium
 
 

It probably did not install, you can check the program files (x86) directory and see if it is there. I got it to work by installing it first on a computer and that I knew MOO2 would run, then copied the entire micropose folder and placed the entire folder in the program files (x86) directory. As mentioned you will need a dplay.dll file (it doesn't seem to matter if this file is place in the windows system, windows system32 or the windows SysWOW64 directory, so I placed in all three as several other old games need it. You can find that file by googling it or copy the dplayx.dll file found in the windows SysWOW64 directory and rename it dplay.dll and place it in the mention directories as you chose, be sure that you still have the dplayx.dll file in the SysWOW64 directory as it is needed. Then the bat file should work, just be sure you use the 64 bit bat file and not the 32 bit file.

After you play you must click ok in the thanks for playing Masters of Orion II, that will relaunch windows explorer. If you close the bat file first you will probably be forced to use a hard shut down to relaunch windows.
My System SpecsSystem Spec
.


15 Feb 2010   #14

Windows 7 RC Build 7100
 
 

I have been having the same color problems. I tried the method given by kiliddar, but after several screen flashes, I am taken back to the desktop and an error "fonts.dll [entry 0] was not found" appeared. I only get this error when running after disabling explorer.exe, and it seems run perfect after re-enabling explorer.exe (save from the original color problem). Any idea what this could mean?
My System SpecsSystem Spec
16 Feb 2010   #15

windows 7 home premium
 
 

I do not know what method was suggested by kiliddar was it the same bat file as I listed as I found this elsewhere in a post by Lord_Xorn on the Atari forum at http://www.ataricommunity.com/forums/showthread.php?t=696418 but he did not reference where he found it. The color palette issues seemed to be caused by windows explorer which the bat file disables. If you have not tried the methods I have posted in this thread try them they work great on my laptop as well as others you have tried it. It may not be a cure all. There are a few screens where cursor movement is very sensitive, but that has been my only issue since using the bat file fix.
My System SpecsSystem Spec
16 Feb 2010   #16

Windows 7 RC Build 7100
 
 

The batch file that you posted does the same thing as kiliddar's method. It is just an automation of that method that allows you to do it with a single button press. I am still running the release candidate, so that might be the problem. But I also don't have the "16 bit color" option, only the 256 bit color.
My System SpecsSystem Spec
16 Feb 2010   #17

windows 7 home premium
 
 

I suspect it is your version, as I am running only the windows xp sp2 compatibility option (the last one I tried before finding the bat file fix), though it susposedly does not need any at all.
My System SpecsSystem Spec
25 Feb 2010   #18

Windows 7 Home Premium x86
 
 

I haven't been in these forums in a bit but I can confirm that on a Windows 7 (x32) Home Ed. the solution I found (through the Ages of Empire 2 thread) works. I played over 40 hours of it with only one crash (which was occasionally happening already with Xp and Vista).
My System SpecsSystem Spec
02 Apr 2010   #19

Windows 7 Ultimate 64bit
 
 
Finally got it working on 64bit Ultimate Edition

As others had posted earlier, but fell short for me...

I had the game installed on a computer using windows xp
Then copied the Microprose folder found in Program Files to a flash drive and moved it to my laptop running Windows 7.
I placed the Microprose folder into the "Program Files (x86)" folder on my laptop.

I then made a copy of the DPLAYX.DLL file from the windows\sysWOW64 directory, renamed the copy as DPLAY.DLL and put it in the sysWOW64 directory (be sure the original DPLAYX.DLL file is still there)

I created a batch file in notepad that reads

TASKKILL /F /IM "explorer.exe"
cd C:\"Program Files (x86)"\Microprose\Orion2
start /w C:\"Program Files (x86)"\Microprose\Orion2\Orion95.exe
start C:\Windows\explorer.exe

then saved it as MOO2.BAT

This had all been explained before but the game still failed to run on my Windows 7 Ultimate 64bit OS. I kept getting a black screen, nothing else.

Figured it was a compatibility issue so this is what I did to finally make it work.

First go to C:\Program Files (x86)\Microprose\Orion2 > edit the ORIONCD.INI file to contain the proper path to your CDROM or MOO2 CD game files. For example my INI file reads

E:\

because that's the drive letter designated for my CD/DVD-ROM drive. Yours may vary. I had to check this because the XP computer I had originally installed the game on, had D:\ as the location of the MOO2 CD.

Second, you need to make one more modification to the MOO2.BAT file you created earlier. Right click it > select Properties > select the Compatibility tab > check and select mode Win XP SP2 > also check 256 color, 640x480 res. !!!Note that Run as Administrator is disabled and you can't check it. No problem. To run MOO2.BAT, ALWAYS remember to right click it (Not double-left click) and select "Run as Administrator" near the top of the drop-down menu.

That's it. Just run the MOO2.bat as Admin when you want to play the game.

Works like a charm now finally
My System SpecsSystem Spec
11 Aug 2010   #20

Windows 7
 
 

I got it working on mine. What I had to do is use dplay.dll from my old laptop with XP. Just copy dplay.dll from an XP system, from the system32 directory, into the folder where MOO2 is and it will play fine. You must also have compatibility set to 256 colors and 640x480, anything else didn't seem to matter.
My System SpecsSystem Spec
Reply

 Master of Orion II - Anyone got it to work correctly?




Thread Tools



Similar help and support threads for2: Master of Orion II - Anyone got it to work correctly?
Thread Forum
My Win 7 x64 doesn't work correctly with DDR3 Hardware & Devices
PLEASE HELP!!!master of orion 2 windows 7 Gaming
apostrophe key does not work correctly General Discussion
Master of Orion II Difficulties Gaming
"Master of orion 2" colors are completely messed up.Help! Gaming
Win 7 search does not work correctly..help?? General Discussion
Master of Orion 2 - Works with Win7 Gaming

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:51 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33