Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: FPS Drops after i installed a new motherboard and cpu.

11 Apr 2015   #1
CheeseDoodl

Windows 7 Home Premium x64
 
 
FPS Drops after i installed a new motherboard and cpu.

Hello everybody! I've had this problem for a few month now and was hoping someone on here could help me.
So i installed a new motherboard (MSI 970 gaming) and a new CPU (AMD FX 9590) and my FPS will drop for a few seconds every 30 seconds or so. I've tried to reinstall Windows 7 but i believe it was a OEM version since my computer keeps saying failed to verify Windows. I have another version of Windows Ultimate lying around here somewhere so i might try to install that instead.
I a post from someone else who had the same problem a couple of years back. He said the problem was that a BIOS setting was holding back cores. I have no idea what setting that was though.
I've also tried to download MSI Afterburner and checked on the NVidia page for my GPU and it said that my
Base Clock (MHz) should be 980 and i've noticed sometimes it drop to ~130. My GPU is up to date according to NVidia Experience.
According to this site the CPU and motherboard should be compatible: FX-9590 A List of Motherboards That Fit FX-9590
I am currently running BIOS 22.2

Any help would be greatly appreciated.


My System SpecsSystem Spec
.
11 Apr 2015   #2
CheeseDoodl

Windows 7 Home Premium x64
 
 

I don't believe heat is the issue.
My GPU is constantly ~30-50 degrees celcius.
My System SpecsSystem Spec
14 Apr 2015   #3
M1GU31

Windows 10 64bit
 
 

What power supply you're using? If it doesn't have sufficient amount of power to use your parts correctly it could be a issue too.
My System SpecsSystem Spec
.

15 Apr 2015   #4
AstaLaVista

Windows 7 x64 (Ultimate)
 
 

is the RAM also compatible?

By Nvidia 760 you are actually saying that you have a GTX 760?

How about filling out your system specs a bit more... you would get a more accurate help.

Also did you update your Video and Audio Drivers after W7 installation or did you use the drivers from the CD.

Going with Ultimate will not hurt either.
My System SpecsSystem Spec
19 Apr 2015   #5
CheeseDoodl

Windows 7 Home Premium x64
 
 

Quote   Quote: Originally Posted by M1GU31 View Post
What power supply you're using? If it doesn't have sufficient amount of power to use your parts correctly it could be a issue too.
Im using a Corsair CX 750W.
My System SpecsSystem Spec
19 Apr 2015   #6
CheeseDoodl

Windows 7 Home Premium x64
 
 

Quote   Quote: Originally Posted by AstaLaVista View Post
is the RAM also compatible?

By Nvidia 760 you are actually saying that you have a GTX 760?

How about filling out your system specs a bit more... you would get a more accurate help.

Also did you update your Video and Audio Drivers after W7 installation or did you use the drivers from the CD.

Going with Ultimate will not hurt either.
I appoligise for the sloppy info i supplied you all with.
My GPU is a Gainward Geforce GTX 760 2GB
My CPU is a AMD FX 9590
My motherboard is a MSI Gaming 970.
HyperX Fury DDR3 1600MHz 16GB Black.
My CPU cooler is a Corsair Cooling Hydro H55.
My power supply is Corsair CX 750W.

I was able to activate my Windows.

I have updated my video drivers using Geforce Experience but i have forgotten to update my audio drivers (which i will do now).
My System SpecsSystem Spec
20 Apr 2015   #7
Mellon Head

Win 7 Pro x64/Win 10 Pro x64 dual boot
 
 

It sounds as though you have the CPU's turbo mode turned on in the BIOS. That will mess with your clock speeds every few seconds or so, and might be causing the FPS drop. Is the FPS drop significant? How many FPS are we talking about?
My System SpecsSystem Spec
23 Apr 2015   #8
CheeseDoodl

Windows 7 Home Premium x64
 
 

Quote   Quote: Originally Posted by Mellon Head View Post
It sounds as though you have the CPU's turbo mode turned on in the BIOS. That will mess with your clock speeds every few seconds or so, and might be causing the FPS drop. Is the FPS drop significant? How many FPS are we talking about?
Well i mostly play Counter-Strike so i will use that as an example.
In CS:GO is usually get around 150-200 FPS. Every few seconds it will drop to 15-40 FPS.
I have tested it on other games too and everyone had the same result.

How do i turn off my CPU's turbo mode?
I've tried turning off AMD Turbo Core Technology and will update you all in a few.
My System SpecsSystem Spec
23 Apr 2015   #9
CheeseDoodl

Windows 7 Home Premium x64
 
 

Quote   Quote: Originally Posted by CheeseDoodl View Post
Quote   Quote: Originally Posted by Mellon Head View Post
It sounds as though you have the CPU's turbo mode turned on in the BIOS. That will mess with your clock speeds every few seconds or so, and might be causing the FPS drop. Is the FPS drop significant? How many FPS are we talking about?
Well i mostly play Counter-Strike so i will use that as an example.
In CS:GO is usually get around 150-200 FPS. Every few seconds it will drop to 15-40 FPS.
I have tested it on other games too and everyone had the same result.

How do i turn off my CPU's turbo mode?
I've tried turning off AMD Turbo Core Technology and will update you all in a few.
It does not appear to have worked. I still get FPS drops every now and then.
My System SpecsSystem Spec
01 May 2015   #10
CheeseDoodl

Windows 7 Home Premium x64
 
 

Does anyone else have any ideas as to what could be the cause of the problem?
Anything is greatly appreciated
My System SpecsSystem Spec
Reply

 FPS Drops after i installed a new motherboard and cpu.




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
FPS Drops after i installed a new motherboard and cpu.
Hello everybody! I've had this problem for a few month now and was hoping someone on here could help me. So i installed a new motherboard (MSI 970 gaming) and a new CPU (AMD FX 9590) and my FPS will drop for a few seconds every 30 seconds or so. I've tried to reinstall Windows 7 but i believe it...
Hardware & Devices
BSOD after a new motherboard and processor was installed.
Hi all, I have the blue screen that tells me there is an error and then the system crashes. I have recently bought and had a shop install a brand new Gigabyte GA-B85M-D3H mother board and Intel i5 processor. It did have a AMD graphic card but the man at the shop took it out? I am not...
BSOD Help and Support
BSOD since new motherboard installed
BSOD since new motherboard installed I have my minidump file thanks in advance
BSOD Help and Support
Problems installing Win 7 over XP, new motherboard installed.
Installed new motherboard after old one crashed, have original hard drive installed. When I try to install win 7 I get the following message..."Selected disk has an MBR partition table. On EFI systems, windows can only be installed to GPT disks." Talked to Western Digital, as I have a WD5000AAJS...
Installation & Setup
Installed new motherboard issue
So i installed my new motherboard and cpu, everything is connected (I double checked) and when i turn it on i can hear one short beep and there is no display. Anyone know this issue? Specs: Asus P8H61-m le/USB3 Gigabyte GTX 550 Ti Intel i5 2500k 3.3 Ghz
Hardware & Devices
No sound after after new motherboard installed
So I am getting no sound after putting a new motherboard in my PC, and doing a clean install of windows 7 64-bit. This is my motherboard P67 Motherboard Series Manufacturing - ASRock Inc. I installed all default drivers from the CD that came with the board
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:55.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App