Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Crossfire & Crysis

11 Nov 2009   #1

Win7 Pro (6.1, build 7600)
 
 
Crossfire & Crysis

OK. After much trouble I've gotten my machine's issues down to Crysis and it appears I have an 2 subpar options: (1) Disable Crossfire and play the game laggy, w/ weird crackly noises, and the constant bickering knowledge that i spent twice as much money for a game which won't work properly with your full investment.

(2) Then I can play with crossfire on but then i get white dots and squares (like pixelation) mainly in vegetation. I fixed this issue by disabling Catalyst AI but this resulted in no sound. Funny thing is that with the no sound setting the performance and everything is awesome.

Is there not a way to resolve this so that i can have the awesome performane and sound?

My System SpecsSystem Spec
.

12 Nov 2009   #2

Windows 8.1 Pro
 
 

The white dots issue has been around for sometime with the cats drivers. Don't know about Nvidia as i've never owned one of their cards.

You might want to have a look around here CATALYST Drivers - Rage3D Discussion Area I'm pretty sure you can find a solution or answer to your problem.

Not that we can't help you here, but they specialize in ATI...like we specialize in Windows 7 here
My System SpecsSystem Spec
12 Nov 2009   #3

Win7 Pro (6.1, build 7600)
 
 

Thanks! I'll check out the link! N e one with my system specs having this issue/resolved it?
My System SpecsSystem Spec
.


12 Nov 2009   #4

Windows 7 Ulitimate Beta 32 Bit, Windows Vista 32 Bit, Ubuntu 9.10 32 Bit
 
 

hm..... don't have crysis.... but if you either update or rollback the driver that should help....
My System SpecsSystem Spec
12 Nov 2009   #5

 
 

Quote   Quote: Originally Posted by chiefboo View Post
O I fixed this issue by disabling Catalyst AI but this resulted in no sound.
Disabling Cat AI also disables driver optimizations - it's essentially the same as disabling crossfire.

As for the sound, are you using the HDMI output?
My System SpecsSystem Spec
13 Nov 2009   #6

Win7 Pro (6.1, build 7600)
 
 

I am. Sound doesn't work for Crysis but it does for everything else. My audio settings are correctly set for audio unless there is a setting for how games use audio device...?

Also thanks for clearing up the relationship between crossfire and Cat AI. People kept saying that disabling one is disabling the other... but its actually disabling the AI disable the optimal settings for crossfire? Whenever i disabled AI i was always wondering why it still had Crossfire enabled. It's odd that the the white squares go away with the optiminal settings.. guess the optiminal settings aren't as optimal as they should be..

Thanks for the posts. I checked out that site and they talked about various adjustments to the AA in CCC and in game. I tried out everything and nothing worked. In fact some of teh settings i tried made it worst and made my computer crash.

I ended up uninstalled CCC drivers and such and reinstalling with 9.10 suite downloaded from the website. Now crysis won't even start and bioshock won't start either. When bioshock does start it is when i've removed the bioshock folder from 'my Documents' and my desktop resolution is set at 1280x720. Bioshock defaults to some other resolution and when i try to set it to 1280x720 i get a system crash and the machine reboots itself.

please help...? lol
My System SpecsSystem Spec
13 Nov 2009   #7

Win7 Pro (6.1, build 7600)
 
 

ok i got bioshock working. but still no progress with crysis. maybe thats what they meant by the title... they hype up a game then have so many issues with it that solving issues is part of finishing the game itself?
My System SpecsSystem Spec
13 Nov 2009   #8

Windows 7 x64 (Ultimate)
 
 

All I can say is, make sure you have the latest patch for the game, update your Sound & Video drivers if you haven't. If you did it before installing the game, I have found that sometimes, installing a game corrupts my drivers somehow so I just uninstall and install fresh drivers and I am usually up and running.

I have only used Nvidia products so I am not sure on the problems with ATI.

I have a friend that has an old sound card with old drivers and he is not even able to play crisys because of the horrible thumping sounds the game makes. He doesn't have a problem with anything else, hence, why I am leaning to a driver issue on your end.
My System SpecsSystem Spec
14 Nov 2009   #9

Win7 Pro (6.1, build 7600)
 
 

ok. i had problems installing the patches. i'm guessing it was because i got crysis via digital download from gamestop. i actually went out and got a copy of the maximium edition and installed it along with the patches. still the same issue. here is a screen shot of exactly what i'm having to deal with...

[ame="http://www.flickr.com/photos/chihbu/4101710967/"]Photo0087 on Flickr - Photo Sharing![/ame]
My System SpecsSystem Spec
21 Nov 2009   #10

windows 7 32-Bit Alienware Edition
 
 

Crysis works on Windows 7 32bit //// Cf not working on 32bit works well on 64 ( i saw and heard it once of my friend on xfire ) he deleted gameguard.des file and let the game patch up and it workd for him
My System SpecsSystem Spec
Reply

 Crossfire & Crysis





Thread Tools



Similar help and support threads for2: Crossfire & Crysis
Thread Forum
Solved Crysis VS Crysis Warhead? Gaming
Crysis 2 ... anybody got it yet? Gaming
Crysis 2 Gaming
Crysis and HD5870 Crossfire Issues - Upgrade to gtx 580?? Graphic Cards
Crossfire HD5870s and Crysis Warhead - Huge FPS Drops? Graphic Cards
Crysis W7 64 Bit Gaming
Crysis Gaming

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:08 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33