Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Arkham Asylum wont install


14 Nov 2009   #1

Windows 7 Home Premium 64 bit
 
 
Arkham Asylum wont install

Hi Folks.

Today I got Batman Arkham Asylum and tried to install it.
I had previously had the free demo installed and I just went ahead and put the disk in and clicked autorun.
The installation seemed to run smoothly but I couldn't access the game even though it was there in my start menu etc it wouldn't run. All I got was a square splash box with install at the bottom greyed out and run game or setup would not work.
I figured it might be one of two things: the pre release demo or pctools firewall.
I used RevoUninstaller to get rid of the demo and all of it's traces, restarted and disabled pctools firewall.
Then I tried again and this time I got an error box saying "wxmsw28u_core_vc_custom.dll." is missing and advising re-installing the program.

I've tried this several times and I'm not succeeding. Also the empty shells of both the game appear in My Games.
I'm stuck here. Anyone know what I've done wrong?

John

ps. I'm on Windows 7 HP x64

My System SpecsSystem Spec
.

14 Nov 2009   #2

Windows 7 Home Premium 64 bit
 
 

I just looked at the compatibility list and Batman is there as x86.
Does this mean I've bought a game that I can't play?
My System SpecsSystem Spec
14 Nov 2009   #3

Windows 7 Professional (x64)
 
 

I have Batman Arkham Asylum installed on Windows 7 x64 working perfectly so it's not your Windows version. Anyone else?
My System SpecsSystem Spec
.


14 Nov 2009   #4

Windows 7 Home Premium 64 bit
 
 

Thanks Hugh. I didn't think that could be the case as the demo worked perfectly.
I really wanted to be The Batman this weekend
My System SpecsSystem Spec
14 Nov 2009   #5

Windows 7 Professional (x64)
 
 

Are you saying that you previously installed the demo which may have messed up your registry? Then you went out and bought the retail version, and it's now not installing correctly?

From what it sounds like, RevoUninstaller definitely caused the issue by not completely removing the demo. Is it possible to reinstall the demo and simply use Windows uninstaller to remove? That's what I'd try to do.
My System SpecsSystem Spec
14 Nov 2009   #6

Windows7
 
 

I believe the wxmsw28u_core_vc_custom.dll is related to PhysX. If you haven't installed PhysX, you may need to do so even if you don't turn it on.

When the same problem has come up with other games, some have sometimes installed to folders that are different than the default and it's fixed whatever likely registry issue is occurring.

But whatever issue you're having, it's not Arkham Asylum not being compatible with Windows.
My System SpecsSystem Spec
14 Nov 2009   #7

Windows 7 Home Premium 64 bit
 
 

Poin2. You were right. Following my recent install of the retail copy of Windows 7 x64 I had neglected to re-install PhysX. I had assumed it would come with the latest drivers (195.39).
I have now installed PhysX but I'm afraid it hasn't solved my problem or made any difference.
If I try to install the game it acts like it's already installed but I get the same error as above if I try to launch it. I have also tried setup from within the program but with the same results.

Hugh. I am now trying your idea. I have found a download for the demo. Unfortunately it's going to take an hour and a half.
I'll then try to re-install that. It occurs to me that I shouldn't have to uninstall it. Surely this game can deal with it's own demo?

Anyway thank you both for your input. I'll let you know the outcome after I try with the demo. Probably tomorrow now, John

PS Any other input would be most welcome.J
My System SpecsSystem Spec
14 Nov 2009   #8

Windows 7 Home Premium 64 bit
 
 

Well I downloaded the demo and re-installed it. Then I got a "this program may not have installed properly..." so clicked re-install properly option.
This has got me no further forward. I've still got the square splash box with BM stood there. The install button is greyed out and if I click to play or setting I get "the specified file was not found" box.
So I can't install my brand new game and can no longer even play the demo.
This is really irritating
My System SpecsSystem Spec
15 Nov 2009   #9

Windows 7 Home Premium 64 bit
 
 

This is driving me nuts. Think I might go for a reformat and re install of 7.
Got this game won't install also google chrome won't display it's first page (I get error 300 this webpage is unavailable)
I've tried uninstalling chrome but it's the same each time I re install.
Also I've tried everything I can think of and Batman just won't work.
It'll be a pain in the **s to re install but I've got the feeling something isn't quite right.

John
My System SpecsSystem Spec
15 Nov 2009   #10

Windows 7 Professional (x64)
 
 

Sorry to hear about that. Hope someone else has some insight.

Is it possible to roll back to before you installed the Batman demo?
My System SpecsSystem Spec
Reply

 Arkham Asylum wont install




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:32 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33