Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: AOE 2 does not want to play on my W7

15 Nov 2009   #1

w7
 
 
AOE 2 does not want to play on my W7

Hi,

I got new computer, and wanted to have few games on it. I installed Civ 4 , no problem. AOE 2 shows only flash screen, and stops. Flash screen is gone, and like nothing happened. Tried another clean install, and it is same. Any ideas?


My System SpecsSystem Spec
.

15 Nov 2009   #2

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by igormis View Post
Hi,

I got new computer, and wanted to have few games on it. I installed Civ 4 , no problem. AOE 2 shows only flash screen, and stops. Flash screen is gone, and like nothing happened. Tried another clean install, and it is same. Any ideas?
Hi and welcome

Thanks for filling in your specs. Give us needed info.

Have you upgrade you video driver, and directx?

There are several places we can go to diagnose the problem

First type device manager in search. go to the display tab. Is your video listed? does it have a yellow triangle on it?

Are there any other "unknown" devices that have yellow on them?

Let us Know

Ken
My System SpecsSystem Spec
15 Nov 2009   #3

w7
 
 

If by video you mean Display adapters, than yes. and there are unknown devices(pci serila port, and pci simple communications sontroller). imaging devices (lexmark x422) has yellow triangle too.
My System SpecsSystem Spec
.


16 Nov 2009   #4

Windows 7 Ultimate x64
 
 

Try getting another copy of aoe2, mine is working fine on both windows 7 x32 and x64.
My System SpecsSystem Spec
16 Nov 2009   #5

Windows 7 Professional x64
 
 

you may have already tried what im about to say but if i was in your shoes i would:

check that all my drivers are up to date and the latest ones for Windows 7.

patch the game to latest version, i know this doesnt help on the Windows 7 funny colours problem but still, its worth doing.

Close all unneeded applications

run the game

if still black screen post back here so we know

if you do get into the game, you might want to track down the thread about AoE2 colours being weird, thats another problem then, but we know how to solve that one.
My System SpecsSystem Spec
16 Nov 2009   #6

w7
 
 

yeah, i updated everything, and game is brand new. still nothing.
My System SpecsSystem Spec
17 Nov 2009   #7

Windows 7 Home Premium x64
 
 

The same thing happened to me with the same screen resolution.

I solved it by running AOE2 in windowed mode using a modified dll.

Check out posts 27, 28 and 29 here: Age of Empires 2: AoC expansion
My System SpecsSystem Spec
Reply

 AOE 2 does not want to play on my W7




Thread Tools



Similar help and support threads for2: AOE 2 does not want to play on my W7
Thread Forum
some dvd's can't play on sony dvd player but they play on onida player Music, Pictures & Video
WMP can't play avi Music, Pictures & Video
"Play Selection" doesn't play all highlighted Music, Pictures & Video
Would you like to play some TF2? Gaming
Combat Arms wont play on 7077, did play on 7068 Gaming

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:53 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33