Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: FEAR and Rome: Total War on Windows 7 64bit (NIGHTMARE)

09 Dec 2009   #11

Windows 10 Pro

Quote   Quote: Originally Posted by Coolness View Post
uhh, was that sarcasm? And if not, youre welcome.
Uhh why would you think that was sarcasm? What does it say below my name?

Here to learn

Yes it's true...even I don't know it all

Again, thanks for the info.


My System SpecsSystem Spec
09 Dec 2009   #12

Win 7 pro 64-bit, Ubuntu 9.10 64-bit

^^ Peace man!
My System SpecsSystem Spec
14 Dec 2009   #13

Windows 7 x64 Ultimate

I have also a problem with rome total war and i thought of posting here instead of creating a new thread
I manage to run rtw normally. Everything works, except... whenever i try to press the "end tyrn" button the game instantly minimizes. I can come back in the game and do whatever i want as long i donn't press that button :P Any clue guys?
Thanx in advance!!!

EDIT: Solved i just reduced the resolution of the game from the highest :P
My System SpecsSystem Spec

28 Feb 2011   #14

Windows 7 Home Premium 64bit
Problems with Rome TW

Hey guys, I'm having the same kind of problem you had. I've tried everything and still the game tries to open and closes withou any message of error.

Can anyone help me please?

My System SpecsSystem Spec
27 Apr 2011   #15

Windows 7 Ultimate and Ubuntu 10.4

"OK try this Reinstall one of the games then defrag right click on the Icon on the desktop for the game:
Goto> Compatibility Tab. Under Compatibility mode put the last OS you had it working well on (example XP SP3) then check "Disable visual themes" And check "disable desktop composition". Also check " Run this program as an administrator". Some games for what ever reason have a problem with "Aero" and all the fancy "Bling" that 7 has"

I tried this and it worked - the game is a bit glitchy but its still playable - just remember to save regulary. thanks SomeITGuy - just one question: would this process work with any 'older gamer' say built for xp?
My System SpecsSystem Spec
08 Jun 2011   #16

Windows 7

Quote   Quote: Originally Posted by nqdp View Post
Here's how to get Rome TW to work.

Right-click your desktop and open the "screen resolution" menu. Now run Rome. There are still some display issues and it might crash, but I did manage to play a custom battle.

I'm running Rome with no expansions off a flash drive, and I have Win 7 Ultimate 64-bit.
You said with Rome there are some display issues and that it might crash. What exactly do you mean by display issues. Below is a message I posted in another thread on this site, read it and tell me if you're having the same problem and if its constant and if there's anything I can do about it.

Hi, I installed Rome: Total War and the Barbarian Invasion expansion. It installed no problems at all and I was able to start up the game just fine. But when I'm playing the game (tutorial/campaign) the guide (the person giving me advice in the game) will start like repeating itself and getting kinda like glitchy and skippy like they'll say something like "The Barbarians are attacking-attack-atta-attacking, send your archers, send your arch-archers now" and the same type of thing will happen with the combat too. I don't know which of the audio and video settings to adjust. Is it a problem with with Windows 7 maybe or what might be causing this? I know its an old game, but something obviously tells me that its clearly not supposed to be like this. My laptop is only 2 years old too and I'm running windows 7 so something tells me that I should be able to run this game on the highest settings, but obviously not. Can someone please help me out because this is REALLY ruining the fun in the game for me. Also when am I allowed to save in the game, lol? If you are going to reply to me, I would appreciate it if you sent me a private message too because I kinda just stumbled onto these forums. Thanks in advance.
My System SpecsSystem Spec

 FEAR and Rome: Total War on Windows 7 64bit (NIGHTMARE)

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Language Pack Installation a total nightmare on Windows 7
... just like File Transfer and Explorer crashing constantly! Been the whole day trying to get the Spanish Language pack installed ion this my wife's Windows machine, should have bought her a mac - I knew Windows was asking for trouble! What I have tried so far: 1) downloading a .Net...
Installation & Setup
BSOD after Total War Rome II install
My son installed this newly bought game on his laptop. He leaves for college in 2 days and it has significant problems. He says that he actually played the game for a bit, left the laptop in standby mode for a few hours, and came back to the BSOD. This is not a new machine (he is going to be a...
BSOD Help and Support
Rome total war problem
ok i tried to install Rome Total war on my Windows 7 laptop it seemed to install but when i tried to run it nothing hapened : no error messages or any thing so i tried to run it as administrator and i got an error message saying that the start up file was missing so i checked the program files and...
Trouble with Rome Total War
Hi guys, sorry if there's already a post regarding this game but I cba to search the forum. Basically I installed the game but when I click on the .exe program files, the game loads but then immeadiately takes me back to desktop. I have the most recent drivers for my graphics card, etc and I am...
Rome: Total War - Windows 7
Greetings, I am running Windows 7 Enterprise, 32bit, on a Lenovo SL410 laptop with 2GB of RAM. I have this for a processor: Intel(R) Core(TM)2 Duo CPU T6570 @ 2.10GHz, 2101 Mhz, 2 Core(s), 2 Logical Processor(s). I have this as a graphics card: Mobile Intel(R) 4 Series Express Chipset Family....
rome total war problems
hi ive brought rome total war and it seems install ok,but when i try to play it a box comes up saying i dont have permission .i have changed the compatibilty but it still isnt working. thanks ianbud:confused:

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:12.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App