Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Europa Universalis 3


08 Dec 2009   #1

Windows 7 Ultimate 64 Bit
 
 
Europa Universalis 3

I recently picked up the Complete version of EU3, and it installed fine. The loader launches fine, and I even get to the menu screen with no problems.

I then went to the tutorial, and tried to run that and it seemingly freezes the game on an "Adapting history..." loading screen. Granted, it could just be an abnormally long load time (I got impatient after about 10 minutes), but it seems like this shouldn't be happening.

Victoria Revolutions (another game by the same company in the same style) runs just fine, so any advice would be helpful.

Thanks.


My System SpecsSystem Spec
.

08 Dec 2009   #2

Windows 7 Ultimate 64 Bit
 
 

After a bit of fiddling around, I figured out that it was a corrupted patch file. I did a clean reinstall from the disc, redownloaded the patch, installed that, and now it loads up fine in ~5 seconds.
My System SpecsSystem Spec
09 Dec 2009   #3

Win 7 pro 64-bit, Ubuntu 9.10 64-bit
 
 

Good, now mark it as solved please?
My System SpecsSystem Spec
.


Reply

 Europa Universalis 3




Thread Tools



Similar help and support threads for2: Europa Universalis 3
Thread Forum
Europa Universalis III start-up problem Gaming

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:46 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33