Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Games that Worked ok for me

30 Dec 2009   #1
dorian hawkmoon

Windows 7 Ultimate (x64) SP1
Games that Worked ok for me

Games that Worked ok for me:

1) NFS MW (1.3)

2) NFS Carbon (1.4)

3) Psi-Ops

4) Mass Effect

5) Sin Episodes Emergence

6) MOH: Airborne [Had to uninstall PhysX driver beforehand, because it causes conflicts with the older one that the game installs, and you will want to start the Win firewall service if it's not started ]

7) Warfront

Will install Arkham Asylum, POP (2008) next. Hope it goes well.

My System SpecsSystem Spec
31 Dec 2009   #2

Win 7 pro 64-bit, Ubuntu 9.10 64-bit

My System SpecsSystem Spec

 Games that Worked ok for me

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Autocad worked Ok in XP why not in W7?
I've been using AutoCad 2004 in Wxp for years. But it wont work in W7. I've tried installing Oracle virtual box but it still wont run. I'm at the end of what I know can anyone help. Thanks
Running a software twice that worked on XP before
Hello everyone, I know this topic is all over the net and I have been googling my brainz out but haven't found something useful yet. As the titel says I have a software (a messenger for textbased RPGs similar to Skype, so it is nothing illegal) I want to run twice. Before I had Windows...
USB ports worked in XP not in 7
Hi, Hope you don't mind me asking this question as it is still a puzzle to me. I have built all of the PCs currently in use - one that my youngest has access to has an MSI Motherboard in it (sorry haven't got the mobo manual to hand at the moment. Purchased an upgrade from Windows XP Pro to...
Hardware & Devices
64-bit worked before System Recovery
Hello, So I decided to do a system recovery on my laptop. I had Windows Ultimate x64 previously installed and everything worked. I did a system recovery and it took me back to vista. I think, "No problem. Let's go dig out your old 64-bit Windows 7 disc from storage and get this show on the road...
Installation & Setup
Win 7 Ult 64 Audio worked, and now it doesn't?
Hello everyone, first post here. I am a college student with a computer that I built myself. I currently run a Gigabyte EP45T-UD3LR MoBo which has the capability to run 5.1 surround sound (maybe better?) and has some other neat things that I enjoy. I installed Windows 7 Ultimate x64 a month or...
Sound & Audio
No Sound Now - Worked in 7 Beta
I have a Compaq Presario that I have been running the Beta on since it was released to the general public. I just did a clean install of 7 RC and now, the sound does not work. It seems to have picked up the latest driver. In the Beta, I had to do an update driver from the device manager...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:36.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App