Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Empire Total Crash

08 Feb 2010   #1

Windows 7 Home Premium 64 bit. (OEM)
Empire Total Crash

Hi all, my first post on the 7 forum is a tricky one - I've just finished my first PC build last week with Windows 7 (OEM) 64 bit running smoothly with specs as follows - Asus P5Q Deluxe (BIOS 2301), Q9550, Noctua NH U12P SE2, Corsair HX850, 2X2Gb OCZ PC2-8500 Reaper, Sapphire HD5850, WD 640Gb 32Mb cache, Sony Optiarc AD-7241S.
Everything seemed to be working with Empire Total War, until that is, when I flashed the latest BIOS from Asus (2301) using AsusUpdate. Now when the game begins and is still in campaign mode, the entire system crashes to close, Autostarts with message 'Windows did not close properly last time' and offers to start in safe mode.
Has anyone had a similar problem, any advice is appreciated. BTW games like BF2 are ok, desktop is fine inc. browsing - No OCing done yet . . .

My System SpecsSystem Spec
08 Feb 2010   #2

Windows 7, 64-bit

Hey mate,
Like you said before, I think my situation is completely different. I just bought new RAM coz i beleive that I don't have enough to run Windows 7 (64bit) with Empire Total War. But you have 4GB anyway so I'm sure you have a different problem.

Only suggestion I have for you is to make sure all your drivers are up to date with that BIOS update.

Hope you get it fixed man.

My System SpecsSystem Spec

 Empire Total Crash

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Empire Total War, can you run it?
Hello everyone! excelent forum. I have a problem with Empire Total War: I have this computer: AMD X2 6000+ 2gb ram nvidia 8600gts Windows 7 build 7057 I can't run Empire Total War full version.I've tried with compatibility modes and "run as administrator", I reinstalled directx and I...
All help welcome - empire total war
Game was working find up till yesterday. Over night downloaded a set of Windows 7 updates (security etc) and no game hangs at intro screen. I have updated my drivers but still having the same problem. All help gratefully received. I have looked at the other Empire threads on the forum and...
Installing Empire Total War (Steam-game) - ERROR 1935
So each time i try to install the game i get a the "error 1935" message. Could someone help me out step-by-step, as I'm really not into PC's ... Thx in advance Btw, i only found hard-to-understand windows Vista troubleshooters on the net for this error, but I'm running WIndows 7. Thx in...
Empire Total War still reboots PC
Hey guys, I posted this thread before, Sadly, it is still happening. After getting an extra 4GB of Kingston Ram and updating all my drivers, the game still crashes. It is getting really fustrating...really. Never...
Empire Total War - rebooting PC
G'day, thanks for taking the time to read my thread. I just recently upgraded from Windows XP 32bit to Windows 7, 64bit. My computer specs are: 2GB Gskill 800mhz RAM Gigabyte MA790X-DS4 motherboard Leadtek 8800GT AMD AM2 Athlon 4800+ dual core
Empire total war problem
I have the empire total war on my system (Windows ixtreme M3720) but when i play it the game's frame rate slows and 'jumps'. Can you please tell me how i could fix this problem. Thanks

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 16:21.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App