Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Can't Run Half Life 2

02 Apr 2009   #1
wrathloki

Windows 7
 
 
Can't Run Half Life 2

So for some reason whenever I start Half Life 2 it just goes to a black screen and I see the round blue windows loading mouse icon. Left 4 Dead and Team Fortress 2 work perfectly fine also, which is odd. I've tried SP2 compatibility, disabling windows composition, visual themes, run as administrator, -32bit in the launch options in steam and nothing works. What could be going on?

Edit: Counter Strike Source works perfectly fine as well.


My System SpecsSystem Spec
.
03 Apr 2009   #2
Bladerunner

Win 7 x64
 
 

No idea what could be the problem.
But if all else fails you could try to delete the local content for HL2 and redownload and see if that fixes it.
My System SpecsSystem Spec
03 Apr 2009   #3
Coldout

Windows 7
 
 

You could try the adding the -dx9 too, no idea if it will help, just an dea.
My System SpecsSystem Spec
.

03 Apr 2009   #4
wrathloki

Windows 7
 
 

Tried deleting local content and redownloaded, no luck. Tried every possible operator for game launch options, nothing. This doesn't make any sense, every game that uses the Half Life 2 engine works perfectly except for the game itself...
My System SpecsSystem Spec
22 May 2009   #5
Crucible

Windows 7 RC
 
 
Fixed?

Hate to bump an old thread, but I'm having the same problem right now with only Half-Life 2 and no other Source games. It changes the resolution to 1024x768 since I haven't changed the game settings for my native resolution yet, and just sits there with the rotating icon and a black screen. When I open task manager and end hl2.exe, my mouse goes back to a regular pointer, centers in the screen, and my entire machine becomes unresponsive until a hard reboot.

Anybody found a fix for this yet?
My System SpecsSystem Spec
23 May 2009   #6
wrathloki

Windows 7
 
 

Hmm, are you running RC1 yet? I installed RC1 and now I have no problems with Half Life 2.
My System SpecsSystem Spec
23 Jun 2009   #7
Volund

 

Did anyone actually find a solution to this? I'm running build 7100, and I get the exact same issue as the OP, black screen with the windows loading circle going round and round. I have to go to task manager and end the task, the game lists itself as not responding.
My System SpecsSystem Spec
05 Jul 2009   #8
shadowbladex

Windows 7 RC1
 
 
Possible fix

Hello all.... I was having the same problem and came across this forum post. I was also reading another forum and someone posted something that worked for me.

Try simply waiting in all honesty. My game would show as not responding in the task manager so I kept closing it every time. However, I took his advice and waited ... and waited some more. It took about 3-5 minutes without touching anything else on the pc and it loaded up! Now it loads up instantly every time afterwards. I don't know if it just had to detect something or install something else in the background. Not sure, but it definitely does work now!
My System SpecsSystem Spec
05 Jul 2009   #9
SeVeNrOxS

Windows 7 RTM x86
 
 

Same issues with me.When I create my server and wait for some time then game begins.But when I connect some one else server and wait,it doesn't respond even after 5 min.


Hope it should be fine with RTM.

Welcome to sevenforums shadowbladex
My System SpecsSystem Spec
05 Jul 2009   #10
Volund

 

Quote   Quote: Originally Posted by shadowbladex View Post
Hello all.... I was having the same problem and came across this forum post. I was also reading another forum and someone posted something that worked for me.

Try simply waiting in all honesty. My game would show as not responding in the task manager so I kept closing it every time. However, I took his advice and waited ... and waited some more. It took about 3-5 minutes without touching anything else on the pc and it loaded up! Now it loads up instantly every time afterwards. I don't know if it just had to detect something or install something else in the background. Not sure, but it definitely does work now!
you rock m8 thanks a lot, it works perfect now
My System SpecsSystem Spec
Reply

 Can't Run Half Life 2




Thread Tools




Similar help and support threads
Thread Forum
can someone help me with my HALF LIFE 2 graphic??
Hi, been playing Half Life 2, found out some weird graphic glitches, i have tried using steam, and not using steam, so I can conclude that it ain't a steam problem, anyway, the first problem occurred in "the red letter day", all models have that light blue shading on them even at close proximity, i...
Gaming
Half Life 2: Episode 2
So hey guys i'm just wondering if I can run this game on DX 8.1 Mode because I was able to run CS Source on the same mode since both of them can run in my old pc with Intel GMA 3100?
Gaming
Half Life 2 on 7
Just installed HL-2 and Steam did an additional update. On first-run, it generates an error and won't boot. http://i177.photobucket.com/albums/w.../HL2_Error.jpg I'm running Windows 7 x64 build 7201. Here's what I've tried: 1 - Direct launch from Steam. 2 - Desktop shortcut, 'Run as...
Gaming
Half Life 2 Might Never Get Episode 3
Acknowledging that Half-Life games tend to take a bit too long to come out, Valve came up with the neat idea of episodic content for the game, releasing HL2: Episode 1 two years after the original HL2 in 2006, and in 2007, HL2: Episode 2. The idea behind this concept was to deliver the...
Gaming
Half-Life 2
I did not have these problems on Vista. 1. When I run steam, i open half-life 2 (its the only game atm that I installed). I see a black screen where the VALVE and SOURCE logo should be. I also hear the sound that plays as the logos are shown, but I only see black. I see no creepy valve logo...
Gaming
half life
hello I have windows 7 ultimate (build 7100) and i have problem with half life (want to play counter strike 1.6) and after few minutes game is turning off, strange becouse on windows vista everything was ok. "luncher has stopped working" someone have the same problem ? help.
Gaming


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:09.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App