Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Civ4

12 Apr 2009   #1

Windows 7 Build 7229 x64
 
 
Civ4

Anyone else notice that 7 turns off Aero when running Civ4? This has happened with 7000, '68, and '77, all x86. Not sure if it's the same with other versions. The game runs the same as it did before...nothing's changed other than the loading time between turns on big maps being faster.

I just found it odd considering Vista didn't do this.



Attached Images
 
My System SpecsSystem Spec
.

28 Apr 2009   #2

Windows 7 x64 build 7100
 
 

Not happening to me with Civ4 BTS on the 64bit Windows 7 version.

It really does load faster as you noted. But then I also upgraded to an i7 processor over the old Vista system.
My System SpecsSystem Spec
02 May 2009   #3

Windows 7 Build 7229 x64
 
 

What build are you using?


I can't even get past the first turn in 7100 x64 on BTS. Still having it turn off Aero, though I noticed it didn't do this for the normal Civ4.


Edit: I updated to 1.17 and it's working fine now. The issue with Aero is still there, though.
My System SpecsSystem Spec
.


03 May 2009   #4

Windows 7 x64 build 7100
 
 

Quote   Quote: Originally Posted by Azural View Post
What build are you using?


...
I was running 7000 when I wrote that, but am running 7100 now (the Technet download.) I did have it turn off Aero and set itself to low res with most animations, etc turned off the first time I ran it. I set it back to high res and turned back on the features, but it is still turning off Aero when I start it.

Other than that, no problems.
My System SpecsSystem Spec
04 May 2009   #5

Windows 7 Build 7229 x64
 
 

Yeah, it's been working great for me since I updated it to 1.17. It actually defaulted to the highest setting for everything but resolution when it installed. Odd that it didn't for you as you've definitely got the hardware to support the highest settings.
My System SpecsSystem Spec
04 May 2009   #6

 

Are you running the latest video card driver for your system?
What card are you running?
My System SpecsSystem Spec
05 May 2009   #7

Windows 7 Build 7229 x64
 
 

Moble Intel 965 Express...definitely not the greatest, but I don't have any trouble running Civ4 or it's expansions on the highest settings. I am using the latest driver.


It wouldn't bug me so much if I didn't tab out of games often.
My System SpecsSystem Spec
13 May 2009   #8

Windows 7 64-bit (7127) & Mac OS X 10.5.7
 
 

I noticed this happening too with Beyond the Sword 3.17 (Civ4 and Civ4:Warlords have both latest patches installed as well).
My System SpecsSystem Spec
04 Sep 2009   #9

Windows 7 Ultimate
 
 

I cannot even get Civ4 to install. I have Windows 7 ultimate x64 build 7600 with a new machine. nVidia, recent driver. I right click the setup.exe file and run as admin and get this:

Error Code: -5009 : 0x8002802b
Error Information:
>Ctor\ObjectWrapper.cpp (163)
>Ctor\ObjectWrapper.cpp (391)
>Kernel\Component.cpp (1163)
>Ctor\ObjectWrapper.cpp (34)
>Ctor\DriverWrapper.cpp (31)
>Kernel\Component.cpp (1152)
>Kernel\CABFile.cpp (384)
>SetupDLL\SetupDLL.cpp (1526)
PAPP:Sid Meier's Civilization 4
PVENDOR:Firaxis Games (##IDS_PRODUCT_URL##)
PGUID:CFBCE791-2D53-4FCE-B3FB-D6E01F4112E8
$11.0.0.28844
@Windows 98 (67766446) BT_OTH
My System SpecsSystem Spec
22 Jan 2010   #10

wndows 7 Retail 32bit
 
 
You need a good Video Card

you need a good video card with 64Mb and be running ultimate Eddition for Areo to work.
My System SpecsSystem Spec
Reply

 Civ4




Thread Tools



Similar help and support threads for2: Civ4
Thread Forum
civ4 stability? Gaming

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:59 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33