Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Age of Empires 2 no longer compatible?

28 Mar 2010   #1
lordtemplar

Windows 7 Home Premium 64 Bit
 
 
Age of Empires 2 no longer compatible?

I've been searching google for the last few hours and have come up with nothing as to why AOE2 no longer works with windows.

Here's what happens.

My friends and I select TCP/IP (the non-LAN one) and I host. My friends can see my game but when they try to connect, it always gives them an "Unable to join game". When they try to host, same result. I know my ports are forwarded, I've got the DMZ set to my computer. My firewall is off. Why can't I connect to my friends?

From my research it seems to be exclusive to Windows 7. Windows XP machines can play the game(lost) between each other. One of my friends is using Windows XP, one of them is using Windows Vista and the other two are using Windows 7. We're all pissed that this game isn't working. Also, from my research every post I've read anywhere was never successfully answered. I intend to, hopefully, fix that with this thread.

Would it be best if I somehow call their tech support? It pisses me off that this old, great classic won't work with my computer, and it is still being sold in stores, but Ensemble Studios was disbanded!


My System SpecsSystem Spec
.

29 Mar 2010   #2
Jonathan_King

Windows 7 Professional x64
 
 

Welcome!

Try running the game in compatibility mode for XP.

Compatibility Mode
My System SpecsSystem Spec
29 Mar 2010   #3
Lanthus20

Windows 7 Ultimate 32 bit
 
 

Well I just tried and it works for me. Heres how to do it.

Run AOE II, once you get the main screen press CTRL-SHIFT-ESC
It should take you to task manager on your desktop. Go to processes and end explorer.exe for your user.
Once finished just exit the game and open task manager again. Go to applications, click new task, and type in explorer. Press enter and you'll have everything back.

This fixes the grass/water discoloration at least. If it won't run at all then I don't know.. works fine for me.

EDIT: Make a batch file that does this automatically!

Code:
taskkill /F /IM Explorer.exe
age2_x1.exe
Start explorer.exe
put that it in a text document, save it as all files with .bat at the end of the name. Example of mine

Age of Empires 2 no longer compatible?-aoe2-fix.png

Oh and make sure to save it into the directory your age2_x1.exe is. Then you can make a shortcut to it so you don't have to navigate there all the time!


My System SpecsSystem Spec
.


30 Mar 2010   #4
lordtemplar

Windows 7 Home Premium 64 Bit
 
 

Running in compatibility mode does not work.

Thanks for the fix for the graphics, but that doesn't fix the connection issue.
My System SpecsSystem Spec
30 Mar 2010   #5
KremmenUK

MSDN Home Premium
 
 

Quote   Quote: Originally Posted by Lanthus20 View Post
Well I just tried and it works for me. Heres how to do it.

Run AOE II, once you get the main screen press CTRL-SHIFT-ESC
It should take you to task manager on your desktop. Go to processes and end explorer.exe for your user.
Once finished just exit the game and open task manager again. Go to applications, click new task, and type in explorer. Press enter and you'll have everything back.

This fixes the grass/water discoloration at least. If it won't run at all then I don't know.. works fine for me.

EDIT: Make a batch file that does this automatically!

Code:
taskkill /F /IM Explorer.exe
age2_x1.exe
Start explorer.exe
put that it in a text document, save it as all files with .bat at the end of the name. Example of mine

Attachment 63726

Oh and make sure to save it into the directory your age2_x1.exe is. Then you can make a shortcut to it so you don't have to navigate there all the time!
Wouldn't it be nice if Microsoft fixed this properly so that their games ran on their OS properly
My System SpecsSystem Spec
30 Mar 2010   #6
Lanthus20

Windows 7 Ultimate 32 bit
 
 

Quote   Quote: Originally Posted by KremmenUK View Post
Quote   Quote: Originally Posted by Lanthus20 View Post
Well I just tried and it works for me. Heres how to do it.

Run AOE II, once you get the main screen press CTRL-SHIFT-ESC
It should take you to task manager on your desktop. Go to processes and end explorer.exe for your user.
Once finished just exit the game and open task manager again. Go to applications, click new task, and type in explorer. Press enter and you'll have everything back.

This fixes the grass/water discoloration at least. If it won't run at all then I don't know.. works fine for me.

EDIT: Make a batch file that does this automatically!

Code:
taskkill /F /IM Explorer.exe
age2_x1.exe
Start explorer.exe
put that it in a text document, save it as all files with .bat at the end of the name. Example of mine

Attachment 63726

Oh and make sure to save it into the directory your age2_x1.exe is. Then you can make a shortcut to it so you don't have to navigate there all the time!
Wouldn't it be nice if Microsoft fixed this properly so that their games ran on their OS properly
Well yah, But let's face it. The game's too old. I'm really upset about age of empires 3. It won't work and it's like a year or two old.
My System SpecsSystem Spec
30 Mar 2010   #7
Lanthus20

Windows 7 Ultimate 32 bit
 
 

On topic, LordTemplar, fill out your system specs.

Go to your start menu, all programs, accessories, system tools, then click system information. This will give you a bit of info, mostly the stuff we want to know like hardware. We don't really care what mouse your using but hey, fill it out!
My System SpecsSystem Spec
31 Mar 2010   #8
lordtemplar

Windows 7 Home Premium 64 Bit
 
 

Processor:
AMD Phenom(tm) II X4 810 Processor (4 CPUs), ~2.6GHz
Memory:
6144MB RAM
Hard Drive:
640 GB + 250 GB + 1 TB
Video Card:
ATI Radeon HD 4800 Series
Operating System:
Windows 7 Home Premium 64-bit
Motherboard:
GIGABYTE GA-MA770T-UD3P AM3 AMD 770 ATX AMD Motherboard
Computer Case:
Antec 300 Black Steel ATX Mid-tower

I also have a DVD+RW drive and a BD-R drive.
My System SpecsSystem Spec
31 Mar 2010   #9
Lanthus20

Windows 7 Ultimate 32 bit
 
 

Sweet! I don't see how you should have any problem, I have a similiar computer (in labtop form though) and it works on it. I know you video card at least should work.

Also go to your account settings and update your specs there. Sorry i couldn't help but it will help in future problems as they can just click "My system specs" and see them instead of you posting them everytime!
My System SpecsSystem Spec
03 Apr 2010   #10
dupnitzabg

Windows 7
 
 

Would this also work for Star Wars Pod Racer?
My System SpecsSystem Spec
Reply

 Age of Empires 2 no longer compatible?




Thread Tools





Similar help and support threads
Thread Forum
Windows is taking longer and longer to Boot?
ok so my laptop's a few years old. It came with Windows 7 Home Basic. it still has it. My question is that it take A LOT of time to boot. Heres what happens: 1. The starting windows doesn't take that long to disappear, im satisfied with it. 2. But the welcome screen, ugh, First it just...
Performance & Maintenance
Age of Empires II: The Conqueror
Hi I am wanting to play Age of Empires II: The Conqueror over lan with 4 computers. 2 vista and 2 win7. I have been playing Age of Empires II: The Conqueror online with Voobly but I want to play over LAN. Hope someone can help :cool:
Gaming
Age of empires
Can some please tell me if age of empires, will play using windows 7? Thanks, Sarah.
Gaming
Age of Empires II
Hi, I have a problem with Windows 7. I can play Age of Empires II, because the whole picture is green! The video is up to date,knows someone who is wrong? Thx
Gaming
my win 7 does not install Age of Empires!
I just bought Age of Empires (very cheap! Only 50 Saudi Riyal which is about 15 US Dollar) and I tried to install it in my win 7 machine however I got a message that Age Of Empires is not installing, press O.K. to exit! I am not sure why do i get this problem but i think this game is a...
Gaming
Age of Empires III! [ALL]
Hello, sorry. I have searched around the forum and I've found out that Age of Empires III does work on Windows 7 BUT I'm too newbie to understand. Can someone please tell me how to make it work? Actually, I'm just having some small issues rather than those extreme ones like whenever I play the...
Gaming

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:12.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App