Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Call of Duty Lan Server Kick Problem


05 Apr 2010   #1

Windows 7 Ultimate x64
 
 
Call of Duty Lan Server Kick Problem

Recently, my mates and I decided to start playing Call of Duty (the original one) over our own server again. We played this 5 years ago with no issues whatsoever, but now each time any of us try to join the server the game loads up the map then on the team selection screen kicks us off with the following message...

Server Disconnected - Unknown Soldier
Punkbuster kicked player 'Unknown Soldier'
(for 0 minutes) ... PB GUID AUTH: UNKN

We never had this issue before and we have done nothing different apart from all the players machines are now running Windows 7. The Server is being run on the same XP laptop. By the looks of the message above, it looks like a Punkbuster problem, but then I don't seem to have a problem with joining an online game just our own Server?!

Can anyone offer any help?


My System SpecsSystem Spec
.

05 Apr 2010   #2

W7 Ult. x64 | OS X
 
 

Yeah, it's definitely a Punkbuster problem. I'm not sure how it works on the server side, but on the client side there are two services that should be running PbstrA and B.exe. One updates PB and the other runs the service. Make sure that both services are running on the server. If that doesn't help, you can try reinstalling Punkbuster on the server. Although, that in itself is a pain.

EDIT: Apparently this was an issue back in 2005. If you update your version of punkbuster it should fix the problem. (Update it server and client side) Otherwise, you can use this workaround.

/rconaddress "server ip"
/rconpassword "rconpass"
/rcon pb_sv_guidRelax 1
My System SpecsSystem Spec
05 Apr 2010   #3

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by notsograymatter View Post
Yeah, it's definitely a Punkbuster problem. I'm not sure how it works on the server side, but on the client side there are two services that should be running PbstrA and B.exe. One updates PB and the other runs the service. Make sure that both services are running on the server. If that doesn't help, you can try reinstalling Punkbuster on the server. Although, that in itself is a pain.

EDIT: Apparently this was an issue back in 2005. If you update your version of punkbuster it should fix the problem. (Update it server and client side) Otherwise, you can use this workaround.

/rconaddress "server ip"
/rconpassword "rconpass"
/rcon pb_sv_guidRelax 1
Wow, thanks for the mega quick response mate. Nice one.
I have updated our server (laptop) and 2 of our clients to test it, and we are still getting the same problem. I want to use your suggested workaround, but I'm unsure what to do? Here is a portion of my cfg file I am using...

// General Settings
set scr_friendlyfire "2"
set sv_maxclients "12"
set sv_privateClients "6"
set sv_maxRate "15000"
set sv_minPing "0"
set sv_maxPing "0"
set sv_pure "1"
set logfile "1"
set g_log "games_mp.log"
set scr_killcam "1"
set scr_freelook "1"
set scr_spectateenemy "1"

Do I just add your workaround like so...

/rconaddress "server ip"
/rconpassword "rconpass"
/rcon pb_sv_guidRelax 1

or

rconaddress "server ip"
rconpassword "rconpass"
rcon pb_sv_guidRelax 1

Also, where 'server ip' is do I put in my router's ip instead?

Just tried the following which I found on another Site...

Brightness/gamma and PB problem.
It works under windows 7 by
Numbers 1-5 is the fix for PB kick.
Number 6 is the fix for brightness/Gamma problem.

1. Have PB updated.
2. Have pnk's .exe under C:\Windows to run as Administrator.
3. Have pnk's .exe under C:\Windows set to vista compatibility
4. Have pb services to interact with desktop, under services.msc.
5. Set your game to always run as administrator from its directory .exe Properties.
6. Set codmp.exe as xp/sp3 compatibility under its own properties.

This didn't sort it either!
All 3 machines that I am doing this on by the way are fresh installs.

Update:

Okay, managed to get up and running now by adding...

pb_sv_guidRelax 1

to the server .cfg file and following the steps above that I found on that other Site. Fingers crossed!

Incidentally, we never had any of these problems with the 1.4 update for Call of Duty, only when we used the 1.5 update.
My System SpecsSystem Spec
.


05 Apr 2010   #4

W7 Ult. x64 | OS X
 
 

Glad that the workaround fixed your problems. According to the posts I read, the problem was "fixed" by punkbuster via an update. It could be that a feature was causing the problem and since the original CoD is rarely played anymore, they added it back in. Either way, that line should help you, and you don't have to worry so much about security since you're running a LAN server. In fact, you could take punkbuster out of the equation if you wanted, given that you trust your friends not to cheat.
My System SpecsSystem Spec
05 Apr 2010   #5

Windows 7 ultimate X64
 
 

I have a question along those lines myself. I haved been fighting(no pun) with network hijackers, and all my cod player files are gone. Sucks, but whats worse, is the server I play on (Hounds of Hades) is no longer listed in the server directory. Is there a way to manally add it to the list? Or how do I get to the server? I do know the IP, though...
My System SpecsSystem Spec
05 Apr 2010   #6

W7 Ult. x64 | OS X
 
 

@ DreemWarrior, what version of CoD are you running?

If you don't want to wait, google "How to manually add a server to CoD #"
My System SpecsSystem Spec
07 Apr 2010   #7

Windows 7 ultimate X64
 
 

Quote   Quote: Originally Posted by notsograymatter View Post
@ DreemWarrior, what version of CoD are you running?

If you don't want to wait, google "How to manually add a server to CoD #"

Its COD4. After reinstallinf windows, I managed to save my profile(wodering if that was a good idea) and restored it. dont know much about the program and all its files, but there are file listed under\virtualstore\programfilesx86\ for COD with a servercache.dat file that says its a videocd file. Do you know if this is accurate?
Thanks
My System SpecsSystem Spec
Reply

 Call of Duty Lan Server Kick Problem




Thread Tools



Similar help and support threads for2: Call of Duty Lan Server Kick Problem
Thread Forum
Solved Call of duty 4 Sp and Mp problem ! Gaming
Call of Duty 2 problem Gaming
Call of duty 2 problem Gaming
Call of Duty Server in Windows XP Mode? Gaming
Call of Duty WaW Problem Gaming
Call of Duty 2 Problem BSOD Help and Support
Call of Duty 1 problem please help Gaming

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:23 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33