Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Need For Speed: High Stakes Problem

16 May 2010   #11


what about installing the game in an xp install in virtualbox and playing it that way?

My System SpecsSystem Spec
16 May 2010   #12


Quote   Quote: Originally Posted by Pusspa View Post
what about installing the game in an xp install in virtualbox and playing it that way?
that might work.. here
My System SpecsSystem Spec

 Need For Speed: High Stakes Problem

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Sleep problem on high speed RAMs
I've noticed this problem after my new RAM, which run on 2400mhz without any errors & problems. In short, when I click on "sleep" button PC goes in sleep, but when I hit "turn on" button computer just keeps restarting & monitor keeps just black until after 2nd attempt there is a message: "All...
Hardware & Devices
High download speed and signal, high ping in games, slow page loads
Recently, I reinstalled my Netgear wna3100 driver. Ever since then, I've been experiencing problems with high pings in games where I normally never had problems with. Pages load slowly even just the home page of Google. I've attached my ipconfig picture. Any help would be greatly appreciated. ...
Network & Sharing
High Speed Connection - Low Speed Download?
I have a 2Mb/s connection. At least that is what online speed test shows. But why are my downloads much lower? I mean less than 1Mb/s
Network & Sharing
high cpu fan speed
Hi, i have a asus p6t mobo, with a i7 920 cpu and a asus engtx 260 gpu. when i connect to a lcd monitor via a dvi cable the cpu fan is quiet but when i connect to a 42" lcd tv using the supplied dvi to hdmi plug the cpu fan runs faster and louder this is from a cold start in both instances.any...
Performance & Maintenance
HIGH speed USB hub running at FULL speed.H
after dealing with PCI usb hub. i went and got external usb hubs and yes it worked on windows 7, but only FULL speed, my cam went from fast to laggie, iphone connect to usb hub had a message " it can perform faster if connect to a high speed port" , i check under device manager and it says " the...
Hardware & Devices
Need for speed 2SE & NFS HIGH stakes:problem
old gamers recognizes these two well i guess. but in win seven. these two wont run. :( any help?:cry:

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:39.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App