Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Age of Empire 2 not working Win 7


03 Jul 2010   #1

64 bit
 
 
Age of Empire 2 not working Win 7

Age of Empires 2 The Age of Kings & Age of Empires 2 The conquerors expansion not working.

The game installs fine but when I go to play it I get a loading screen. The game never loads. The loading screen disappears and nothing. If I go to task menu it does not even show the game. I downloaded the latest DirectX (DirectX 9.0 Web setup) I also have turned off all boot start ups. Still nothing works! Now I go to Welcome ValuSoft, a division of THQ, Inc. Online Store as it says and follow the 1000 easy steps they give to fix this (enraged sarcasm). Yet it still don' work. Yet to top it off and find not a single email or contact on the site. hehehe yes I love it when they do this! Now I am here hoping someone can help me with this.


Dell Inspiron 19
Pentium(R) Dual-core CPU E5400 @ 7.70GHz 2.69
RAM: 4GB
OS:64-bit


My System SpecsSystem Spec
.

03 Jul 2010   #2

Microsoft Window 7 Professional 32 bit
 
 

Have you install the .Netframework 2 for the games?

Regard,
Tuan
My System SpecsSystem Spec
03 Jul 2010   #3

64 bit
 
 

I have .Netframework 4. Do I need to go back to #2?
Age of Empire 1 works fine on my computer.

Also I took a screen shot so you can see the screen I see before it disappears. And just for a little bit more info this is a store bought game not burned and its bran new.
My System SpecsSystem Spec
.


03 Jul 2010   #4

windows 7 home premuim x64
 
 

try changing the compatibility settings for the age of empires.exe.
1:right click on the shortcut

2:click "open file location"

3:right click on the .exe

4:click on the compatability tab

5:check the "run this program in compatability mode for:" box

6:make sure windows xp (doesnt matter wat service pack, i usualy do pack 2 just to be safe) is selected in the drop down box.

7:click apply and try running the .exe

hope it works
My System SpecsSystem Spec
Reply

 Age of Empire 2 not working Win 7




Thread Tools



Similar help and support threads for2: Age of Empire 2 not working Win 7
Thread Forum
Empire Total War, can you run it? Gaming
not able to run age of empire 3 in window 7 ultimate 32 bit Gaming
All help welcome - empire total war Gaming
Age of Empire 3 No Audio Sound & Audio
Empire Total Crash Gaming
Empire Total War - rebooting PC Gaming
Empire total war problem Gaming

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:16 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33