Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Mass Effect 2 Help please.


08 Jul 2010   #1

Windows 7 Ultimate 64bit
 
 
Mass Effect 2 Help please.

Sorry to post this again cause someone already posted it I think but the situation was explained by faulty RAM but my issue is different.

I got this awesome game Mass Effect 2 and got an FPS lag every 30 seconds or so.

Here are my PC Specs:

OS: Windows 7 Ultimate x64
Motherboard: MSI P6n Sli v2
CPU: Intel Core2 Duo E6750 2.66 Ghz
RAM: 4 GB (two 2GB sticks)
GFX: nVidia 8600 GT (Club 3D Edition)

I play with 1280x1024 resolution with highest details and only anisotropic filtering is 8x you may say that My PC is below requirements but I know its not my specs that cause the issue because I've already played this game for the first time with exact same options and with no lag at all. I just wanted to finish all side missions so started all over again. And that's when all the trouble began. Since then I had the same problems with almost every game.

Solutions I tried but didn't Help:
1) Running in compatibility mode for vista, vista sp1/sp2, XP sp2.
2) Running in Administrator mode.
3) Turning down Kaspersky Internet Security
4) Upgrading and downgrading drivers from 190.62 to 257.21 versions
5) Using RivaTuner to make my coolers spin at 100% (though this helped me with Prince of Persia: Forgotten Sands)

so anyone can tell me what is wrong? Please. cause every game has the exact same problems and I really enjoy PC gaming.

PS. It's my first post so if i messed ups smth don't be harsh


My System SpecsSystem Spec
.

08 Jul 2010   #2

Windows 7 Pro 64bit
 
 

Im surpised you can run it with that video card, with all the bells and whistles on. Have you checked to see what temps you are getting on your video card. Check them with Riva while the game is running. ALT-tab out when you get the lag.
My System SpecsSystem Spec
08 Jul 2010   #3

Windows 7 Ultimate 64bit
 
 

its Club 3D overclocked edition and it is faster and better than original 8600GT (and it costed me much more than original one for sure) and it used to be enough for me to play, but somehow it ain't no more. Temps are really high like 84-89 degrees. and Riva's fancontrol isn't enough this time it seems. but what I don't get is why the heck should I need Riva in first place, when I could play the game with no lag at all? what happened? did my coolers go down? I opened the box and they seem to spin normally with no annoying sound. Only thing is when I change spinning speed in Riva their pace doesn't seem to change.
My System SpecsSystem Spec
.


Reply

 Mass Effect 2 Help please.




Thread Tools



Similar help and support threads for2: Mass Effect 2 Help please.
Thread Forum
Solved Mass effect glitch??? Gaming
Mass Effect Gaming
mass effect 3 Gaming
mass effect problem Gaming
Mass Effect 1 Gaming
Mass Effect Gaming
Mass Effect on 6801 Gaming

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:47 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33