Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Another "Search" problem--Solved


30 Jul 2010   #1

Windows 7 Pro 64
 
 
Another "Search" problem--Solved

I had this problem, then found a solution, this note is just to vent a little, and perhaps save others a little irritation. This topic may be a little geeky probably not too useful for beginners.

The indexer or search or something (I suspect indexer) does not work in Junctions, until you push it a little--if you create a junction to a location, say to folder-X, that junction will for many purposes work as a substitute for folder-X. A glaring exception, is that the search on that junction will return zilch, nada, zip.

Why was I using junctions in the first place? I was testing life as a Standard User (in Vista etc was called a Limited User). It was easy to start up a Std Usr account, but I wanted access to my old documents, and, I did not want to have 2 copies of thousands of documents in my "real" account and in my "Standard User" account. Would be a version control nightmare.

I had found the Junction utility earlier
Junction v1.05
and found it promising, but was not sure where to use it. Now I had a use. I went to my original "Real" account, and gave my Standard User account access to my documents. Then
Code:
C:\Users\StandardUser> Junction Documents c:\users\RealUser\Documents
Now all my documents were accessible whichever account I was logged into. But search did not work in my Std Usr account. I fought this quite a while. At first I thought that it was a privilege issue, I deleted and rebuilt the index twice, still no search (at least, where I was always searching--somewhere in my data) Except that I did have one search result, after I edited one of the documents from the Std Usr account. The light came on, I realized it might be the junction problem, and I tested a few documents of negligeable importance, dragging them from c:\users\RealUser\Documents to C:\Users\StandardUser\Documents.

Note that the documents dont really move, the Junction (symbolic link, what ever you call it) is like a wormhole, for most purposes, the documents are already in both places, even thought there is only one copy of each document. Whatever, it worked, so I dragged a folder, it worked, then I dragged all my documents--Viola! All documents accessible from each account, and Search, as near as I can tell, is working fine. And working as a non-admin user is looking better all the time.

This forum is teriffic, and I have solved many problems just by lurking here. But now and then it is nice to solve one for myself.

My System SpecsSystem Spec
.

30 Jul 2010   #2

Windows 7 Home Premium (64-bit) *** Windows XP SP3 (32-bit), OSX 10.6
 
 

Quote   Quote: Originally Posted by periboob View Post
But now and then it is nice to solve one for myself.
I know the feeling... but if people had much better research skills, we'd be obsolete! Thanks for posting your solution and welcome to SevenForums

Cheers,

Walker
Windows Outreach Team
My System SpecsSystem Spec
Reply

 Another "Search" problem--Solved




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:09 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33