Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: 'access is denied' when saving a file

16 Aug 2010   #1

Windows 7 Home Premium (x64) (build 7600) English
 
 
'access is denied' when saving a file

Hi, I have an external HDD that contains data originaly created with a windows XP PC. When plugged into my Windows 7 PC, I cant seem to be able to save changes. E.g. if I dbl click on a .txt file to open it in notepad, make changes and then try to save it, notepad says 'access is denied'. Similarly for ultraEdit. If I launch UltraEdit selecting 'run as administrator' this solves the problem. But that doesnt help when opening files by dbl clicking on them.

Under file properties, I have checked the files does not have a read-only attribute, and the Administrators group has full-control. I have changed the file-ownership to me. I am configured as an Administrator rather than a Standard-user.

If I create a new file on this drive with the Windows 7 PC, I can save changes no bother.
I have compared the file properties for the 2 files and the only difference I can spot is that the newly created file has me listed under the Security tab; whereas the old file only has group names listed.

What have I missed please (other than turning off the UAC)?
(Or does anyone know how to launch a program 'as administrator' by right-mouse clicking over the file in Windows Explorer?)
Thanks.

My System SpecsSystem Spec
.

16 Aug 2010   #2

Systems 1 and 2: Windows 7 Enterprise x64, Win 8 Developer
 
 

Is the external hdd formatted as NTFS?
My System SpecsSystem Spec
16 Aug 2010   #3

Windows 8.1 Pro (x64)
 
 

Use your user name not your group for permissions.
Or use the "Everyone" account.
My System SpecsSystem Spec
.


16 Aug 2010   #4

Windows 7 Home Premium (x64) (build 7600) English
 
 

Lemur, Yes it NTFS. I've also tried it with another HDD (also formatted NTFS) and it has the same problem.
My System SpecsSystem Spec
16 Aug 2010   #5

MAC OS X v10.4.10
 
 

one of the following might be the issue:

you don't have ownership of the file (Security Policy) or you don't have permission to write to removeable storage (Group Policy) . . .
My System SpecsSystem Spec
16 Aug 2010   #6

Windows 7 Home Premium (x64) (build 7600) English
 
 

Thanks logicearth that worked. I selected the entire drive and ticked the 'full-control' box for the 'everyone' account. I can now edit and save files on the drive.
Thanks
My System SpecsSystem Spec
Reply

 'access is denied' when saving a file




Thread Tools



Similar help and support threads for2: 'access is denied' when saving a file
Thread Forum
Print to file: Access denied General Discussion
File - Access Denied Network & Sharing
Solved Access Denied when saving Dreamweaver CS3 files locally General Discussion
Solved Can't delete a file - Access is denied General Discussion
FSX CFG File Access Denied Gaming
Rar file 'folder access denied' General Discussion
Put file on desktop -> open file -> access denied? General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:12 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33